LG G5 boot into recovery show-stopper (maybe not understanding the manual)

Dear community,

I’m struggling entering the recovery of LG G5. Following the https://doc.e.foundation/devices/h850/install I flash TWRP by ‘5. Flash recovery onto your device:’ successfully. Now, the manual requires me to reboot into recovery.

I used the battery pull suggested by LG G5 /e/ flash problem - #4 by archje But I cannot enter the TWRP recovery mode. Any try adb reboot recovery lands either on “no command” (Android laying on it’s back) or LG Android recovery (single page questionnaire: Wipe data yes/no).

I would like to know clearer, what should I do between

 fastboot flash recovery twrp-x.x.x-x-h850.img


 adb reboot recovery

to enter TWRP recovery successfully.

fastboot reboot reboots the phone, but no recovery mode is entered.

Do I understand correctly that adb reboot recovery should be equivalent to waking up th phone by Volume Down + Power combination?

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone


After fastboot flash recovery twrp-x.x.x-x- reboot into recovery via hardware keys.
It’s absolute needed to boot into recovery after flashing twrp. If you will boot into system, TWRP will be gone and you have to flash new

1 Like

OK, I was not able to do so. I describe the steps:

  1. Being in Bootloader mode, just after flashing TWRP
  2. adb reboot recovery is not working (no devices/emulators found) – I understand that the phone is not prepared to receive adb command
  3. Volume Down + Power (nothing would happen holding them down for 20 so seconds)
  4. bootloader reboot sends the phone in reboot. (still holding buttons)
  5. LG logo appears
  6. release the Power button for a second (still holding Volume Down)
  7. push the Power button again
  8. “Factory data reset” appears [No(Exit)/Yes] (been here and done that, Android would be restored)

I did not get any other Recovery menu (with Backup, Wipe,…)

In bootloader mode only fastboot commands are working. adb commands are only working on booted device or in recovery

because you don’t restarted in recovery after flashing TWRP. Booting in system will remove TWRP.

On some devices it’s a pain to get in recovery with hardware keys. I doN’t know for sure which keys have to be pushed together. Normally it Power up and Power. On samsung is Volume up + Power + Home button. On my Samung I need 20 and more tries till I get it running.
On my OPO device I have to push Power and when OPO logo appears I have to push and hold volume down.

I think you should search he web, how to boot in recovery with hardware keys.

The Recovery is described on the e.foundation. In short, it is Volume Down + Power, 1 sec release of Power with LG logo on and pressing Power again.

So, I identified the issue on my side: I need to restart into the Recovery when being in Fastboot. There is no fastboot command for it, is there any?

In Fastboot, holding down the Volume Down and Power as described on https://doc.e.foundation/devices/h850/ does nothing for quite some time (I tried already for more than 1 minute).

Also, I cannot Power off, when being in Fastboot. Holding down the Power key (1 minute) does nothing. So there has to be a reboot

I even came up with a command not documented on the fastboot screen fastboot reboot-recovery with a success on the laptop CMD line:

Rebooting into recovery                            OKAY [  0.006s]
Finished. Total time: 0.008s

but with the phone booting into Android.

no, sorry. I miss it too

yes, this command is wrong. fastboot can only boot into system.

Hurray! I looking at the booting /e/ screen – which shall apparently take veryyyyyyyyyyyyyyyyyyyy long!!! (OK, it’s over in 5.5 minutes)

In short: I had to downgrade to Android 6 and then go through the whole process again. I intend to collect the links and hints I used on my way, but I’m excited now over my new pRecious…

Cool, congratulations. Enjoy eOS :+1::rainbow:

Hi, I promised to come back and report on the how-to. Recalling the issues I ran into, I have to admit I was impatient in step 8 of my earlier report. To others going through the /e/ install process on LG G5, further ref. as the installation manual, I suggest to do the following at 6. Now reboot into recovery to verify the installation.:

  • One should shut down the phone in order to boot into Recovery. There is no fastboot command or button yoga to achieve that. The only way to shut down I’ve found was pulling the battery as suggested by @archje in another post.
  • When phone is powered off, slide the battery in and follow the steps into Recovery in the installation manual. If unsuccessful, you have to try sliding in the battery at various times: before or after you placed your finger on Volume Down and Power. Sliding in the battery, triggers boot immediately.
  • Do not forget to slide in the battery completely, until the click sound – once in excitement, I didn’t and the battery was hanging out half-way. I was sweating when clicking it – the phone was running –Progress XX%– at the time. Half-way out, half-way brick?
  • Expect the Factory data reset and select Yes. There may be another Remove sth screen, before the actual TWRP Recovery screen.
  • The second step using adb reboot recovery in the install manual did not work for me. When booted and the adb command can be received by the phone, the TWRP has been already replaced by the original Recovery tool – that was my understanding.

Other issues I ran into:

  • In many cases I had to try connecting in MTP or PTP mode (alternating) to receive allow-connection request and be able to send adb command.

I went through a how-to-root video and they said in the video and the comments that it is crucial to downgrade to Android 6 in order to successfully enter TWRP Recovery. So, I went for a downgrade and it was a highway to hell. Here is a list of links that helped me to downgrade: