Messages issues: not syncing, not backing up, and texts going to wrong threads

The title explains my issues.

Last year when this happened, i tried resetting the messages cache, which works, but it removes my messages , so I have to backup first.
Since backup doesn’t work, I have to install a third party app.
Ok fine, but this time I tried syncing first and found out that I was syncing from a corrupt database or something because it immediately wiped all messages other than the most recent ones… Now if I sync, I’m concerned my backup will have the corrupted data…

Now after i updated to /e/19 2 weeks ago, i did have to call my provider and get them to fix the fact that my MMS and data were not working, but that was supposedly done last week… I’ll do so again, but these issues have been around for a while.

“Messages app needs work!”

@manoj, should this go to a different thread or section?

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

I looked into the backlog and tagged forum messages, though I know of the issue I couldn’t find an exact post on the /e/ side for the thread-index issue

Just go with qksms proper until the included Messages app is updated


So you don’t think it’s at all the database? I tried a third party backup, which has worked fine for years, but it didn’t catch the most recent messages when backing up (since last restore but after trying to sync erased them from messages)

Thanks for the qksms pointer; I’ll check it out!

I really don’t know the storage side of qksms. I think if you’re anything more than a normal user towards Messages - with applying message backups making you already a power user :slight_smile: - better use current qksms - and if issues still occur, then investigate. Maintainers like new bugs