Mi 11 Lite 5G Recovery issue

Solved it:
The most recent e-os build is still based on the LOS 19 version. Make sure you do not upgrade your device to andriod 13.

Yes! Althou eOS getting upgraded to 13, it is not yet. 13 will be coming in soon. Also keep in mind there is a list of devices that doesnt support downgrading from 13 to 12

Many will find this useful, please can you give a url for this list.

Hi, I started a new post at Recovery on Xiaomi 11 5G NE won't start. But I see now you had the same problem.
My Android version = 12 and MUI 13.0.8.
Can you tell me what yours was. Because when I trie to install LOS I have the same problem as with e/Os. I can’t get into recovery mode.


At which point in the process are you failing ?

The gist of my post was to make sure you download the appropriate files from the LOS repository. The link provided in the instructions of e/Os will point you to the most recent release of the LOS files. However, if LOS progresses to a new android version and e/Os does not there is a mismatch.

If nothing works you might want to flash miui again and repeat from a clean basis.

I followed the proces untill the step of flashing the recovery rom. After that step I got stuck in fastboot mode. Using the volume up and power button doesn’t work.
The problem with the versions is clear. I have to use LOS vs 19. Thats why I didn’t update the MUI version.

If you are using the appropriate LOS (19) files in the previous steps as well as in this step, then we might not have the same issue

I tried again using the LOS (19) files, and have still the same issue.
I tried later to use a TWRP version: https://unofficialtwrp.com/twrp-3-70-for-xiaomi-11-lite-5g-ne-lisa/ without the root procedure.
I can get into recovery-mode then, but got a error on the lisa e/os (zipfile)

I managed to install OrangeFox recovery, and it’s working fine.
The next step wil be to trie to install lisa e/os. I’ll keep you posted.

I am also trying to flash my “Lisa” After hours of trying I am able to start into Recovery Mode.
You need to use all the *.img from LOS 19. And your device must be still with Android 12! Otherwise you won’t be able to boot into Recovery mode. So far so good.

But now I got an error Message I won’t be able to fix by myself. (I guess):

After 47% of the installation process I get a Message that the Signature verification failed. If I press continue, it stops with the following error Message:
Package is for product lisa but expected lisa_global

Can someone help me out with this, please?

Best regards

It took a while form me to try and install e/OS.
(I had a holliday).
My recovery didn’t work anymore so I had to try again.
I found https://sourceforge.net/projects/lisa-builds/ and downloaded the dtbo-, vendor_boot- and boot-image.
Did a clean flash:

• fastboot flash dtbo dtbo.img
• fastboot flash vendor_boot vendor_boot.img
• adb reboot bootloader
• fastboot flash boot boot.img
• fastboot reboot recovery

With the Orangefox recovery working I followed the https://doc.e.foundation/devices/lisa/install from the step: “Format The device”.
When I installed e/OS it stopped also at 47% and I got the warning that the android version did’nt match. (I was on MUI 14)
But I could choose for ‘continue’ and at last got the ’ Total xfer: 1.00x’.
And now it’s working fine, and when I go to recovery I see the e-recovery.

1 Like

Nice to hear that I have a real chance to get it work. After a week try and error I almost gave it up.
What version of Orangefox do you use? I have v11.1_2. Do you have another, better or newer you could share?

So if I understand you right, in your 4. step (• fastboot flash boot boot.img) you use the *.img from Orangefox. And rest you downloaded from Sourceforge, as you wrote above.

I will try this out. Do you already have experience if this “installation” will survive OTA?

Best regards

Your question: Do you already have experience if this “installation” will survive OTA?
Answer: No I haven’t.
I will trie to share the files I used with you, but I prefer to do that private. I’ll send you a message.

with the img you sent me directly it worked like a charm. I still got the Message that the Signature Verification failed and that I am currently doing a downgrade, what is not supported. But after all it was booting - after weeks of try and error, thanks a lot!

What I was wondering: The order of the commands were totally different in you PM. Maybe that did the trick, I don’t know.

Now I am only waiting for the overdued Update to 1.13! Then we will see if OTA is working well. (Hopefully!!)

one more question to the expert. How long takes your flashed cellphone to startup?
Mine remains for around 30s with the Mi Logo.If the “e” appears it runs like a horse. Do you know this behaviour?

@Co_chise Yes, it’s the same by mine.

Update for: Mi 11 Lite 5G Recovery issue - #12 by aburg
This is how i did it (a little different from what’s in the reply in this topic linked to):

Clean flash (coming from a MIUI):
• Reboot to bootloader (fastboot)
• Connect phone to PC
• fastboot flash boot boot.img
• fastboot flash vendor_boot vendor_boot.img
• fastboot flash dtbo dtbo.img
• fastboot reboot recovery
• Select Wipe data/factory reset & confirm
• Go back and select Apply update from ADB
• adb sideload e-1.11-s-20230512288805-dev-lisa.zip

Co-chise added: I still got the Message that the Signature Verification failed and that I am currently doing a downgrade, what is not supported. But after all it was booting

1 Like

small Update: OTA works! Directly from 1.11 to 1.15 - until now no Issues

When did you get the update? My Mi 11 Lite 5G NE did’nt get an update.

Yesterday, Friday! Around at 11am suddenly appeared the Update.
It’s also listed on the Website now. I guess it’s a question of time. Can be that the Rollout is not for all on the same time? To not overload the Server?

I recieved him just now.