Missed calls and texts status?

I just had a similar situation to this thread, where I didn’t receive a call (luckily a voicemail was left), the call did not appear in missed calls (but T-Mobile’s visual voicemail app notified me), and a text message took around 40 minutes to arrive from the time it was texted.
I haven’t had many situations like this, but they have occurred before. Is this issue continuing to be looked at? I feel like this is the most privacy focused solution out there and the roadmap for 2021 has me very hopeful, but I can’t have situations where someone is trying to get in contact and can’t.

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

Anyone seen this at all? For the past two days, I’ve had people complain to me that their calls were going direct to voicemail rather than ringing. I’ve also had delayed text messages occur.
I utilize Mint Mobile as my cell service. Trouble shooting steps so far include turning off the Mint Mobile app’s Wifi Calls/Texts functionality. Unfortunately I really don’t know how to nail down what’s happening here.
I like /e/, I value my data privacy, and I’d say the S9 and S9+ are pretty perfect as far as hardware goes. But if my phone can’t be a phone all the time, it’s not worth it.

I have had the same experience with my Samsung S7 (SM-G930F) Android 7.1.2, Guava 7.
I have had a lot of callers say it goes right to voicemail. I also never see the number listed in my calling list. Sometimes my txt’s don’t show up for days. I had been blaming this on the T-Moble network. So how does one lookup if this build is having trouble on my S7? I have no idea which way to look except try a different phone with my sim and see if stops dropping calls.
I do like the way the OS is working but the call dropping has been a problem for awhile.
Anyone know what is going on?

The issue hadn’t presented for a few days, but happened again yesterday. I had a call go direct to voicemail (although to be honest, I’m kind of thankful it did), and then had six text messages show up on my phone after I sent one (almost as if the act of sending a message “woke up” my phone and allowed it to receive again). I’ve had similar experiences with restarting my phone - a message will immediately be delivered upon being powered back up.
Mint Mobile utilizes T-Mobile’s network, so it is of course possible that this is a T-Mobile problem, but I don’t recall it ever happening when I was an actual T-Mobile customer, leaving me to believe that the OS could be the culprit. I’ve set my phone so that the Phone and Messages app bypass both my VPN, Data Saver, and Battery Saver settings, and I’m running out of ideas.
I love my S9 and S9+, and am very happy with the concept of /e/, but if my phone can’t be a phone, I may have to make some sacrifices with regard to my privacy so that people can actually get in touch with me if I can’t get some support.

To help finding the root cause, I’ll try the following on a daily basis (let’s say, at breakfast time) :

  • activate, then deactivate airplane mode (can be added to power menu, but I don’t remember how)
  • in network settings, disable “automatic network”, let the device re-acquire networks, put it back to automatic if needed

Shouldn’t be too tough
What am I looking for as I do this?

If it works, it will only prove that your device is somehow “disconnected” from the network at some point.

Unfortunately it is always difficult to identify the origin of such problem :frowning:
It could be network provider, hardware, firmware, software …

To begin with digging into problem, you could compare output of *#*#4636#*#* (Phone information), before and after performing connection reset.

Alternatively, you could :

  • if your SIM is quite old, ask your network provider for a replacement (I know, it looks dumb. But it helped in some cases).
  • ensure your device has the latest Samsung firmware (preferably generic, not provider-specific).
  • ask Mint for detailed APN settings, check against your device.

Successfully in and out of Airplane Mode. It did take some time for a list of Network selections to be generated, but it was eventually, and I was able to manually select the T-Mobile network, as well as go back into Automatic.

To your other points:

  • My SIM is brand new, I only recently switched from proper T-Mobile to Mint

  • Both my devices have purchased from the eSolutions store have Android 8.1; I understand it’s possible to get to 10, but I believe you have to put the phone back on stock first in order to properly upgrade? I’m not sure I’m equipped to do that and I’d be afraid of bricking. Any progress on an easier method?

  • APN settings are a possibility as well, will look into that

Please repeat the network search over a few days, on a daily basis, and let us know if it helps.

As I remember, a user living near the border between two countries had a similar problem : phone was switching to a foreign network because of poor reception of his “home” network (the networks have roaming agreements, but foreign didn’t let him call or send SMS).
Problem was solved by disabling Automatic mode.
How is your signal strength ?

I’m not familiar with /e/ Samsung’s upgrade to 10 :frowning:
I know there are some threads here, but nothing very clear to me. Better write to support@e.email to get an official advice.
If both of your devices have the same problem, I’ll suggest to upgrade only one of them at a first step.
Also, I remember a user who had a similar problem to yours, apparently solved with an update…

I’ve had Automatic Network disabled for a few days now. Thought it was helping but unfortunately I did have another call go direct to Voicemail just now (luckily VM is quite quick on the draw, but if a message isn’t left I don’t get a missed call notification).
I will probably reach out to Mint tomorrow to see if I can run down a solution as I see some people have similar issues on their service (although none of my Mint family members have reported such an issue which is why I think OS could be the issue).
Hopefully I will have an easy way to upgrade to Android 10 soon, which as I understand it would allow for WiFi texts/calls and hopefully “solve” the issue.

Sorry that the “trick” didn’t help :frowning:

10 /e/ brings a lot of enhancements and bug fixes, let’s keep fingers crossed !

I have found some more info with regard to this problem:

This Reddit very much describes my problem almost exactly (right down to the time it occurs at). As a test, I didn’t turn WiFi on yesterday and didn’t observe the issue at all.
Obviously never using WiFi is not a solution to the problem so what I’m trying now is a setting in Developer Options that keeps Mobile Data on despite being connected to WiFi as well. I’m seeing if that helps, however I would hope soon I can easily upgrade to a version of /e/ with Wifi Calling and Texting (none of my family members observe this issue, I assume because they can utilize that feature).
I’ll keep anyone interested in the loop.

This sounds like a VoLTE issue to me. As in “lack of.”

1 Like

Agree 100%. As I said, hoping it becomes active in some form or fashion soon.