Murena / Teracube 2e rooting


These new phones have the A/B ‘seamless update’ setup, right? Where it’s got two copies of the system in two different areas? If so, how do we switch? Mine was on ‘b’.

Apparently, if the phone attempts to boot from one slot several times and fails, it’ll switch back to the other slot, so I’m going to keep it plugged into USB and let it cycle for awhile to see if that does it.

Very sad… Well, I tuned it back to read only as it was when realized it’s not doing what I need. then turned off debug mode and disconnected from PC. This way it works fine and I’m able to reboot.
Did you bring it back to read only before reboot? If yes, then it could be a different issue. With Pinephone I can boot secondary OS from SDCard, maybe there is a similar option for Teracube…

Yes, I did, then I booted into Recovery Mode to see if I could push build.prop from there… I couldn’t. On reboot, I got the boot loop.

Ok, it’s been stuck in a boot loop for more than 50 cycles, so if it was going to switch back to the A slot, it would have by now… looks like I’ll have to return it to get it repaired, unless I figure out a way of doing it.

Does it? As far as I know, all aGPS does is download satellite information from mobile base stations (to which my phone is already connected). It allows my phone to pinpoint my position quicker than waiting to get direct fixes from the GPS satellite themselves. Are you suggesting that, if my phone is using aGPS, it will then share that information with the mobile base stations? If so, can you give a citation, or any up-to-date evidence for that?

I’m not happy with Google doing it, which is why I use /e/OS, and why I don’t log in to a Google account on my phone.

The articles you link to are from 2013, since when EE has changed hands: in 2015 it is was acquired by UK’s BT from it’s previous owners Orange and Deutsche Telekom. The articles don’t mention anything about location data. The also don’t say that EE actualy did sell any user data, just that they were discussing it nine years ago. Their current privacy policy says

We’ll sometimes need to share information with third parties to perform services on our behalf or to provide services to you. For example, when you join EE we’ll need to complete a credit check and ask organisations such as Experian and Equifax to help us.

We may also share information with other companies within the BT Group who may help us to provide you with a service. For example, if you get access to the BT Sport app with your EE mobile plan, we’ll need to tell BT your telephone number so that they know you’re eligible to access the app.

Do yo have any evidence to suggest that they are lying when hey say that?

You haven’t given me any information or evidence to suggest that turning off aGPS will make any difference at all to how much I (or my phone) am subject to “constant surveillance”. Or that anyone is any more able to track my location and monetise it if I use aGPS than if I don’t.

I’m happy to consider evidence: all I have read so far from you is FUD

You’re not giving much details on what you did in between working and non-working state for guesses and I’m not a pro to help. Anyway did you try to press and hold volume+ button right after restart? - it should give you a fastboot and recovery options to play with.

Ok, so I did exactly as you did, in attempting to push build.prop. It didn’t work, so I reset read-only permissions just as you did, then rebooted into Recovery Mode from the power menu of the phone (press the power button, it pops up a menu, you press ‘Restart’, it offers the option to restart the system, restart into fastboot mode, or restart into Recovery mode… I think the settings for that are in Developer Options, IIRC) (on my old phone with TWRP, it’s easy to transfer files via TWRP)… I mounted the file system from the Recovery Mode Advanced Options menu, connected to the phone via adb and attempted adb push, that didn’t work, either, so I rebooted… and boot loop.

Now it won’t even give me the screen to use the volume buttons to navigate the little text menu… it stops at the initial screen, stays there about 5 seconds, then reboots, ad infinitum. I’ve tried the buttons in every combination, including Power + VolUp, no joy.

Here you will find a link to download TWRP for the terracube 2e

Thanks, Piero. After I get this bootloop issue resolved, that’s the first thing going on the phone.

Applause. Glad you get so much fun from trolling.

Thanks you for providing some evidence: that’s a step forward :slight_smile: From reading that, the server can ask for the client’s location. Do you have any evidence that my network provider, or any other network provider, uses or has used that functionality to track users “24/7”? Or is just used - as designed - in emergencies?

From the abstract, it seems that is is technically possible to use aGPS to track my phone’s location and movement within a building which has a rooftop antenna and an “Extended Kalman filter”. Are systems like these installed in many buildings, or is this just an academic paper discussing what is technically possible? Any evidence that Google, network providers, or anyone else is actually using such a system to track and monetise users’ location?

You can demand whatever you want :slight_smile: I spend a lot of time on this forum trying to help users of /e/OS, some of whom have less technical knowledge than me. When I see people - especially Usenet trolls from years back - suggesting that aGPS is actually used to “spy on you” , “to pinpoint your location 24/7” and “to track your every move and monetize it.” then I’m going to ask for evidence to back that up, so that people are not put off using a potentially useful function, because of unfounded fears about being spied on and tracked, and having their location sold. I’m still waiting for any such evidence.

So I will ask you to either retract your statements about aGPS being used to track users, or to give some evidence that it is actually so used. But I have enough experience of trolls to expect that won’t happen. And I’ve spent more than enough time feeding trolls this year (actually, in the last 2 days, since you joined the forum), so I’m going to say “goodbye” to you, and hit the “Ignore” button (which I assume you will count as me “melting down” and add another tick to your list of “melted kooks”). Have a nice life, and enjoy your new phone!

You’ll have to do your own research to prove yourself wrong, Pete. I’ll just sit back and point and laugh at your inept attempts at DYOFDW. LOL

Pete wrote:
“Do yo have any evidence to suggest that they are lying when hey say that?”

Well, they’re selling ads based upon… user information! Yes, that includes location, to target the ads.

Specifically, the phone’s location, with ads targeted via tracking location. Still think they have no incentive to track you 24/7? And that’s just for business… as totalitarian as our governments are becoming, I suspect they’re doing the same.

As to whether it’s “potentially useful” to have 911 know my location, with the ability for anyone with the right commands to remotely enable aGPS and track me… if I’m in an accident and unable to pick up the phone to call 911, then the phone company, 911 and every mobile advertiser out there knowing my phone’s location isn’t going to help me… they don’t even know I’m hurt.

If I’m in an accident but I’m able to pick up the phone to call 911, I can also pop up the GPS app and read off the GPS coordinates to the 911 operator, or cut-n-paste them into a text message and message the 911 operator.

The difference is in who controls that data… that data goes through me. I decide whether and how it is given out, not someone else with unknown ulterior motives. It’s all about choice and control.

I am sorry to but in but i am not techie and i did not understand from the above posts. Does /e/ has aGPS or not? And if yes does it send data to Google and under what conditions ? :slight_smile:

Thank you

Yes it does.

At the moment some devices appear to be using Google APIs (but this does not mean that you are being “spied on” and your location is “tracked 24/7”). This has been raised as an issue, which is being worked on by the /e/ development team.


Yes, all Android (and iPhone, and any other OS) phones have Assisted GPS (aGPS), and yes, they all send your exact GPS coordinates to the telephone carrier (and to Google if you’ve got Google on your phone).

IIRC, a study showed that iPhones phone-home ~53 times per day, whereas Android phones with Google phone-home an average of 11 times per hour.

1 Like

Ok, I recovered from my boot-loop. Had to totally wipe the phone, install the Teracube factory-install OS, then kludge up an install routine for /e/ OS, but I got it.

The only problem: I had to erase every bit of memory to get the install to take such that it wasn’t still in a boot-loop, so the IMEI numbers are erased.

No problem, I can fix that a couple of ways.

Here’s what I did:

Unzip it to a folder of your choosing.

Unplug USB
SP Flash > Format > Auto Format Flash > Format Whole Flash
Plug USB
Format completed successfully
Unplug USB
Remove phone battery
Wait 5 minutes
Install phone battery
SP Flash > Download > (select scatter file in the folder above, flash Teracube_2e_A11_05_20211102)
Plug USB
Flashing completed successfully
Unplug USB
Remove phone battery
Wait 5 minutes
Install phone battery
Attempt to boot the phone

If the phone boots, you’re now running the factory-install Teracube ROM, not the /e/ OS ROM.

Keep in mind that my phone is a 2022 version… if you have a 2021 version, you’ll have to use a different ROM.

Download (or the latest, if there is a later version) and unzip it to a folder. I copied the contents of that folder to j:\Android\test because ‘test’ is far shorter than ‘IMG-e-0.22-r-20220307169166-stable-emerald’.

Normal Boot the phone.
In Settings > About Phone, tap ‘Build number’ about 10 times to enable Developer Options.
In Settings > System > Advanced > Developer Options:

  • enable ‘USB debugging’
  • enable ‘Disable adb authorization timeout’
  • enable ‘Unlock bootloader’

In an administrator-level command prompt, type ‘adb kill-server’, then ‘adb reboot bootloader’… you’ll get a prompt on the phone, tick the check box ‘Always Allow’, and tap the button ‘Allow’.

The phone will reboot into fastboot mode.

In an administrator-level command prompt, type ‘fastboot flashing unlock’. The phone will give you a textual prompt to push the Up volume button to accept, whereupon it’ll unlock the bootloader and reboot into fastboot mode again.

You’ll see:
(bootloader) Start unlock flow
OKAY [15.760s]
Finished. Total time: 15.761s

Now type the following lines, one at a time (substituting your own path below):

fastboot -w
fastboot flash boot j:\Android\test\boot.img
fastboot flash ramdisk j:\Android\test\ramdisk.img
fastboot flash ramdisk-recovery j:\Android\test\ramdisk-recovery.img
fastboot flash vbmeta j:\Android\test\vbmeta.img
fastboot flash dtb j:\Android\test\dtb.img
fastboot flash dtbo j:\Android\test\dtbo.img
fastboot flash gz j:\Android\test\gz.img
fastboot flash lk j:\Android\test\lk.img
fastboot flash md1img j:\Android\test\md1img.img
fastboot flash scp j:\Android\test\scp.img
fastboot flash spmfw j:\Android\test\spmfw.img
fastboot flash sspm j:\Android\test\sspm.img
fastboot flash super j:\Android\test\super.img
fastboot flash tee j:\Android\test\tee.img
fastboot reboot

… and you’re back to running /e/ OS.

I’ll update later after I get the IMEI numbers restored.

1 Like

Just putting this here for future reference…

*#*#4636#*#* from the phone app brings up an interface to test/change connection settings for telephony… but it doesn’t change the IMEI.

Anyone know the phone-code to enter MTK Engineering Mode on this phone?

Well, I tried flashing TWRP 3.6.1, and it put the phone right back into a boot loop, so I had to flash the original .img file back.

Not sure how we’re supposed to do this… the files for the Teracube ROM and the /e/ OS ROM don’t even have recovery.img (and recovery.img isn’t listed in the Teracube scatter file), but the file in the link provided above by piero is recovery.img. I tried renaming it to boot.img (only because that’s the only file with the same exact size as recovery.img) and flashing it to the boot partition, which boot-looped.

Anyone have any idea how to put TWRP on this phone?

Please can you tell me if this is a super partition device. Thanks.

Official /e/ smartphone selector give infos for Teracube 2e
yet only run with Android 10 as a base :

The thread i liked for TWRP is also about 2e device.
Not emerald.