Murena Teracube 2e stuck in bootloop

I tried to update my Teracube 2e (bought directly from E Foundation) to firmware 1.1, but it wasn’t working. I followed the instructions to install TWRP so that I could manually install it, but now I’m stuck in a boot loop. I just get the “Teracube” splash screen, then the screen goes dark, and then the “Teracube” splash screen over and over. Holding power and vol+ doesn’t work; nothing happens and the boot loop continues. I’ve tried connecting a USB cable and forcing adb reboot bootloader but it says “waiting for device.” I never even get to the E slash screen. Have I completely bricked my device? What can I do about it?

Please help. I’ve been working on this for six hours and am about to have a nervous breakdown!

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

1 Like

Hi YJ, sorry about the like just there; scrolling error on my phone touchscreen, lol.

Anyway, try not to panic and don’t just keep random pressing buttons. If it’s bootlooping it’s still alive and likely to be recoverable from the mishap. Sadly I don’t know the 2e but others here do. Meanwhile let’s research the correct button press combo to power down the device.That would be a good starting point. If I find something I’ll get back.

And edit the title of your post to read:

Murena Teracube 2e stuck in bootloop

or something similar

1 Like

Hi Chris, thank you so much for replying! I renamed the thread as you suggested. No worries about the like. I’m just glad someone saw my post!

I’m sure someone will be along to help. Meanwhile you could search the forum (as I’m doing) for relevant posts. Or just go to the devices category and look.

Which teracube 2e is it, the 2020 running eos Q or 2021 running eos R?

Does it turn off with long press power button?

I bought in January of this year, so I’m assuming it was running eos R, but I don’t know for certain.

No, it does not turn off with a long press of the power button.

It would be helpful to give more detail about what happened. What happened when you first tried to update? Did a download start, how far did it get, would it not download at all, that sort of thing.

Then which installation instructions were you following (link) to install twrp and what steps did you do before the bootloop?

Here’s the sequence of events as best I can remember:

  1. Saw the 1.1 update. Downloaded it and clicked “install.”

  2. Phone got to 20% of installation then rebooted to recovery. I clicked “apply update,” but never got anywhere.

  3. Tried installing TWRP. I followed these instructions: [HOWTO] Install TWRP I noticed that switching to fastboot would wipe my install and I’d have to set the phone up again and I’d have to go back to enable developer mode.

  4. I thought I had managed to successfully install TWRP, but pressing power + volume up at boot didn’t take me to TWRP or any other recovery screen; it just booted right into eos.

  5. Downloaded the update through the gui again, clicked install, got to 20% and phone rebooted, and this was when the boot loop started.

Edit: It’s 1:30 in the morning my time, so I’m going to head to bed for now. I’ll check back in the morning. Thank you so much for your help so far @chrisrg

1 Like

Looks like you have a removable battery, so that’s an option to power down but still need advice from someone who knows the device and what happens when you do that. It might reset it , I don’t know.

Others are reporting issues with the version 1.1-r, have a look in the Devices/Teracube category. Best to abandon updating for now and concentrate on getting the OS back.

This is from the teracube forum:

“There are two batches of Teracube 2e (T2e) so far”

  1. 1st batch - Serial number starting with 2020 (internal codename: zirconia)
  2. 2nd batch - Serial number starting with 2021 (internal codename: emerald)

How to identify the batch

Check Serial number (SN). (Under the battery or dial *#06#)

  • The 1st batch starts with “2020” in their SN. Sample - 202011T2Exxxxxx
  • The 2nd batch starts with “2021” in their SN. Sample - 202111T2Exxxxxx.

I pulled the battery to power it down. When I put it back in and tried to power it on, the bootloop started again. Serial number starts with 202011T2E. So it must be from the first batch.

Ah so.Well you know a bit more and you can conserve power by whipping the battery out whilst getting things figured out. I’m pushed for time at the moment but will be around again in a couple of hours.

I’m sure that you can crack this one way or another. Options at the moment look like:

1.Contact Murena point of sale; looks like the update is causing problems for people.

2.Create another post on here and teracube forum to specifically discover if there is a known button press to power down the device. (side note: ~I read somewhere conflicting versions of how to get into download mode. I’ll check that out again later)

3.Last resort: there are instructions to flash stock android via SP Flash tool on teracube forum with specific advice to help with connecting while in bootloop. Might need windows computer, not sure at the moment.It needs careful handling, it’s a powerful flash tool.

1 Like

Thanks! I’ll give it a try after work. I contacted Murena support, but it’s a bit slow emailing back and forth due to the time difference (I’m in Canada and I assume they’re in Europe).

Weird question, if all else fails, does Murena accept phones back to be fixed when problems like this arise? It would give me a great deal of reassurance if I knew that was an option, even if one of last resort.

Thankfully, my old phone still works, so I at least have basic talk/text in the meantime.

Sorry, I have no idea about that.

If you knew what the button press combos/options were you could make headway possibly. Like, how do you get manually into recovery from the powered off state. If for example it was hold power and vol down…you could mimic that by removing battery then reinserting battery while holding volume down. Then if by magic you booted into recovery you could try factory resetting possibly (you’d lose your data setup obv.) and then rebooting.

I’m sure there must be some clue of an answer to this question on teracube forum somewhere.

I am kind of wondering about the initial TWRP thing. That HOWTO thread is generic and old.
In this back and forth I see no mention of where TWRP was obtained from. The recoveries are device specific. There is no official TWRP for the Teracube.

Did you use/see this thread…
[Advanced users only] TWRP recovery + root for Teracube 2e (1st batch, SN:2020) - Guides - Teracube Community

If not then I can assume you took a random TWRP, tried to install it, and that’s when the troubles started?

1 Like

I didn’t use that thread. You are correct. Took a TWRP, tried to install it, and that’s when it all went horribly horribly wrong.

Success! I flashed Lineage OS to my phone. Do you have any good tutorials for how to flash eos for the Teracube 2e coming from Lineage OS? According to @marcdw some of the HOWTO threads are out of date. I’ll mark this thread as solved as using SP Flash has fixed the boot-loop. Thank you so much for your help! I’ll sleep much better tonight!

Solution: Flash Lineage OS using SP Flash [Advanced] Installing factory Android image w/ SP Flash - Guides - Teracube Community (This fixes the boot-loop issue) then flash eos on the device. (Just to make things clear for anyone else who has this problem on the Teracube 2e)

1 Like

Hey, well done YJ so glad you got it sorted in the end.Good result. Sorry, but I don’t know about going from LOS to e.

Which LOS rom btw? Can’t see anything on their downloads pages. Unofficial rom?

1 Like

I think it’s included in the firmware files you download as you follow the instructions from that very helpful link you provided to SP Flash.