My phone does not install system updates in /e/

Good evening,

I am new to this forum and would like to thank you for your support in advance.

Since lately I have been using /e/ on my Samsung Galaxy S6 and by now several system updates are due. By now several system updates have been issued without me having been able to install them, the latest update I dowloaded was of the date of April 15 2020.

When I try to stell them, nothing happens, the status bar simply shows a notification saying “installation error”. I also tried to install the system update manually via TWRP (which is at release 3.3.0-1), but therein cannot find the save location to which the updates are downloaded to. I was suggested the folder /data/data/org.lineageos.updater/, but cannot make any find of it.

Where can I find it? What shall I do?

Kind regards

Hello @Forumsnutzer, I use the Samsung Galaxy S6 Edge - “zeroltexx” and it has the same problems with /e/ OS as your S6 - “zerofltexx”.

Use this folder /data/lineageos_updates with TWRP “Install” and read more and more and more …

PS: Forum user sounds so German, right?
PS: Forumsnutzer hört sich so deutschsprachig an, oder?

All e-0.8-n builds for S6 (edge) were buggy. Some /e/ users are back to e-0.7-n-20200215*.

Info: S6 zerofltexx reboot when locking + access to images forbidden

I’m wearing sackcloth and ashes. I did install the wrong update for TWRP, zerofltetmo, instead of zeroflte. Having corrected that I was able to execute the update to the latest version.

So far so good, but now I’m facing a new issue: My device keeps on rebooting constantly. What the heck is going on there?

Install the last “0.7” version you have. The download page for S6 has been removed… Make a backup.

Now, please excuse my words, but this is really fucked up.

Yesterday I begot a backup with TWRP, which I just tried to install. However, I am not able to transfer it to my phone as the transferring process keeps getting interrupted by the device which reboots all the time…

And no sdRam on the s6…
Try to Boot to TWRP and enable MTP if isn’t, in order to transfer the Zip into the phone internal memory.
Or use an OTG/usb drive

Yes it is, I don’t know why the download page has been removed… I have already raised the problem to the one in charge of this a few hours ago.

Done. Thank you!

Thank you!

My backup takes the form of a folder named

How do I get TWRP to recognize and install it?

When you have created the backup, TWRP has created a folder tree /TWRP/backups/drive _identity/date_and system identity/differents_partitions_saved.

When you want to restore, you have to point for a storage drive where your backup is

Oh, that folder is empty.

I created a backup yesterday with Backup on the entry page.
This begot a folder of the form as just mentioned.
Now I just did it again but found that another folder of that kind bad been begot. However, there is nothing to see of folder named /TWRP/backups/drive _identity/date_and system identity/differents_partitions_saved.

Alright… after some research I got it done. That took some doing, for eventually getting back to where I was…

But now I’m back in a 0.7 version again.
Well, initially I switched from LineageOS to /e/ in order to use an operating system that is provided with updates, also for a device such as my Samsung S6. Now I find that I am provided with updates, but they don’t work. :pensive:

The OTA updates worked about every weeks for a year but since a month there are problems (with 0.8 for some samsung device) some dev are working to fix this issues, wait and see…
I think it is a question of days or a week.

I consider that’s a brave thesis, considering the bug. “OTA update is not automatically installed via TWRP” is not fixed since 12.2019.

I assume that the S6 / S6 Edge does not have a high priority at /e/. Therefore updates are only done automatically by default. But real changes do not take place.

That’s a pity, because the S6 series are technically demanding (Exynos 7420 Octa-core, UFS 2.0 internal storage) and especially the S6 Edge are optically beautiful samrtphones. A change for the better can only be expected with the migration to /e/ OS 9-pie.

At least the download page is back, without the problematic versions.

Yes sadly even if bugs that make the device unusable are rare, it can happen.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.