My S10e is stuck at Samsung boot logo after install


My Samsung S10e with Android 12:

  • unlocked bootloader
  • most recent firmware
  • Dev options, Debug USB & unlocked OEM

after installing e/OS recovery with Heimdall (recovery-e-1.5.1-s-20221102231515-dev-beyond0lte.img)
and system with adb sideload (1.5.1 for Android S) (upload successful)

gets stuck at boot logo.

Help please…!

Hi @Qiqo welcome to the /e/ forum.

Easy things first.

  • Ensure the battery is fully charged and reboot.

  • It is always possible that First boot failed; are you able to boot into Recovery mode and Factory reset ?

Secondly, in the same article under Recent generation we see

Be sure to follow the Pre-Install Instructions shown of the install page for your device.

Good luck.

Thank you @aibd
the battery is fully charged when rebooting (almost always power plugged).

I tried a few times installing and it’s failed everytime.

I think I might need to downgrade the firmware, will check that…

hmmm … you say you are putting e-1.5.1-s- onto Android “12” so that should be ok – e/OS + Android OS version names and numbers? - #3 by aibd


It is android 12 S from october the 5, so it’s ok

1 Like

Managed! thank you

Factory reset before every step

  1. I reinstalled the most recent Samsung (Nov '22 French) firmware, erasing the /e/ recovery
  2. replaced by an older Samsung firmware (Sept '22)
  3. installed recovery then OS
1 Like

I have a similar problem on the s10 (SM-G973F) beyond1lte and I have followed the steps on xda it was on Android 12 (S) october 5th version.

Below is what was showing on my phone:

Then rebooted and got greeted with this:

And after pressing power I am stuck on the second screen, waiting till eternity…:frowning: :

I am able to go to Download Mode (the blue/green screen)

Can someone please (@Qiqo maybe?) share the exact steps taken to end up with a freshly installed /e/OS on the device?

I would be most grateful…I’ve spent half a day already trying to get it working.


PS. I’m on Ubuntu Linux (not very experienced) and have a stock firmware sitting on my hd ( do I need to flash this one and repeat the steps I did before???

Same with me.
Got a S10+. Tried installing latest /e/-firmware (1.16) with latest Odin, latest TWRP, and adb sideload and got stuck up at the boot logo like you.

Same discussion in the german /e/-forum.

A german S10+ User found this discussion in the XDA-Forum.
Seems that Samsungs newest firmware makes problems. The solution was to install Samsung’s spanish stock ROM and then to install /e/. Seems it worked.

I didn’t try it yet.

To be honest I ended up installing Iodé but the same procedure might work.
I believe one important aspect is to factory reset/data wipe every time you install something new (either recovery or OS).


  1. download and install heimdall and “adb fastloader” first (they are command line tools, the easiest way is to “call” them after having opened their respective folder in the Terminal, and to copy the recovery .img and OS .zip files in each folder.
  2. To start with I data wipe
  3. download mode > installed the latest firmware from my country (France) for s10e. Maybe for /e/ and or for another phone you have to do it differently (older firmware? from another country?…)
  4. data wipe
  5. download mode > (you have to install heimdall) heimdall flash --RECOVERY [the /e/ recovery .img file in the right version] --no-reboot
  6. reboot immediately in /e/ recovery mode, I think you have to hold the 3 buttons until the recovery page shows up other you miss it (if you fail to do that you have to start again from step <3>
  7. data wipe
  8. /e/ recovery => apply update > sideload
  9. (install adb fastloader first) adb sideload (corresponding /e/OS zip file version)

I hope it works

Bless you guys @MvdL @Qiqo I will have a look at both your suggestions and report back in this thread

Thanks @Qiqo for sharing your steps, but at step 0. I already started to sweat because it means I have to unzip the stock rom, then untar the AP, BL, CP and CSC, And decompress the lz4 files. :exploding_head:

Enter odin4 for Linux. Download it from XDA here

Download stock firmware for your device here
In my case I’ve downloaded which is a lower version than the one that gave me errors.
Unzip it.
Do not rename the files because the md5 check will fail!

Reboot, I saw error but it booted stock rom eventually, phew! :smile:

Then I repeated the process as written here and got greeted with the bouncing /e/ logo, after that setup phone.

Thanks guys!

1 Like

Great that you managed!

For the next pioneers, let me reply that
at step 0 I didn’t unzip or untar anything. The installation/download is made directly through heimdall and adb directly, so no need for Odin app, which I found so simple.