Need to downgrade? Samsung Galaxy S10+


I bought a refurbished Samsung Galaxy S10+ (SM-G975F/DS), he is on stock Samsung Android 12. Do I need to downgrade to version 10 or 11? And if so, how do I do that? How do I download the OS?

I prefer to ask because I see that the Lineage version for the S10+ is based on Android 12L, so a superior version to mine (Android 12).

Thank’s in advance!

Welcome to this user forum @Ludi

You can wait ( no date announced yet for your device ) :


You can downgrade ( if it is possible ! ) :


You also can don’t care ( as this user did ) :


I see, I thought the R version was on 12L

It would be useful to show the android version next to the letter version of /e/ :slightly_smiling_face:

For now, I have unlocked the bootloader, then I tried to flash /e/ recovery, the flash have worked, but when I try to boot onto recovery mode, the phone boot as normal and don’t show me the recovery menu.

I searched the forum, and I’m a bit submerged by the differents informations. I don’t know if I need to root the phone, or downgrade the firmware to install a custom recovery.

Right now, my config is :

Model: SM-G975F/DS

Android version: 12


Can anyone help me? :slight_smile:

UPDATE : I found this post: Installing /e/OS on a Samsung Galaxy S10+ with latest Android 12 revision - #4 by Geron and start to try the solution mentioned

Hey, can someone upgrade my account? I can’t have more than 2 links on a post and I would like to share how I have succeed in installing /e/ on the S10+ (and with links it’s a lot more convenient for someone who want to follow the instructions)

1 Like

Trust Level 0 – New

By default, all new users start out at trust level 0, meaning trust has yet to be earned. These are visitors who just created an account, and are still learning the community norms and the way your community works. New users’ abilities are restricted for safety – both theirs and yours.

(We also want to hide any “advanced” functionality from new users to make the UI less confusing for them as they gain more experience.)

Users at trust level 0 cannot

  • Send personal messages to other users
  • “Reply as new topic” via Link button (UI removed)
  • Flag posts
  • Post more than 1 image
  • Post any attachments
  • Post more than 2 hyperlinks in a post
  • Have actual links in the ‘about me’ field of their profile (will be silently and temporarily converted to plain text)
  • Mention more than 2 users in a post
  • Post more than 3 topics
  • Post more than 10 replies
  • Edit their own posts after more than 24 hours

Admins can change these limitations by searching for newuser and first_day in site settings.

Trust Level 1 – Basic

At Discourse, we believe reading is the most fundamental and healthy action in any community. If a new user is willing to spend a little time reading, they will quickly be promoted to the first trust level.

Get to trust level 1 by…

  • Entering at least 5 topics
  • Reading at least 30 posts
  • Spend a total of 10 minutes reading posts

Users at trust level 1 can…

  • Use all core Discourse functions; all new user restrictions are removed
  • Send PMs
  • Upload images and attachments if enabled
  • Edit wiki posts
  • Flag posts
  • Mute other users

source : Understanding Discourse Trust Levels

Success! :smile: My Samsung Galaxy S10+ (beyond2lte) is now running on /e/ OS !

It’s been a process with a lot of try/error so it’s difficult to give a detailed “how to”. But here’s the few things that helps me: (just note that I’m french, so the name of settings, elements… are probably a bit differents, because my phone is in french)

To start: No need to downgrade the Samsung stock software to unlock the bootloader. It’s way more easy than that:

You can unlock the bootloader like in this video. (OEM unlock in the settings isn’t enought)

Then you can follow the instructions of this user: Installing /e/OS on a Samsung Galaxy S10+ with latest Android 12 revision - #4 by Geron

Note: I did all the flash from my SD card, except the TWRP one.

But for me, after flashing LineageOS 19.1, TWRP didn’t work anymore, I tried multiple things (I even got a LineageOS bootloop), I was getting errors like “error opening: … permission denied” whenever I tried to do a factory reset.

Not sure what solved this problem, I tried to remount the internal storage, format data and then it worked again and I could reinstall LineageOS 19.1. From there, it was impossible to have the smartphone boot in recovery mode on TWRP. No matter how I tried holding the 3 keys… it didn’t work. So I found a solution:

Boot the smartphone normally, follow the LineageOS welcome screens (you can check the "Update Recovery Lineage OS, it didn’t matter much), then go to settings and search “Recovery”, then go to “Advanced Restart” and enable Advanced Restart (the exact path is: Settings > System > Advanced > Gestures > Power menu > Advanced restart). Now, when you hold the power button and go to Restart it show you have an option to boot on Recovery. And it work! (it’s not TWRP tho, it’s LineageOS Recovery)

From there I did a factory reset (Format data / factory reset) and I installed LineageOS 18.1 (you can find it here)

Then, I tried to install the /e/ Recovery, but it didn’t work, nor TWRP, so I followed the welcome screens of LineageOS again and I went into the settings to enable the Advanced Restart like previously. From there I rebooted onto the recovery mode (LineageOS Recovery still) and I went to “Apply update” and installed the /e/ OS. And it worked!! Yeah you can install /e/ OS from LineageOS Recovery (it say that signatures are not corresponding, or something like that, but you can continue)

Now everything seem to work fine. Call, photo, internet, video etc… (and the recovery mode is now /e/ Recovery)

I made a small adjustment to have bigger elements (icons, button) on screen, because by default it was pretty small, so you can change that in the settings (under Screen settings), advanced settings and Screen Size. I put it on Large.

If you feel adventurous, maybe that you can unlock the bootloader, flash TWRP Recovery, and skip the LineageOS flash part, to just directly flash /e/ OS. I have the feeling that it can work (since there’s someone who already did it from stock Samsung), but I’m not responsible if you turn your phone into a brick :innocent:

Something more that can help you:

Thank you piero that help me.

And if you have the S10+ and you need help to flash /e/, ask me, maybe I can help you :wink:

Hello, thanks a lot for this very thorough explanation, this sure will help new user. I never wrote in the forum that I faced the same issue as you : not being able to start recovery with key combination from a shut down phone. I also had to start recovery from the running os through the advanced restart menu Settings > System > Advanced > Gestures > Power menu > Advanced restart.
I hope your additional explainations will make their way in the doc. Maybe we should confirm the simpler installation procedure of installing e os directly from up to date android 12 .
I don’t know all those cases can be dealt from within easy installer. Anyway thanks for everybody’s great work. E os is already a better system than lineage, more usable, more up to date, more phones being maintained through is simpler build process. E cloud is already the better solution I have ever used for saving my contacts and calendar. SMS backup of qksms works well. Os backup saving with seed /USB key or nextckoud is working well and good enough for saves.

1 Like