No cellphone network service after /e/ OS install

Try resetting your network options:
Settings | System | Advanced | Reset options | Rest WiFi, mobile & Bluetooth

Please check your APN settings, does they match your provider’s, noticed on their website ?

I have tried these options. Also reinstalled/e/ OS but the problem remained the same.

The only thing I could find online so far was that I need to update the modem driver or something but I have not tried it yet: [ROM][OFFICIAL][pioneer][11] LineageOS 18.1 | XDA Forums

When I started, I used Sony’s default flash tool. I am kind of hesitant to use other tools flash tools.

Sure you reinstated Android 9, 50.2.A…?
And did you carry out the copy-partitions step on the eOS install?
Were you on Sailfish prior to RTS (return to stock) with emma?

The little cross is to indicate mobile data is turned off btw.

Have you tried to compose *#*#4636#*#* in the dialer to set the preferred network ?

Not sure what you mean with that. I got a new Xperia XA2 and updated the device to the latest Android Stock firmware provided by Sony.

Yes I believe I did.

No I used a new device but I do also have a device with Sailfish OS coincidentally.

Yes and when I try to turn on ‘radio mobile’ it allows it, but it does not really turn on and when I leave the screen and come back it is turned-off again. It does not let me turn-on the mobile network. I tried to change the settings with no effect. It returns them back to where they where after I close and re-open the screen.

Even last choice of the 3dot menu ?

Even changing preferred network combination, matching your country carriers technology

Yes, they return to the previous once, like if they are not stored. Selecting or making changes there do not become permanent. When you return to the same screen they are back as they where. It seems to be disabled.

So you installed Android 9 using emma. 50.2.A etc is the number allocated to Android 9. Android 8 would be 50.1.A something (as indicated in the XDA link you posted.You would be achieving the same thing by installing 9 via emma)

You can double check the firmware version with phone in fastboot mode, in terminal enter
fastboot getvar all
Sixth line down in the output look for “version-baseband”, what do you see?


You had me scratching my head there for a minute! :sweat_smile:

I’m sorry I don’t know what the problem could be, other than to think it’s a broken install with the sony’s emma or a problem with the phone itself; but I guess you already tested the sim with android before flashing e?

I’ve flashed the XA2 back to stock with emma many times but there was one occasion where it didn’t work properly; I couldn’t turn on wifi after booting. This isn’t going to help you but I relate the story just for what it’s worth. This was Feb last year, phone was on sailfish and I did RTS with emma. When wifi didn’t turn on I ran it with emma again. Same problem. Flashed it with newflasher and android 9, same problem. Not knowing what else to do I then flashed the e pie test-build and it worked and the phone was alright after that. Still don’t understand it.

1 Like

As part of the latest testing round I returned my XA2 to stock android 9 (newflasher) before installing e-0.21-r and I’m now experiencing the same issue. This will be reported in the testing channel and I’ll probably make out a bug report if one does not exist already.

Previously I had tested up to and including 0.19-q and 0.19-r without experiencing this problem.

May I ask what e version you are running?

I am currently running 0.20-q.

Can I downgrade to 0.19-q without a problem?

Without wiping data, I don’t know. Maybe someone else can say.

If you were going for clean install you might as well try R, no? Q will eventually lose support anyway. But obviously there are issues to be fixed.

I already wiped once unfortunately just to see if it solves the problem.

R seems to have a single version from October and said it was Beta so I thought I should go for the Q which seems to receive updates each month.

You mentioned e-0.21-r but I do not see that option on this page: /e/ image ROM download

0.21-r currently in testing by volunteers. 0.21-q will follow.
Follow the weekly updates for testing status and look at the testing category for more info.
If I get any useful feedback relevant to this topic I will share it.

1 Like

It turns out that there are no issues with phone calls due to the eOS versions mentioned above. Whilst I cannot pinpoint 100% what was going wrong I can say that if one follows the installation instructions exactly a good result should follow.

In brief (for a previously unlocked device) that would be:
Return device to stock android 9
Boot up, test calls etc, take a note of APN if one wishes
Turn on usb debugging
Plug device to pc, reboot bootloader
Flash boot with recovery-e
Power off device (unplug), manual reboot recovery*
Plug device to pc
In recovery
Sideload copy-partitions zip and allow to complete
Factory reset/format data
Set up adb sidelaod with Apply Update
Sideload eOS zip

*This step is missing in e installation instructions.

I have closed the bug report with feedback.

I re-installed 0.19-q, I then installed 0.18-r with the same result. I then used Sony EMMA and restored stock android 9.

Then re-installed 0.018-r after and the problem was resolved.

What I did different the second time was:

  • I had a sim-card installed (the first time I had no sim card installed)
  • The first time I connected the factory default Android 9 to WIFI and updated it to the latest version. This time I did not update Android 9 after I used sony EMMA to install the factory default Android 9. I made a phone call and confirmed it worked I went straight to follow the default instructions to install the /e/ OS 0.018-r

Not sure if any of this matters but for anyone with a similar problem go straight to Sony EMMA and repeat all the steps again.

Great you got it sorted! Watch out for the update to e-0.21-r fairly soon for more improvements.