Notes on phone that wouldn’t sync lost after OS update. Any hope of recovery?

the next /e/ update to v1.10 will avoid the error and open, but not restore notes that were local only and never synced. As I see it, adb methods are the only ones available. I can write more elaborate Howtos, but they will involve the commandline.

1 Like

I mean I’d be glad if this (the recovery of local-only notes) works, but didn’t see it when I tested myself, maybe I missed something.

Nextcloud notes app uses the official Room library for its Db. There must be tooling around to offer a button in the settings to export db state - greatly simplifying any recovery if the user needs one. That is one of my takeaways from this. It would empower the user that can install a GUI Sqlitebrowser, but the whole adb stuff is too much for

Thanks for the feedback. And sorry for the delay…
So there is nothig to do. Is that right?
Or would it be safer to save stuff before the next update

as you initially said you lost all your notes on both phone and in the Murena account I’m sceptic the v1.10 update once released will make a difference for you. But if it will, all the better and feedback that it does is appreciated

1 Like

I noticed there was further work by Fahim I was missing before on introducing a migration for old note entries that never synced. That is the proper way, I’m impressed - … this will very likely recover notes that were thought to be lost with the App update

Some time has passed since last time…After my initial disappointment and trying to get over this loss. I had decided to try the more involved recovery if someone can help. However, I hadn’t seen The last message of @tcecyk does it mean that I just need to update to v1.10? I haven’t done anything yet trying to avoid thinking about it :slight_smile: .
Thanks for any advice!

Hi again
Looking at the solution by fahim it seems that the first step before updating the os is to:

setup [/e/OS Notee] app in <= 1.8 build.

I tried but this doesn’t work. I still get the message below.
Note that i’ve previously installed nextcloud app and this one synchronises. Is this enough?

App Version: 3.7.1
App Version Code: 3007001

Files App Version Code: 402060000


OS Version: 3.18.91-g35f12d2389e(eng.root.20230310.201313)
OS API Level: 29
Device: heroltexx
Manufacturer: samsung
Model (and Product): SM-G930F (heroltexx)

--- La requête HTTP a échoué avec le statut HTTP :301
	at$$ExternalSyntheticLambda0.subscribe(Unknown Source:6)
	at io.reactivex.internal.operators.observable.ObservableFromPublisher.subscribeActual(
	at io.reactivex.Observable.subscribe(
	at io.reactivex.internal.operators.observable.ObservableSingleMaybe.subscribeActual(
	at io.reactivex.Maybe.subscribe(
	at io.reactivex.Maybe.blockingGet(
	at io.reactivex.Observable.blockingSingle(
	at it.niedermann.owncloud.notes.persistence.CapabilitiesClient.getCapabilities(
	at it.niedermann.owncloud.notes.importaccount.ImportAccountActivity.lambda$onActivityResult$5$it-niedermann-owncloud-notes-importaccount-ImportAccountActivity(
	at it.niedermann.owncloud.notes.importaccount.ImportAccountActivity$$ Source:4)
	at java.util.concurrent.Executors$
	at java.util.concurrent.ThreadPoolExecutor.runWorker(
	at java.util.concurrent.ThreadPoolExecutor$
Caused by: java.lang.IllegalStateException: <html>
<head><title>301 Moved Permanently</title></head>
<center><h1>301 Moved Permanently</h1></center>

	at android.os.Binder.execTransactInternal(
	at android.os.Binder.execTransact(

the first item of that list that you quote is a test for reproducing errors or verifying the approach - not a solution itself. The line “update the os to the patched version.” is what you need to do, at best the latest v1.12.

The migrations should both recover unsynced notes and not introduce duplicates (that was a followup issue fixed in 1.11 I think). All that said, migrations are fragile, backups are great.

1 Like

Yes, it worked . my notes are back after the update and sync on the cloud.
Thanks for the support!

1 Like

cool - at last ! the developer (Fahim) really did right by that issue and doubling down when the first restore migration had side effects. When /e/ dev team availability is criticized in other respects, I think back of this

Hello everyone, I’m reading this thread very hopefully. Had the same problem, notes in the notes app that weren’t synched and weren’t disyplayed anymore after an upgrade, but under settings the app info says there’s still a lot inside the notes storage.

inside the settings it says the app is currently on version 3.7.1

I’m a bit nervous about doing sth wrong right now, as I would be very desperate if I lost all the notes :cry: can anyone tell me what steps to take, would be incredibly grateful :slight_smile:

just did the update, unfortunatelly when I open the notes app it only says “welcome to notes” and a button “select account”.
Is there anything I can still do to get the notes back?

Still says there’s 10MB inside the storage of the notes app, so I hope my notes are still there?

I am also able to use adb commands with instructions. Unfortunatelly my phone isn’t rooted, doesn’t simply have the options to do that in the developer settings, and also doesn’t have TWRP installed.

Any ideas what to do? Would still be very very grateful :sweat_smile:

I think if you’d add a cloud account temporarily you will see the notes. If you can handle adb and cli in general, no root needed, just java and these 4 lines: Notes have been deleted / Notizen wurden gelöscht - #22 by tcecyk

Hi, thanks for your answer!
I’m a bit nervous that the internal storage data might get overwritten and I will loose it entirely if I synch with the cloud now. But if you know that won’t happen I’ll try that :slight_smile:

I tried the 4 lines and am still working through error messages [if you want to know the current error:
x apps/foundation.e.notes/db/OWNCLOUD_NOTES
tar: --to-stdout: Not found in archive
tar: Error exit delayed from previous errors.

are you on mac? --to-stdout is a gnu tar option probably, just open the archive then and pick the db file by hand

1 Like

not a mac but windows

Hi, I know it’s been a while, but maybe there are still ideas on how to handle this? I would be soo happy to get my notes back. I’ve got two files in apps/foundation.e.notes/db/OWNCLOUD_NOTES even with the error message above. One is 32kb, one is 500kb. Is there a chance I can do sth with these files?

I would also love to try what you said in your message on Aug 15 @tcecyk , can you give me more information on what to do?

Re-synching with the cloud didn’t work unfortunatelly.

they’re sqlite db files (and a WAL file aside that should be the smaller one). adb pull it and use any sqlite browser from an environment you’re comfortable with. If the program doesn’t offer to open it, append .sqlite or .db file extension.


this worked! I’m so incredibly grateful! Thank you a lot for all your time and help, I’m very happy and you helped me recover sth very very important for me. Can’t thank you enough!