OnePlus 6 (enchilada): over-the-air (OTA) upgrade not working for me

Hello there, I am happily running /e/ since over a month on my new OP6.

I installed /e/ starting from Android 10 and went through various issues before finally succeeding, see [HOWTO] Install /e/ on OnePlus 6 running Andoroid 10

This is a necessary detail because in order to install this OS I had to flash a more recent version of TWRP, specifically

In my setup, that in all ways work perfectly, when I try to upgrade /e/ using OTA, it always fails.

The initial preparations executed while Android is running seem to succeed, but when I reboot it gets stuck at the bootloader. At that point, I can choose to launch recovery, which instead of TWRP, that was previously installed, is Lineage OS Recovery.

In other words, the OTA upgrade of /e/ wipes my TWRP and installs LOS Recovery instead. This in turn impedes the completion of the upgrade.

In order to upgrade /e/ I always have to do it manually using adb sideload </e/> from within the LOS Recovery and then restore TRWP using the same method.

Is it only me having issues with OTA upgrade? Could it be because of the TWRP version I am using?

When I tried to use the latest official TWRP for Enchilada of July 2019 it could not decrypt the filesystems, hence had to take a more recent, unofficial, one.

Hello @OnePlus6user, that sounds curious. LineageOS works like /e/OS with TeamWin - TWRP for OnePlus 6 (enchilada).

What does “LOS Recovery” look like? Please show a screenshot?

@archje, here you go.

I took the pictures today, when upgrading to latest /e/ OS from yesterday: same problem and TWRP overwritten by LOS Recovery and OTA upgrade not completing.

However, this time after the manual installation of /e/, I have installed the lastest official TWRP (3.3.1-2 of July 2019) for the device instead of the unofficial one mentioned in the first post.

The next weekend, if there will be a new /e/ OS to install, I will try OTA again and see if the official TWRP solves.

@OnePlus6user, the /e/ OS OTA Update feature requires a compatible Recovery, or updates must be installed manually.

The two pictures are very helpful. Until now I didn’t know that LineageOS uses its own Recovery version instead of the well-known version with the TeamWin - TWRP user interface.

Apparently the LineageOS own version was developed for A / B devices.

I know from the TWRP Team Win Recovery Project version that it cannot be easily uninstalled or removed. Installing another recovery is your only real option.

So since you haven’t managed to install the version of TWRP Team Win Recovery Project used by /e/ OS yet, I recommend to bite the bullet and download StockROM OxygenOS 9.x [Pie] to reinstall.

This is guaranteed to overwrite the existing recovery with the Android recovery. After that it must be possible to flash the Team Win Recovery Project version twrp-3.3.1-2-enchilada.img used by /e/ OS via fastboot.

TWRP is also made for A/B devices. When it is installed, it explicitly says that it is being installed on both slots (something like “Patching slot A” and then “Patching slot B”).

I actually did install it two weeks ago, as written in my previous post:

However, I confirm that even with the latest official version of TWRP (3.3.1-2 of July 2019), OTA does not work for me: same identical issue.

This is unfortunately not an option for me: this is my only phone that I use on a daily basis and backing up, restoring, re-configuring everything the way I need it would take too much time and is too risk prone. I don’t use any external account for saving apps and data, so the whole procedure would have to be manual.

I will therefore keep on updating manually from recovery, at least for the time being.

I am now wondering if this issue with OTA not working is only affecting me or if it is something affecting all users of OnePlus 6 (enchilada)?

Yeah, that would be interesting to know.

My Samsung Galaxy S6 Edge has the same handicap for months. No automatic OTA update - only possible manually. The bug is published on gitlab, known to /e/ support @rhunault but nothing happens.

Another user of this forum tried to perform OTA on One Plus 6 with stock recovery (Lineage OS recovery) and re-locked bootloader and still does not work:

@Hawk, would be great if you could try OTA with stock recovery and unlocked bootloader.

Tested scenarios (so far) where OTA is confirmed not to be working on One Plus 6 device:

  • With latest unofficial TWRP for Android 10 installed ( and unlocked bootloader.
  • With latest official TWRP for Android 9 installed ( of July 2019) and unlocked bootloader.
  • With latest official TWRP for Android 9 installed ( of July 2019), unlocked bootloader and disabled OEM unlocking option (Settings -> Developer Options -> OEM unlocking), which according to this post on XDA should have prevented the possibility to flash another recovery (i.e. Lineage OS recovery) on top of the currently installed one (TWRP): it did not prevent the overwrite of the recovery and OTA failed.
  • With stock LineageOS recovery installed and locked bootloader (as tested by @Hawk, see previous comment).

Another confirmed scenario where OTA for /e/ OS is not working on One Plus 6:

  • With stock LineageOS recovery installed and unlocked bootloader.

Source here: [HOWTO] Install /e/ on OnePlus 6 running Andoroid 10

So we can safely conclude OTA for One Plus 6 is broken.

Same here, but to “finish” the update I dont boot twrp, I use LOS recovery and just sideload.