OnePlus 7T stuck at bootloader screen on easyinstall

Hi all,
I’m fairly new to all this. I purchased a OnePlus 7T (HD1900) which is normally supported by the easy installer. Problem is I get stuck after rebooting in bootloader. I upgraded to Android 12, then rollbacked to Android 11 thinking it could be the problem. But I still get the “timeoutThread” error in the logs.

The bootloader is unlocked. Adb and fastboot are installed on my computer. I run the last Linux Mint distro.

Can someone please help me?

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

This was probably ok … the stable ROM available for Easy Installer according to is at Android 11, R today. Having rolled back have you restarted the device in Android 11, R and checked it is working ok without adding a Google account ?

Might be best to check out the full log Howto troubleshoot issues with the easy-installer feel free to paste the log here.

hi @aibd and thank you for your answer.

i just tried again. The phone boots and works perfectly fine without adding a Google account -
but still no luck, here is the log

can you make some sense out of it?

here are my android version details

Here, edited, are the final lines of your log

2023-05-12 18:47:20,329 INFO [JavaFX Application Thread] e.e.i.c.MainWindowController [null:-1] ResetNextButtonEventHandler()
2023-05-12 18:47:20,667 DEBUG [Thread-20] e.e.i.t.CommandExecutionTask [null:-1] updateParameters(), Parameters = {device_id=6c0623b5, fastboot_folder_path=/snap/easy-installer/32/easy-installer-linux-x64/bin/adb/}
2023-05-12 18:47:20,668 DEBUG [Thread-20] e.e.i.t.CommandExecutionTask [null:-1] getFullCmd(), full command =  [/snap/easy-installer/32/easy-installer-linux-x64/bin/scripts/, 6c0623b5, /snap/easy-installer/32/easy-installer-linux-x64/bin/adb/]
2023-05-12 18:47:20,947 DEBUG [Thread-15] e.e.i.t.DownloadTask [null:-1] timeoutThread is over!
2023-05-12 18:47:42,289 INFO [JavaFX Application Thread] e.e.i.EasyInstaller [null:-1] stage is closing

I cannot explain this. [2]

As I understand it [1] has the simple job of reboot bootloader but this fails to happen be able to move forward.

Perhaps someone more familiar can provide an explanation.


[2] Interesting, compare this thread PC can't find OnePlus 7T driver during bootloader mode

Do you think it could be a driver issue? The device id is displayed when I prompt fastboot devices in terminal

Do you think I could try to install it manually? However, it says in the documentation that I should have Android 12 installed… Weird, don’t you think ?

No, not on Linux ! Furthermore, now that I review the other case we see

I replied with a suggestion to rule out drivers … but the phone is reported to be already in bootloader but stuck.

@comlag does your device react, as if moving to bootloader / fastboot mode as Easy Installer collapses? Edit, you already said in your OP “after rebooting in bootloader”.

Android 12 is correct. The stable Android 12, S build used by Easy Installer was reported in the pipeline, but the dev version we see is released at Android 12, S:

Yes, take your time to read the instructions 3 times :smile: … feel free to ask.