Oneplus 8 - Manual installation leads to a phone stuck in fastboot mode

Hi everyone.

I just tried to install /e/ on a Oneplus 8.
The easyinstaller was stuck just after OS download (just offering to retry download but not allowing to move to next step). it seems that I need Android 11 and not 13 : OnePlus 8 Pro stuck on "Rebooting in bootloader mode" step

So I tried to install manually :
I was able to do the following operations :
(developer mode, USD debugging, and USB default mode = transfer although I’m not sure it quite worked)
adb reboot bootloader
fastboot devices
fastboot oem unlock
fastboot flash dtbo .img
fastboot flash vbmeta .img
adb reboot bootloader
fastboot flash recovery recovery-e-1.17-r-20231109350749-stable-instantnoodle.img

And now my phone is stuck in the fastboot mode, it won’t restart, it keeps landing here after showing


And it never boots, I lost Android and cannot go on with /e/ installation.

I’m stuck, does someone have an idea ?

Thanks !

The screen that I’m stuck on says :
Press volume key to select, and press power key to select

FastBoot Mode
DEVICE STATE - unlocked

So after you flash recovery … the very next step is

  1. Now reboot into recovery to verify the installation:
  • With the device powered off
  • hold Volume Down + Power

What happened at that point ?

This step is really crucial to “breaking” the original system and introducing the new.

Hello aibd,
Thanks for your answer.
Choosing “Power off” with volume buttons + select with power button does not work…
When I press vol up + power for ~10s, it finally turns off.
Then vol down + power brings me back to this same screen (fastBoot mode):

And same when I choose “recovery mode” + power.

Kind of a loop…

Ahh …

So what Android version were you on originally ? This r build would also require Android 11 (R).

I think you must have seen
  • Before following these instructions please ensure that the device is on the latest Android 13 firmware.
  • If installing the stable build, please ensure that the device is on the latest Android 11 firmware.

For Easy Installer you would be given an r stable build, hence the Android 11 (R) warning.

When you switch to manual mode (assuming your device was higher than Android 11 (R)) you would be able to flash the appropriate Android version, in Build type #dev,

Yes, you’re right, I didn’t use the right version, because I was in Android 13 and used the stable R version. (Which is the reason probably why the easy installer didn’t work).
I’ll be more careful next time.

The problem now is that I don’t know how to resume the installation process because I’m stuck in this loop and the phone is not detected by my Linux PC (even though I activated default USB = file transfer) when I connect it with a USB cable.

I found this tutorial to unbrick a Oneplus 8 :
But I don’t have a Windows computer around to try it and don’t know if this would work.

Is there a way to solve this ?

Thanks again

If you believe the device is soft bricked, you are confirming it if you really cannot connect to fastboot, then I believe you will need to get access to Windows.

Here are two links in case this helps give a different perspective from the youtube link.

Re Windows, in another forum post the possibility of a Windows VM on cloud was mentioned Reference here.


Did your Linux computer sees the phone once in fastboot mode? If it does you should be able to flash the e recovery image image and then with it sideload the 1.18T image with the

Does fastboot devices command returns anything from the terminal?

Thanks for your answers.
When I connect to Linux, the phone is not recognized (althoug I set default USB to file transfer, I had to manually click on the screen when I connected the phone). So I cannot access the phone from my Linux.

I gave my phone to a store, which was not able to flash the phone…

I’ll try to get my hands on a Windows computer and do what is suggested here :

But it is impossible to power down the phone when it is connected to the computer. And as soon as I connect it, it shows the fastboot mode screen.

I’ll post the results.


Sorry to hear these… I hope you’ll be able to recover/unbrick your phone.
Best of luck!

I had a lot of trouble (even fell into Qualcomm crashdump mode…) but finally managed to install back Android 11.
I found capital information here :
and here :
And here :
It turns out my phone needed an International OS (and not European).
Not the first time this happens : Recovery image for one plus 8 pro - #14 by Nello.
(Still unable to use Easyinstaller though (although I installed the latest version of Android 11), I’ll create another issue…)
Thanks for your help !

I finally managed to install manually :

This topic was automatically closed after 90 days. New replies are no longer allowed.