OnePlus - Nord - avicci - Documentation Suggestions

It could be keeping your actual android 11 firmware, only replace /vendor.img, by an android 10 based. and install /e/Q,
in a near futur, you will be able to only replace the /vendor.img by the android 11 based one,
and install the /e/R build skipping the entire reinstall of the android 11 stock firmware step.

Replacing /vendor, could be done by Fastboot or by TWRP or OrangeFox Recovery previously linked (if they works…)

1 Like

Just researching the use of “Unbranded” by @mauronofrio Recognized Developer at xda. He also wrote [OnePlus 6] How to rebrand your device: from HydrogenOS to OxygenOS and vice versa | XDA Forums and OnePlus 6/6T: How To Rebrand from HydrogenOS to OxygenOS

In preparation to flashing to Android 10 I rebooted the device and lo! /e/ came up, much to my surprise. To make sure everything is in order I would like to get your opinion on this. Here is what happened:

  • I (probably) updated a brand new device to Android 11
  • followed the instructions for installing /e/
  • finally uploaded the firmware without prior formatting
  • which ended in a bootloop
  • following suggestions from the forum (thanks!!) I booted into recovery and wiped memory (advanced → factory reset → format data / factory reset)
  • did much preparation and communication (thanks again), but nothing actually to the device
  • rebooted and voilà, /e/ came up
  • system setup is running, so far I set the system time and made a WiFi connection


  • is there a way to find out on which version of Android I installed?
  • any test if the /e/ installation went OK?
1 Like

Great news! Go to Settings > About phone > Android version > tap for /e/ version, long press copy to clipboard.
Also foot of About phone > Build number. Also, long press copy to clipboard.

Great news indeed!
It’s Android 10.
Build number: 10 QQ3A. 200805.001 eng.root.20211027.184332 dev-keys,stable-release

Probably I did not upgrade to R, although this seems not very likely.
I am amazed that formatting /after/ flashing did the trick.

Thanks a ton for your help!

1 Like

@Manoj Hi, better provide no installation instruction than a wrong one. Can you please update the instruction or at least write on top that it’s wrong!!!

  1. Problem with not recognized driver under windows: [Guide] Fix Device not showing up in Fastboot Mode (windows 10) | XDA Forums
  2. There is no TWRP for OnePlus Nord ?
  3. Is it a must to downgrade to android 10 ?

I guess point 6 is the TWRP recovery?
Hours later: found an inofficial TWRP, wipe was ok, but advanced wipe has no cache and system option? I have only the following options:
Dalvik/Art Cache
Internal Storage
USB Storage
Isn’t there a way to do this with fastboot commands instead of TWRP?
C:\fastb>fastboot erase cache
Erasing ‘cache’ FAILED (remote: ‘Check device console.’)
Same with system and nothing on console

Hi, I’ve just gone through the steps for the OnePlus Nord - “avicii”.

When starting the phone, I am getting an error stating that the OEM is unlocked.

I tried to lock it again and received an error:

Your device is corrupt. It can’t be trusted and will not boot. Visit this link on another device:

The device was working perfectly aside from the OEM warning before locking the bootloader.

Is there a step missing in the instructions to lock the bootloader again?

Hi @wadejbeckett welcome to the /e/ forum. Sorry if you do not get a helpful response on this thread. Locking after /e/ install is not possible on this device, I think!

Sadly, many devices get that annoying message - some just regard this as a “badge” for “escaping”!

This does not help you right now :blush:

If you do not get a solution feel free to ask on a new thread.


Hello! the picture from Info about OnePlus Nord - avicii suggests it has one fron camera when in reality it has two, I might we wrong but seems like that :slight_smile:

Thanks @Guillermoto will pass this info on to the Graphic designer to update.

  1. I notice a slight misleading documentation of the links, both developer and stable links have the following title/heading:

/e/ ROM latest dev build downloads

should say

/e/ ROM latest stable build downloads

yet links are as follows;

  1. I just installed e on a Nord AC2001 last night and the steps were not exactly clear.

At step 13 I got response: Script succeeded result was [0.0]

Again minor but it kind of scared me sitting there for 10 minutes before I realized I could reboot.

This issue has been reported a couple of days back with the build team. Will check for an update.

1 Like

On the step: “Booting a custom recovery using fastboot”,
#5 says: " Flash a recovery image onto your device by typing fastboot flash recovery recoveryfilename.img Replace the recoveryfilename with the name of the recovery image you downloaded in the previous section"

This could use some clarification as every time Ive tried it, it doesnt work and says “cannot load…”

Once you have downloaded the recovery image, you run the command from inside the folder where you downloaded it …this on an adb enabled PC with the phone being detected by adb
The command should be something like

fastboot flash recovery recovery-e-1.1-q-20220629200240-dev-avicii.img

yes this is the exact part Im stuck at.
phone is not detected by adb when in recovery mode.
when running normally, it shows and when in recovery, it shows in fastboot, just not adb :confused:

ok, documentation suggestions!

  1. in order to open cmd prompt in the proper location:
    press “shift+right click” then, open powershell

  2. for the load recovery step; use: shift+right click to open a powershell inside the folder where the recovery file is and then drag and drop the file into the powershell instead of manually typing the name

I tried many times to type it manually and drag and drop worked first time


Following the installation instructions on a device with OxygenOS 12 will brick the device! The following error message appears after flashing the custom recovery and trying to boot to the recovery or system:
"The current image(boot/recovery) have been destroyed and can not boot."
The same happens after flashing other custom recovery images. (TWRP, PixelExperience)

I did the following to get OxygenOS 12 working again:

  • Download the latest OxygenOS 12 image for the correct phone model from here (under Signed flashable zips)
  • Use the Firmware Extractor to extract the img files from the downloaded file
  • Reboot the phone into fastboot mode by holding Volume up + Volume down + Power
  • Flash the extracted recovery.img: fastboot flash recovery recovery.img
  • Reboot the phone

To downgrade to OxygenOS 11:

  • Download the downgrade zip for the correct phone model from the page linked above (under Downgrade zips, version
  • Copy the zip file to the phone
  • Go to system settings → About device → Up to date (Official version) → Dots (top right) → Local install
  • Select the zip file
  • If the verification fails you downloaded a file for the wrong phone model
  • Continue the installation
  • After rebooting to OxygenOS 11 you can continue with the /e/OS installation

Please edit the instructions.


Hi @mat1 welcome to the /e/ forum. Good catch and fix.

@Manoj, looking through the command line install instructions for Nord (and quickly a few other pages which I am fairly familiar with) the standard “Red box” Warnings / Cautions sections seem to be missing in a widespread manner.