Oneplus Nord manual installation problems

If I were you, I wouldn’t worry about drivers. fastboot recognizes the phone; so far there’s everything right. now you need to find the option “ADB Sideload” before you think about drivers at all. and if “ADB Devices” doesn’t find anything when the phone is in the right mode, then we can worry about drivers.

please select “recovery mode”. if you already installed TWRP successfully, you should be landing in TWRP. then, please send another picture. if you don’t land in TWRP nor in /e/ recovery (there’s a white screen and the /e/ logo), your TWRP installtion failed.

It’s getting worse . I reflashed the recovery-e-1.6-r-20221129238947-stable-avicii.img. That seemed to work:

Then I wanted to reboot to recovery and I got this error message:

So appearantly something went wrong with flashing the recovery… I think I need to reboot to fastboot mode and try flashing Twrp, but htere is a problem. The only way to startup in fastboot is holding the volume up and down and power buttons. I then see the fastboot screen, but as soon as I let go of the buttons.this screen disappears and I get the destroyed recovery message again.

1 Like

wow. that’s a bummer. that’s the second OnePlus Nord within a week that had the very same problem that I personally know of. the other one almost gave up and finally could recover his phone ONLY by total reflashing directly:

I would actually reflash stock OS again and then try again to install TWRP from scratch with
or with this (not very good) video tutorial:

don’t loose patience, everything’s going to work out in the end. and you learned some hacking after all…

1 Like

Hahaha, I’ve gotten used to seemingly endless trial and error with previous phones. I managed to reboot to fastboot and tried to flash Twrp this time, but no succes. Same recovery error message after rebooting to recovery. I’ll try your suggestion now.

maybe ask @johannesp , he was the other one. you met each other before. at the topic OnePlus Nord (AC2003) Not supported - #3 by johannesp


… only if yes … there may be a “technique” to the reboot the instructions say

  1. Now reboot into recovery to verify the installation:
  • With the device powered off
  • hold Volume Down + Power

no, not at this point anymore. it’s definitely bricked - and at least at this point there’s nothing to do anymore… @johannesp tried everything I knew.

probalby a messed up partitioning, maybe caused by wrong/unexpected partitioning or Formatting before the start of the procedure (not android R? maybe?). guessing.

I think it was android 11, but not a 100% shure anymore :thinking:.
Since the video’s hirntot posted were not very clear I thought I would follow the instructions for to Revert Oneplus Device to stock ROM on Windows PC on the /e/ website, So I downloaded the file but then I read the assumpion that * The user can’t reboot to recovery or fastboot. That isn’t the case because I can reboot to fastboot mode. So I wonder what to do. Should I start the MsmDownloadTool and conncet the device in fastboot mode or does that make things even worse?

The rollback instructions are a MSM method for a soft-bricked phone using a OnePlus EDL ROM.

The alternative might be to look for a fastboot flashable ROM, if such a thing exists and might work, but I do not think I would mix up EDL / MSM and fastboot.

Perhaps keeps researching till you are sure you have instructions which make sense to you. Personally I might expect to study MSM for quite a long time before I committed !

Ok, Thnx. That sounds like I’ve got some work to do. Since I’m a noob, it may be over my legue, but I’l give it a try.

I found this site: were they have all kinds of stock roms for the Oneplus Nord. Do you think I should try to install the OxygenOS version via fastboot?

You might check here OnePlus Community to get verification of your options.

DON’t follow the (messed up) /e/ Rollback instructions! they totally forget to set the phone in the right mode with a special key combination, that is shown in the video, so it just doesn’t work.

you need to shutdown the phone and keep it shutdown with a special key combination pressed. then it will be recognized by your computer hardware detector, but NOT by fastboot nor ADB, it’s a special flashing program. and it definitely works, since we just had that case a week ago.
the instructions are 100% clear with the first video, just play it with 0,8x Speed if you need to. and do it step by step.

… and maybe wait for @johannesp who might give you support as well after he, being a noob himself (if I remember correct), successfully got it done with that video.

I’m not getting more confident here :upside_down_face:
I’ll wait and see if johannesp comes back with feedback and check the Oneplus community in the meantime.

Here are two links with some MSM information.

From OnePlus Community [Guide] How to use MSM tool

From XDA [OPNORD][OOS AC01AA/BA/DA] Unbrick tool to restore your device to OxygenOS

Good luck

When a device has a super partition one can have unusual soft bricks just by flashing in the wrong sequence. Reading this article which refers to a ROM installed by a fastboot script we are told the device has a super partition. I think the article will be an educational read for you.

Hmmm I read the customDroid guide and it seems pretty straight forward. So I ran the flash-all.bat file. It seemed to get stuck rebooting. After “Rebooting into fastboot” was followed by an OKAY in 0.002s the script is “waiting for any device”.
The script ran succesfully except for 1 error message: “Erase successful, but not automatically formatting. File system type raw not supported.”. This was when erasing metadata.
I’ve waited for a long time, since but nothing happened. I made printscreens of the running script:

Now the phone is not responding to anything anymore. Any suggestions?
Update: Maybe I goofed up even more. I disconnected the device after say 20 minutes and tried to boot holding the up&down volume and power buttons and after a long time it showed the oneplus logo for a tenth of a second and then nothing. I reconnected the device and opened a copmmand window to see if it was in some sort of fastboot mode, but no devices recognised. Then after 5 minutes when I was doing something else all of the sudden the command window in which the script was appearantly hanging on “waiting for any device” started to come alive again. Did I have not enough patience? Or maybe the device came to live again because I restarted it manually? A printscreen of the next lines:

Every operatio failed with the same message: (remote: 'Flashing is not allowed for critical Partitions.
I’m now back in fastboot mode.

In your latest image you also got

Failed to boot into userspace

This is a super partition / fastbootd type error.

Your PC needs a recent platform-tools to deal with this …

or this event could not happen as the device was no longer there ?

Back to today’s starting point … you had to decide if you had a working fastboot or a flaky fastboot on the device.

I guess you decided your fastboot was fine on the device … and fastboot is safer to use than the more intrusive / aggressive “Engineer’s solution” of MSM and EDL.

I would be in no hurry to move on straight away.

What version fastboot have you been using ? Found from fastboot --version on the PC.

fastboot version 33.0.3-8952118. Maybe that is not the latest. version. I installed it when I was installing /e/ on other devices some time ago.
Edit: seems to be the latest version.

Without double-checking whether it is the newest, that should be ok. (You could always check for an update though.)

One more side comment

We don’t know much about this yet … always search … I found this …

… if you find yourself in a position to try again … you might run as root / admin if you did not do this last time.

While this

suggests … not an error, but normal !