OS doesnt boot after changing TWRP

Because I couldnt install the OTA update on my Xperia Z5 Compact from R1.4 to 1.5 I thought maybe it has something to do with my recovery.
No I just tried to change that to a newer version via adb/fastboot (which I succesfully used in the path, thats not the problem) without doing anything else but now the OS doesnt start anymore.
It always boots TWRP. Changing back to the TWRP version which was on before doesnt solve the problem…
Any help how I can solve this would be much appreciated as this is my daily driver!
And yes, sorry for being a dummy in the first place…

A couple of things to try, which have helped on Xperia XZ1 Compact;

  1. Follow the steps described in this post:
  1. If that doesn’t do the trick, maybe format the system partition too
  1. Last resort: when I was testing my custom L4M builds, I got into a state where neither the ROM not TWRP would boot. Eventually, after much swearing, I resolved it be reinstalling stock ROM: see here for details


If none of that works, then I’m fresh out of ideas :frowning:

Thanks a lot Pete, once again!
Now I am just a little afraid of the TWRP backup as it failed last time…
What do I need to back up so it works fine?
Automaticall it suggests “Boot”, “System” and “Data”.
Other options have no size in MB so seem to be not necessary with the exception of “FOTAKernel recovery”, LTALabel" and “Firmware”.
Any suggestions on that?

I just made a backup as automatically suggested (see above post) and to restore on another device (same type, same TWRP) and it doesnt work :frowning:
The other device only boots into recovery as well now!?

I have only ever backed up Boot, System & Data, and usually only restore Data partition I don’t know what the other stuff does

If you restored all the partitions you backed up, rather than just the Data partition, then I guess that whatever was wrong in the original device has now been flashed on the new device.
Sorry - I really have no idea how to fix this :frowning:

The only suggestion I can offer is to re-install stock ROM then re-install /e/OS from scratch:

reflashed stock ROM using flashtool (as describe in this xda forum post, choosing to wipe APPS_LOG, DIAG, USERDATA - NOT SSD (flashed 32.0.A.6 version, should probably have gone with 32.4.A.1.54 version). - No, it worked. Phone eventually restarted in stock. Powered it off, and I could flash TWRP (fastboot flash recovery TWRP_3.6.2_9-0-recovery_suzuran_2022-05-28.img), then format data, and install the new ROM

Oh boy, it just does not want to go easy…
In the meantime I went back to stock ROM (was easy because I already had done it before and everything was prepared in Emma) and then flashed TWRP and ROM and again the device does not go into recovery.
If I just flash TWRP again it works but OS does not…

I could never get Emma to work with any of my Sony devices, once the bootloader was unlocked. Does it reflash all the partitions or just the System partition?

I have always used Flashtool, which I’m pretty sure does flash all the partitions, including recovery. Maybe worth trying?

Ha, at least some victory! I am back on the OS I was and also restored the data via TWRP. Had a lot of tries to do and dont really know what made the difference in the end.
Unfortunately, because the learning curve keeps quite flat this way…

And still the update installation from r1.4 ti 1.5 doesnt work, which was the the beginning of all this mess!?

1 Like

Are you trying to install the update using the Updater app? If so, maybe try installing manually via TWRP

Until now it always worked via the updater app. And I read from others here that it worked just fine. Made me curious…
Now I installed it via ADB Without wiping anything (is that dirty maybe? :slight_smile: ) and its running fine. No data loss so far it seems…