Phone app - have to unlock to answer

Any difference with

Settings > Buttons > HOME BUTTON,

Enable both; Wake device and Answer call.


Thank you aibd,

Was in a restaurant just now with my phone blaring out and unable to answer. Many thanks

Though its strange that the answer / reject buttons are reachable when the screen is locked for Signal, but not for the phone app.

No, doesn’t work. The user experience for the most basic of functions in e/os is dreadful. With the other problems e/os will always be a very niche product and may even disappear.

I don’t think anyone I know would be willing to put so much effort into using a product. People just want things to work.

I have two /e/ devices and on both I can answer calls without unlocking the screen. Pretty sure this is deafult /e/ behaviour.

Just a guess…maybe this setting is interfering with your lock screen?

Even if /e/ worked 100% flawlessly it will always be niche compared to the billions of apple/g users.


But if it worked flawlessly many of us would recommended it to friends and family. No one I know, would be willing to spend the time required to get the phone working like they wanted.

Then when you change your phone, you have to remember the apps and their settings and the system settings you had, and manually set up the new phone as there isn’t a global backup feature. The majority won’t do that. They would laugh in our faces.

Seedvault is coming soon…

I do hope so.

Whilst initially I set up a file listing all the the great apps I had found, the store to get them from, the settings within those apps I set, the settings I set in TrackerControl for those apps, and their settings in phone system and the general phone settings.

I now have 157 apps and haven’t updated my list in a long time, as I don’t have the time. It is labor intensive to log every change, and would be a large project to restore to a new device. No normal user is going to bother with that.

Anyway now on phone calls I don’t get anything appear on a locked screen (remains blank) when I have a call (I get ring tone). Its causing problems with my other half as she is getting pi**ed off if I don’t answer. The basic function of a phone is to make and answer calls. My e/os devices are making it difficult to do that most basic of tasks!

Which device(s) do you have? I have /e/ installed on several Sony devices, and I can answer calls from the lock screen on all of them. Maybe this is a device-specific bug

Just try another phone app, like “simple dialer”.
is the better app anyway. and if it works you are twice happy

1 Like

Yes. A smartphone is a computer device, not a toaster. While it is undesirable to have to set up a phone from scratch, it can’t hurt to be able and ready to do it, should the need arise.

Until Google backup fails to work for them. It happens. What then?

Seedvault should help, but it is not a global backup feature.

Did you check the setting @mike_from_ireland pointed to?

I don’t like seedvault. much expected nothing received.

Indeed, my suggestion was just a “get you out of trouble fix” I have no such issue with not able to answer the phone on my Samsung (and I do not use my suggested fix).

I was initially anticipating the answer might be in conflicting settings within lock screen (or only a little wider?) Please can you check out the suggestion by @mike_from_ireland.

Yes I did what Mike suggested. Still no joy.

No shit sherlock, no wonder I couldn’t get my bread in!

What about Settings - Apps and notifications - Notifications - Notifications on lockscreen? Is it on “Don’t show notifications” perhaps?

Some smartphones are getting very hot during charging, so you can toast our bred very easily…

1 Like

Thanks on my S9, I have Settings - Apps & Notifications, but no Notifications on lock screen option.

Just to be sure … there’s “Notifications” as an inbetween step, “Notifications on lock screen” isn’t directly in “Apps and notifications”.
Could also be a difference in Android versions, I’m on Android 10, perhaps you can just search the settings for lock screen.

I have tested on another couple of devices on a fresh install of /e/ and it all works flawlessly. Please tell us what version of /e/ you have, otherwise it will be hard to provide useful help. Thank you.

Also, if this is a device that you bought from /e/, and this has never worked, then you should contact, as it is definitely a bug

1 Like

My version of e/os is -


Android 8.1.0

The devices weren’t bought from, I set them up with easy installer.

Good news, the problem is finally solved.

Apps & Notifications - Phone - App notifications - incoming calls - Importance, was set to Medium, now set to Urgent.

Hope that helps someone in the future.

Thanks for all the helpful suggestions.