Problem installing /e/ on Galaxy S10 (SM-G973F dual-sim)


I tried installing the build on my S10, but it failed. When I started the adb download

adb sideload 

all is well up to 47% but then I get this on my PC terminal

serving: ''  (~47%)    adb: failed to read command: Success

and on the phone it says

Veryfying update package...
E: failed to verify whole-file signature
Update package verification took 58.9 s (result 1).
E: Signature verification failed
E: error: 21
Install from ADB completed with status 2.
Installation aborted.


Did I do something wrong and is there some way to fix this problem?

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

When you search that error message on the forum, this is the list of matches:

In TWRP did you untick "Signature verification? Edit, you probably did not have that option, but we do not expect to see verify whole-file signature
so probably more important, did you use TWRP or /e/ Recovery? and are you certain you successfully made your first boot into recovery? - the wording here does not look ideal.

Did you try to boot it, despite the error?

Also we see this in “beyon2lte” Samsung - Galaxy S10+ - beyond2lte - Documentation Suggestions - #2 by Manoj

I may have missed something, but I didn’t see anything related to TWRP in the S10 installation document. Should I install TWRP although it doesn’t say that in the document? I used the /e/ Recovery and I successfully booted into recovery. The phone still boots also to stock Android, no problem there.
I’d like to try again, but I don’t know what to do differently so that I might get a successful installation?

You were quite right to use /e/ Recovery and it is good that you saw /e/ Recovery installed.

We have 2 clues to your problem. Firstly

(~47%)    adb: failed to read command: Success

This is usually a success message - the failed part is at the PC or laptop - it could possibly suggest a minor failure of full two way communication between your device and your PC. You might try a different USB cable and you might check your USB port is the best available. (Some PCs have a front usb port connected less optimally than rear ports!)


E: failed to verify whole-file signature

Did you check the hashsum of your download? A corrupted download would give this result.

Less obvious

E: Signature verification failed

an /e/ Recovery should not have asked for Signature verification - so this might just point again to a corrupted download or corrupted transfer of the /e/ ROM.

I included the list of search results in case you found clues there common to your case. :slight_smile:

Edit, the errors could point to a failure at the Wipe data stage.

Thank you very much for your help & ideas/suggestions. :+1:t4:
I did check the sha256sum and it was a match, so the ROM shouldn’t be corrupted. Just in case, I’ll download again and verify. Also, I’m going to use a different USB cable next time I try, I’ll post results here.

Just back to one prerequisite, the device should be at Android 11 for /e/ R.

I think I know what the problem is: although I have the developer mode, USB debugging etc. modes on, when downloading the recovery image to the phone, I get a message at the end of the download saying “only official binaries can be used for flashing”, so when I reboot, the recovery image in use is the original samsung recovery image and not the /e/-Recovery image :frowning:

Is there some setting in developer mode that needs to be turned on/off to get /e/-Recovery image to work? Any other ideas what I could do?

Please can you look at the Odin mode (Download mode) screen and look for anything that says a lock is applied. (Send an image of the screen if you like.)

Yes, it says OEM LOCK ON(UI).

Is there a way to unlock oem lock?

I do not have them available ATM, but the OEM unlock instructions should be on the install instructions. If they are missing or unclear a search will find them.

Gr8, thank you so much for your help :slight_smile:
I will find them.

This seems to be a deeper problem. There’s no OEM unlock option in the developer options for this model of S10, apparently the models with Exynos chips have it, but Snapdragon chips don’t. I tried with the generic instructions - also using the command line option - from the /e/ documentation, but it didn’t work. I guess I’m stuck here :cry:

So it appears that your device is not supportable, IF it is not a beyond1lte

Possibly, although the samsung original recovery ROM is named something like samsung/beyond1ltexx/beyond111/…G973FXXSEFUL1…
so it looks like it is beyond1lte yet I can’t find a way to turn off the OEM lock.

What is the reason you mentioned Qualcomm? What is the reason you originally described it as SM -G973F? Please be specific! Any further info on the Odin mode screen?

The device is as I originally said, SM-G973F/dual-sim, at least that’s what it says in Settings > About phone. The phone simply doesn’t want to allow OEM unlock no matter what I try. Odin mode screen says the same: OEM LOCK ON(UI)

Does not allow it, or does not have it on the menu? The preinstall instructions are very specific about the role of the USB cable. Does the word Prenormal appear on the Odin screen?

Device specific: Install /e/ on a Samsung Galaxy S10 - “beyond1lte”

Finally success :sunglasses:

It all boiled down to finding how to enable the OEM unlocking. The installation document fails to explain how to enable OEM unlocking, when this item is missing from the menu. I got it there by removing the automatic date & time setting and then selecting a date 8 days back.

Anyways, thanks for all the tips and support :slight_smile:

When you point to perceived gaps in the documentation (especially in the case of a relatively “new to /e/” device it is always nice to leave the best information for the next person who finds this situation.

Is there any improvement that can be provided to this article (is it up to date?) and/or how do we make it more findable. OEM Unlock - toggle now missing. Or there is Documentation Suggestions. Thanks.

The only distro I have successfully installed with this procedure is the latest Lineage “lineage-19.1-20221230-nightly-beyond1lte-signed”. I was unable to install any /e/OS distro (e-1.6-s-20221130239247-dev-beyond1lte) nor - for testing - Lineage OS 18. In these last two cases, the installation is fine from the Recovery but the Samsung does not boot anymore. I started from a ROM-STOCK G973F_XEF (android 12).
Do you have any idea how to install /e/OS on this Galaxy S10 (Exynos)?