Problem installing /e/ on Samsung A3 2016

Hi @Adriano,

I took the time to be precise on each of this points.

  1. Reboot when connected on Wifi : not solved
  2. GPS/Magic Earth (with data connction without wifi)
  • 1st test : I saw the map zooming on my position \o/… and reboot :frowning:
  • 2nd and other tests : I just see the loader and the phone reboot each time
    So same problem
  1. GPS/Magic Earth without any data connection : it locate me

It seems to have a problem with internet connection in many ways but next to that I can :

  • surf on web pages
  • consult weather via the weather app
  • check my emails
  • and share the connection creating a Wifi Hotspot (The other devices using it deeply -> no reboot :neutral_face:)

It’s difficult to understand exactly what is the problem


I did exactly the same tests and got also the same results as you did.
In the meantime I updated my phone with the latest /e/ nightly Software from 6th April 2019.
But the problems are still there.

Unfortunately I don´t have any devices which are able to create a wifi hotspot :sleepy:
Lets hope they will be solve the problem soon.:pray:

It´s good to know, to have someone else in the same situation. :sweat_smile:

Hi! Is the reboot when connected on wifi bug solved? I cannot find any issue on GitLab about it.

I would like to test /e/ on an A3 but am waiting for this bug to be solved before compiling trying to compile Heimdall 1.4.2. :wink:

There is a similar issue here and as yet not resolved. Do not have an ETA on this. F.Y.I @rhunault

1 Like


I confirm after testing the last version and it still reboot if :

  • I use wifi
  • I use GPS and mobile data at the same time

This wifi issue is still relevant?
If yes we could consider A3 2016 build as unusable

Maybe someone should try to build /e/ using the LOS device tree that works without Docker and test this issue out.

@Manoj I tried to but I failed. I have a LineageOS unofficial working well (not perfectly) on it.
I’m interested in learning who to move forward.

Hi @Bud, if you are interested in building the /e/ ROM for the Samsung A3 2016 you will find articles on our forum here ,here and here.
The method to be used in your case would be the non docker method as described by @andrelam & @harvey186 here because you will need to do a few iterations with different device trees. We seriously need a device maintainer for the devices which have such issues especially the Samsung phones which are rebooting on connecting to wifi like the A3 .
I had contacted the developer from Lineage who had fixed the issue but he mentioned his sources have been upgraded to the latest Lineage version i.e. LOS 16.0 or Pie. Once we have completed our Pie upgrades of the source code and apps, which I expect should take the whole of June I will be contacting him again if required. Most probably the issue may resolve but we will still need to test it.

1 Like

Just for the record, I had an unofficial ROM found on XDA Lineage 16 installed on the Galaxy A3 2016, I never encountered any Wi-Fi problems or anything except that the phone was relatively slow. After the problems with /e/ I put back a ROM Lineage 15 and the phone became fast again.

So, if after switching from /e/ to Pie the wifi problems are solved but the phone is unpleasant to use because it is too slow, is this useful?
It may be better to remove this phone model from the list of compatible phones.

Thank you @rhunault. I had the same problem as bud with a Samsung Galaxy S7 (herolte) and let runaway weeks before taking time to figure it out and retry the install… May I suggest to indicate the Heimdall version in the instructions? I think some people should earn time :slight_smile:

Anyway, thanks again for the help, my phone feels free now :wink:

i have installed /e/ but when i want to use the wifi my phone reboot continualy. I have no time to note down my pin code, thé phone reboot.
If you have an idea…thanks

Sorry for my english :rofl:

  1. Have you ever tried a “Facory Reset” after installing /e/ OS ROM?

  2. Which baseband version has your A3 (2016 Exynos) “a3xeltexx” SM-A310F ??

  3. Try translation with (free version)

Hi @macmad64 there is an issue with some samsung devices where they reboot when connected to wifi .There is an open bug on this which is pending a resolution.

This is a time-saving and therefore valuable information; at the same time, however, it is also sobering when you look at the timeline.

Hello all,

I just installed e on same device and when setting wifi, the phone restart and restart …
Now i’ll move back to stock rom because this bug is still pending since a year …

Hello @lapinmoutarde,
This issue is gone with the Pie test build. I think it should be released in a few weeks or months in the worst case. Stay tuned !

1 Like

Please see also → /e/ on Samsung Galaxy A3 (2016 Exynos) SM-A310F “a3xeltexx”

1 Like

Thanks for response.
You should better remove this phone from the list of verified phones, because that does not work at all.
And I will surely not wait for x monthes for a fix. This is very frustating.

Thank you archje, I will try it right now

1 Like

I had the same problem, I installed lineage without gapps. Only way to un-goo this handset as nobody seems bothered enough at e to fix this glitch.