Problems getting /e/os running on S9

Hi everybody,

I want to try and use /e/OS on a Galaxy S9, I have installed easy installer and followed all instructions carefully, but I get stuck at the time the E-recovery should start.

I am aware that there are other topics on the subject and I have tried a lot of stuff, like finger flashing the volume down to up at the restart and with lots of different cables.

I can start up the phone in the download screen and wdi-simple.exe seems to do it’s job too.
But when rebooting with volume-up+bixby+power at once the android galaxy S9 splash appears and the phone will run into android recovery.

If there are any more suggestions, they would be welcome, if not I think I have to do it manually somehow? I have read the instructions, but it kinda gives me a headache seeing that I have to use many multiple tools? ADB, Fastboot, Odin, Heimdall?

Here is the download screen:

any help or guidance would be appreciated.
Thanks in advance.

If you tried everything else in Samsung threads, you might check other easy-installer threads, and meanwhile dig out the log Howto troubleshoot issues with the easy-installer.

That are generic informations.
Concerning samsung device only one is needed depends of you favorite Computer Operating System :

  • Windows → Odin
  • Linux or MacOS → Heimdall

using it, you will replace the device recovery-manager, and that’s it !..

  • then you can easily install /e/ from that recovery-manager

Hello Piero,

You were right. Thank you for your reply.
I installed Odin on win10 and managed to install /e/ succesfully. Also thanks to a Howto guide I found in these forums.

Now that I review the stuff I went through, I think the part I was missing were the Samsung USB drivers. Odin only recognized the phone in the download mode after installing them.

Perhaps that is why easy installer didnt work at this step. I noticed a downloadbar on the phone usong Odin, which I didnt see before with wdisimple.exe.

Thanks for the help!

1 Like

This topic was automatically closed after 90 days. New replies are no longer allowed.