Problems running GSI Image on Xperia XZ1 Compact (lilac)

I have just installed the GSI for not yet supported treble phones [2020/06/14] system on my Xperia ZX1 Compact, as described in this topic

Trying to use it I have come across the following problems

  1. Screen blanks when making a call - maybe receiving too. No acccess to dial pad. NO way to end call.
    • See if it happens when receiving a call - yes. Screen goes blank.
    • " with Simple Dialler Yes. It onnly happens when you move your phone.
    • When Phone is default, status bar shows incoming call. Allowing answer & decline. If you answer, screen goes blank.
    • When Simple Dialler is default, no way to answer phone in standy
    • There is an issue about this, also with a Sony Xperia, though different model. I have added a comment.
  2. Smart restart to recovery only works intermittently. Mostly it restarts the system
  3. Can’t backup Data partition . Tried just restoring data, and boot, system & data. When I look in security settings, it seems the device is encrypted. Created new Issue #1610
    • CreateTarFor() process ended with error 255'
  4. When I boot, sometimes I see the \e\ start-up animation. More usually I see Sony boot screen, followed by ‘Powered by Android’ animation, followed by ‘Xperia’ startup animation. These are what you see when this device is booted in a Stock ROM

The result is that this phone isn’t usable for me yet as my daily driver. i will try the following in the coming days i will try the following:

1.Try to flash an unofficial Lineage ROM, either one I built myself or one from XDA. There are working 1.0 and 17.1 ROMs there
2. Try to flash the Unofficial /e/ ROM I built for myself
3. Revert to Stock ROM in preparation for a new GSI image

Yes, the GSI from that location are with root and automatic encryption. And they don’t have a Password for decryption (stupid !!!). Only the GSI from my location/post are not with encryption.

Regarding the other issues, I think the will cause because of wrong firmware. The best would be, tho start over with original Sony pie firmware.

To make sure I don’t get caught again is that the system image at ?

If I didn’t make a mistake myself, the good ones are listed here.

That’s wrong. Here are my latest builds located

It’s the location anonyme has in his list

Do you know which (if any) of those are UNencrypted? There’s no point me having a device where I cannot backup and restore my apps and date. What I need is 'Type A, unencrypted, no root.

All GSI builds made by Harvey are unencrypted by default and without root (if root was activated, I would have tagged them as custom and not unofficial by the way).

Arm64 a-only is this one

1 Like

I’ve now tried that (with several different versions of the original firmware), and it seems that the problem is with the phone. Whatever firmware I have, I get the same problems. So this device is for the ‘spares’ box. I’ll try again if I can get hold of another device - preferably one that can make and receive calls - for a reasonable price. In the mean time, it’s back to my Z5 Compact (with unofficial nougat /e/ ROM) as my daily driver.

Yeah, that’s the problem eith GSI. It’s not really ‘generic’
On some devices it isn’t booting and sone devices have other issues.
That’s why there is no real official GSI.