Recover data from corrupt system eos

Hi My Nord oneplus was loaded with eos e.1.10 stable avicii.

However it cannot login to OS anymore. all it shows is e logo with a dot going up and down below it.

Its stuck.

can i know how to back up my data now ?

will deleting wiping cache help or will it delete everything ?


Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

I see two ways forward. Recover data or replace the system image.

Assuming you have a certain amount of essential data backed up I would go for the second. The risk will be not too much more than a usual /e/OS update (unless something else is the underlying cause of the fail). I have to wonder if there is any reason why you are a few months behind with updates?

You say " e.1.10 stable avicii" (please confirm for yourself that you were running Android S, as listed in this link You could download the e-1.10-s again as a replacement, or take the opportunity to update.

Now reflash the phone, this is the method for a manual update.



Boot into Recovery
Select Apply Update and in next screen Apply update from adb
In the next screen, the device is now in sideload mode

Note at this point the Cancel option is highlighted that does not mean you have canceled the action. The device is in adb sideload mode.

On your PC begin adb sideload.

Type the below command in a console

adb sideload

Replace with the name of the /e/OS file you downloaded.

Press enter key on the keyboard to start the sideloading The screen will show the progress percentage…This might pause at 47%
Give it some time
The PC console will now display Total xfer: 1.00x
The phone screen will now display some text with a message similar to

    Script succeeded result was [1.000000]

This means that the install was successful.

In /e/OS recovery main screen:
Select Reboot system now
The reboot process may take 5 - 10 minutes

Thank you so much. what about option ONE to recover data how to do that ? atleast i mean try it.

I would not be confident on advising on option one, and still no reply on your other thread Oneplus Nord with eos stuck at boot.

Reflashing the system with no wipe or format as described above is expected to retain your data.

Edit, bearing in mind the post now linked to your OP have you any guess why the failure might have happened ? I have had this happen spontaneously,but as I said earlier

(unless something else is the underlying cause of the fail)

i am agree with @aibd try solution 2 !.. just reinstall /e/ over your old installation with no wipe, no format.


another way i see as a solution 1 ( correct me if i am wrong) is flashing TWRP :

(only if your bootloader is already unlocked)

  1. you will see the internal storage of the phone from the file-manager of your PC (internal storage is called sdcard, not external_sd)
  2. with TWRP integrated file manager you will see the entire phone storage and you will be abble to move importants things to an accessible place (internal storage is called sdcard, not external_sd witch is external SDcard)
1 Like

Thanks, I tried to just reinstall e os over using 2nd option. It succeeded and i reboot. However, the e os still stuck at booting.
So i tried using avicii latest version but same thing after reboot its still loading stuck at e logo.

yes i did that so installed TWRP and then used adb pull from storage folder using “adb pull /storage” command. My phone dont have sdcard but i also did “adb pull /sdcard” command and its exact same contents in both.

A little tricky commands available on NET to search to backup contacts and sms messages. but some commands are readily avaialble on the NET.

i was thinking about the TWRP graphical advanced feature “file manager” to move/copy the “concerned folder” to “/sdcard” witch is accessible by the PC
/sdcard volume is a little part of /data partition where apps are installed and store their files
i don’t know where SMS are stored … @tcecyk ?

@piero sms storage is centralized in an android core package database (mmssms.db) and there are utilities than can make a readout or fetch it directly with root - the likes of qksms / the e-messages fork is copying this content to its own database.

@noidea as to “corrupt system”: there never is an error message, just the e-logo bounce until you manually interrupt and reboot? if you can boot twrp, try to delete a bigger video file. I wonder if you’re in the user cohort that runs into space issues. But those do get an error after the boot completes at least past the lockscreen

1 Like

or delete the old downloaded OTA update files in /data/lineageos_updates

This topic was automatically closed after 60 days. New replies are no longer allowed.