Requesting an app (app already requested)

Hello All,

I am a fresh /e/ user on Murena.
So far the experience is pretty good, but particularly missing some of my banking apps.
I am trying to request these, but the form keep telling me these were already submitted.
How may could I check the status, or perhaphs there is a blocker preventing it from being added to the app repository?

The app name is pl.mbank


Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

1 Like

I remember requesting mBank app a long time ago but it’s still not there. Right now I’m using Aurora Store to work around this issue.

1 Like

Thanks for this, did not think about it, at least that is some workaround! :slight_smile:

I requested that apps a least 18 months ago and it still not in aurora, what is the process behind a request and how it work ???

Thank you

PS the app is fr.duniter.cesium

There are two issues here:

  1. If you requested /e/ to add an app, then If they ever get round to it, it will be in the Apps store, not in Aurora Store
  2. Every app that is available in Google’s play store is already available in Aurora Store. However some app are ‘geo-restricted’ (i.e. only available in specific countries). To access those apps in Aurora Store there are couple of hoops you need to jump through. See this post for details

You may also need to change the System Language in your phone to match the selected locale

If you’re having trouble finding apps in Aurora, what I’ve done in the past is go to the Google Play Store in the browser. When you do so, Aurora store should sense that the link can be opened by an app, and allow you to open it that way. Most apps install this way, I think the only one I couldn’t get was New York’s app for hunting and fishing licenses (not a big deal, that can be managed over the phone).
It’s my understanding though that a major revision of Apps is in the works, hopefully this eliminates the need for Aurora, I hate having two app stores.

This topic was automatically closed after 60 days. New replies are no longer allowed.