Restore image file of current wallpaper

Hi all,
I have picked one of my gallery photos to use as wallpaper. Unfortunately I deleted the file in the gallery but the image is still in use as wallpaper image. Is there any chance to get the current wallpaper to restore it as image file?

I tried to use Total Commander app to browse the system folders but wasn’t able to identify/find the current wallpaper image file

/e/os v1.17 is used at my fp.

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

On my A11 ROM the wallpaper is located at /data/system/users/0/wallpaper.

I copied it out to a writable location and added the jpg extension to it (as I looked inside it first with a text editor and saw it was JFIF). Then it turned into a thumbnail which verified it was the current wallpaper.


Tried this on my Fairphone 4 but there isn’t such path… :frowning:
Are there different paths depending on the phone used?

I just checked on several different devices running Oreo, Pie, Q, and R. The location of the wallpaper is the same on all. I do not think there are device-specific locations.
You did not say what Android version you are using. Maybe the location has changed in A12+?
I have put a freeze on Android so I cannot check.

Android version 12 is installed. Perhaps I have to use other apps to get to the location /data/system/users/0/wallpaper ? Using Total Commander app doesn’t bring me to this path. But I am not a pro… :frowning: So I will be happy for any suggestion regarding alternative apps to be used.

Are you rooted?

Oh, the ROM must be rooted to access /data/system/user/0/. Otherwise the contents of that location will be blank.
If the device is rooted, i.e. has TWRP, then you can access that directory from there.

Yes, always. :sunglasses:
Bah. 20 character filler.

So it seems to me the App would not be the issue, but missing root access to the required path would be.

I can’t write a step by step guide right now, but I guess the best bet in this situation should be to enable the Developer options, and in them enable Rooted debugging, to then access the phone via ADB from a computer and use adb root to be able to access the required path?

Yes, with a rooted ROM I was able to get the file.

Thanks! :slight_smile:

I rarely use adb but yes, that sounds like it should work via adb root.
Haven’t had the free time to check.

This topic was automatically closed after 90 days. New replies are no longer allowed.