Roll back to the previous /e/ OS v.0.23 from v.1.0?

Any suggestions on how to roll back to the previous version after updating to v.1.0 ? Is it possible?
Using a Fairphone 3+ and since updating there are bugs that render it nearly unusable :frowning:


The OS version before the last update should be available on the now inactive OS slot of the two OS slots. Be prepared to do a factory reset (may or may not be necessary).

I tried to go back from 1.0 to 0.23 by changing the active slot in fastboot mode. But 0.23 did not startup anymore. During booting it gave me the option to factory reset all data, which is no option for me. So I changed back slots to 1.0.
Seems I have to wait for fixes in the next version for all the problems occurring in 1.0 on FP3: Apps using cameras not working properly, poor overall performance, bad wifi connectivity, …


Thanks for letting me know, that’s a shame!

Same here. The main thing that is driving me crazy is the audio glitching/stuttering during playback. Plus not being able to use Signal for calls.
Hoping these issues will be addressed in the next update.

1 Like

Thank you very much for the info. Unfortunately in my case I don’t have a recent backup so would prefer not to do a factory reset.

Tbh, I’m having wifi issues on 0.23 on my FP3 as well. Wifi often drops out unexpectedly which is a PITA, e.g. when using digital mixing consoles as the reconnection takes time.

Connected to an AVM Fritz!Box on 5 Ghz by chance?
If you are in control of the router, try standard “802.11n+a” instead of "“802.11n+ac”. Furthermore make sure that the 5 GHz channel isn’t set to 116 or higher, Fairphone 3/3+ as well as other devices don’t like that, at least with Fritz!Box routers … My FP3 doesn't like higher 5Ghz Wifi channels, especially channel 116 - The Products - Fairphone Community Forum
But this is general, shouldn’t be bound to a specific Fairphone OS or /e/OS version so far.


Thanks for the tip! Unfortunately this happens independent from the corresponding router and started coming up lately. I might be mistaken but am under the impression that Wifi was more stable before. That’s pretty subjective, though.

Yes, I’m also on a FP3 (using Lawnchair launcher, in my case), and also finding that /e/ OS v1.0 has massively downgraded the functionality of my phone. To pick a few examples:

  • The phone resets anytime anyone calls me or I try to call anyone via an app (whether Telegram, Signal or WhatsApp), though after a reset there is a short period during which I can start calls
  • The camera also only works for a short period after a reset, then won’t take pictures
  • The phone’s basic caller ID no longer works, so all telephone callers come up as “Unknown”
  • The phone is generally slow and unresponsive

I’m so disappointed to hear there’s no rollback option without factory reset. As @ManuelS says, it seems we may be waiting hopefully (desperately!) for the next update to fix some of these issues.


Thanks for the advice @AnotherElk .
I changed the settings to “802.11n+a” and fixed a low channel number instead of automatic channel selection and will see whether that solves at least the WiFi problems.

Be aware that the Fritz!Box may still change that to an undesirable channel from time to time due to supposed interference and not automatically return to the fixed setting. At least that’s the case for me. I informed AVM and suggested a range of channels for the auto-select to be set by the user, but no change so far for several firmware updates since.

1 Like

Thanks once more @AnotherElk .
This is exactly what happened after pinning the 5 GHz WiFi to channel 52. Some time later, my FP3 could not transfer data (apps show offline state and DAVx5 can not synchronize) although the WiFi connection is established. One look into the FRITZ!Box UI and the 5 GHz WiFi is back on channel 116. :rage:
Now I switched off the 5 GHz WiFi to see whether that helps.

i agree to all. FP3 is nearly unusable after the update. issues with all cameras, crashes, freezes… damn!!!
anyone here who could help how to move to FP3 very own OS???
i am a bit sick of /e/OS

Strangely enough, I don’t have any of that trouble with 1.0 on my Fairphone 3. Runs rock-solid, battery doesn’t drain, camera works, Wi-Fi works … I wonder whether I’m spared due to my limited use of messenger and (a)social network Apps. There has to be a cause, one would assume.

Would be interesting to know what are the reasons for these problems.
I don’t use any other messenger than Threema (bought in their web shop, not Google Play), no social media apps and tried different camera apps (none of them works properly anymore).

I agree: Using an esolutions S9 phone, version 1.0 is the least stable of all the releases over the past two years. The app lounge is very buggy, as is the the bliss launcher.

Ok, that was fast. My Fritz!Box keeps the channel mostly for weeks, at least for days, but interference of course will differ from place to place.
AVM Support told me that the reason for the box not simply going back to the fixed channel after a while would be that the box would still detect the interference there, but I can always just fix the channel again, the same one as before, and it will be stable again for a while.
Wi-Fi being complicated tech as it is, I can just live with something like this if I can make it work in some fashion, but I always wonder where this all is headed going forth. Well :man_shrugging:.

If you can live without 5 GHz, and if the 2.4 GHz range isn’t too overcrowded with other networks at your place, it should help.

Ok, so the general App category doesn’t seem to be it.
I have a bit of occasional Signal use and I even have Discord (yeah, I know) running in the background, doesn’t seem to be a problem for me.

Android can be booted into a safe mode, which can confirm whether Apps installed by the user are the cause for an issue (if the issue is gone in safe mode) or not (if the issue persists in safe mode).
It isn’t as intrusive as a factory reset, but it might still be a bit of a pain with App login credentials and some other setup stuff, resources …

Curious to know if you’ve experienced any issues with audio playback on v.1?

Any audio playback at all, or what to check exactly?
MP3 playback from external SD card seems fine.
Same playback on 2 different devices connected via Bluetooth seems fine.

I can confirm that:

  • I can’t rollback to 0.23 from 1.0 without factory reset
  • Element ( isn’t working anymore for video call. Only audio calls. Video calls are clearly crashing the whole phone.

I’d like to use my FP3+ as before :confused: