S7 easy installer stuck on boot screen

Uh, this gives me hard times. I wanted to install /e/ on the S7 with easy installer. However when I got to the point to press Vol+ home and power it would start into an installin screen and giving me the notice nothing to install. I tried it three times running through the easy-installer instructions. I do not know, waht I dit wrong bu now the phone just gets into the samsung boot screen and nothing happens. When I try to power it of it does not work. I tried volume down home and power. It immedeatly restarts. Sometimes it powers of but it never goes throught to start the os. It keeps in a boot-loop which I eventually can shut down via volume down home and power.

I do not hope I bricked it. Fingers crossed. Any Idea?

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone


everything went smoothly until restarting to install the image it never went through to the teamwin screen.

Ok, I managed to boot into recovery and was able to restart into boodloader and restart the phone. However I can not install via easy installer. I use Windows 10.

After the program (easy-installer, Heimdall, or Odin) have flashed the custom recovery manager, YOU MUST IMMEDIATLY reboot to recovery mode !
If not, (other boot mode attempt) it will be overwritted by the classic samsung recovery manager.

You have to restart the flashing process

[HOWTO] Install /e/ on a Samsung smartphone with Windows easily

Ok, I dont get it. I am turning the phone down and immedeately press vol up home and power and I get into a blue screen with Android logo trying to install an upgrade and after a while it tells me there is no command with a broken Android an a yellow symbol aufter few seconds I get into recovery mode and can choose boot options.

Do I have to skip turning the phone down?

I mean, I am really quick, changing from turning of to turning on…

On samsung, there is no bootloader mode but download mode.


If you use newer version, you will flash the /e/ recovery
(recovery-e.img using Heimdall OR recovery-e.tar using Odin)

. [HOWTO] use e-Recovery to wipe & format data before sideloading/install eOS

Thats what I get:

Restart with power/home/vol down and vol up to continue:

After upload successful (easy installer tells me the procedure), unplug USB and
I press power/home/vol down
and as soon as screen turns black
I press power/home/vol up by just sliding my finger to the vol up button (no difference if I just slide or loosen all buttons and press again)

then I get

after a few seconds

and after that

So I do not know what is wrong. I am doing it really quick but I always end up on the blue Android screen.

Am I missing sthg? Do I need an SD-Card?

Your Odin mode screen shows Samsung still in charge!

As you suspect and @piero says, it is all down to timing!

It is explained in the Your first boot into TWRP paragraph in this page.

I am really trying, but however I can not boot into TWRP - no matter how quick I am? Is there no way to shut down the phone (no restart) and then power on with keeping fingers on vol up / home / power? Just wondering.

You mention quick, but actually you only need to commence the boot into recovery at the correct time! My guess is that you are doing the same thing each time.

Pulling the battery is an ideal way to do it, but not possible, I think, with an S7.

Can you get someone else to read the instructions and try – a child would be ideal!

Thank you for your sympathy. However, I think there is something wrong in the process, like TWRP not downloading properly. I will check with ODIN or pure manual install. Did this several times with LineageOS and other phones, so maybe I get ther right timing then. I thought “Easy-Installer” would be, like an easy installer. I imagine Murena selling Galaxy S7 pre installed and 10 people sitting in a room repetetive pressing vol up / home / power on the same phone to get /e/ installed - waiting for the right timing when moving the finger from vol down to vol up.

Thanks for the links and the explanations anyway. I will let you know if there is any sccess.

Ok, success. Obviously, as I suspected, there was sthg wrong with downloading twrp on easy installer. I installed TWRP with odin and I saw the download going on while in download mode, which i did not while using easy installer. Getting into TWRP was then however very easy. So I don’t know why but - maybe the usb-drivers (which I updated several times) were not installed right - now it is working.


Hi, I am encountering the same problem. I’m trying to install /e/ through the easy installer on a samsung S9 (from a windows 11 computer) and always get stuck on the Android recovery screen.

Can you give some more details on which steps you took to solve it?
Should I ditch the easy installer and instead install odin and twrp and go through the installation manually as suggested here: [HOWTO] Install /e/ on a Samsung smartphone with Windows easily ?

Thanks in advance, any help is appreciated :raised_hands:

Hi, it worked for me with odin and

easy installer did not work for me. It seams (I made no deep analysis though) that the phone could not download TWRP. With odin it worked just fine. I recomend to install samsung drivers manually and not just assume that everything will work out of the box if windows installs the drivers automatically. Maybe this also was a problem for me.

In any case look for instllation guides with odin for the S9 as I can not tell if maybe there is a difference compared to the S7 and the steps to take.

Fingers crossed it will work for you.