S7 migrate from LineageOS 17.1 to /e/

On the Galaxy S7 installation page there’s a warning at the top that downgrading from LineageOS 17.x could brick the phone.


I had tried to install /e/ on this S7 last year but was unsuccessful, so I installed LineageOS and that worked. It turned out that I was using the wrong version of TWRP for that version of /e/ but by the time I found that out I had already setup everything on LineageOS and didn’t want to do it all over.

Is the bricking issue no longer a problem if I want to migrate it to /e/ Oreo? I’m looking at version


I obviously don’t want to brick my phone and I’d like to know specifically what version of TWRP to use if installing /e/ after LineageOS 17.1 is OK. Also, are there any specific additional steps that are necessary to prevent the migration from bricking?


Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

First of all, make sure that you download the device-specific TWRP version,
i.e. either for Galaxy S7 ‘herolte’ or for S7 Edge 'hero2lte.

From my own experience I can say -
TWRP 3.3.1-0 and /e/ OS e-0.13-o-
make a good team.

Thanks. The problem wasn’t having the wrong device file, the problem was I had tried to install Oreo on the S7 using TWRP 3.4, which at the time was new and I wasn’t aware (and it wasn’t made clear) that the two were incompatible.
However, now I’m stuck.
I tried reverting to TWRP 3.3.1 and it just gets stuck in a boot loop, unable to go into recovery. The message is about kernel header length, I think, but I’m just going from memory. So I reinstalled 3.4 but then the phone only booted into TWRP and I couldn’t get the OS back. So I reinstalled 17.1 (unoffical) and has success getting that booting, but I haven’t done anything else with it.
What I’d like to do from here is either get a functioning official /e/ installation or migrate to the GSI version you mentioned here, which I suspect might be a long term solution.

Any suggestions on how to proceed? I think I have a couple of options. Maybe.

  1. Somehow downgrade to TWRP 3.3 and go with the official /e/ build
  2. Stay with TWRP 3.4 or greater and move to a newer unofficial release or a GSI build. I don’t know the requirement for a GSI install, so I don’t know if that’s feasible or how to go about it. I’ve done more Linux installs, including partitioning, over the years than I could count, so I’m familiar with the ideas that seem to be at play but don’t know the details of their implementation on Android.

Download the TWRP 3.3.1-1.img to your SDcard,
and use the TWRP install feature
(tap to « install image » instead of « install zip »)

I don’t have a problem side loading TWRP 3.3.1 from my Linux machine, the problem is that after I load it the device goes into a boot loop and gives me an error message about the kernel. It seems that the only way I can get out of that is to side load TWRP 3.4 again, and then I’m back to it booting straight into recovery and I have to reload LineageOS 17.1 to get an OS booting.
There’s a warning at the top of the official install instructions page about potentially bricking your phone if you try to downgrade from LineageOS 17.x, so I’m thinking that I might have to go with an unofficial newer version of /e/ if I can get that somewhere.

My note about the S7 / S/ Edge was only made because you wrote about the S7 and then the S7 Edge in your opening post.

Even if it sounds annoying - the success is worth the small effort: First create a clean starting point with Stock Android. Flashing with Heimdall (Linux PC) or Odin3 (Windows PC) not only deletes or overwrites data, but also reformats all partitions and completely reinstalls the software.

Now you can replace the Android recovery on TWRP Recovery and install the CustomROM. With this procedure I have already completely revived Galaxys that I thought were dead.

By the way: TWRP with TWRP update is possible without further - nevertheless, I prefer the installation via Odin3/Heimdall for Galaxy Phones.

If you want to treblezies your S7/S7Edge, I’ll help you with that. But also GSI ROM need a clean starting base. Therefore - see above …:))

Besides: The S7 / S7 Edge surprisingly received another update from Samsung in September 2020. All previous versions have failed, only with this StockROM I could help an already sorted out to electronic scrap S7 Edge to new life.

Thanks for the response. At first I couldn’t figure out what you meant when you said I had referred to the S7 Edge. It took some looking around but I finally figured out that it was the file name ‘hero2lte’. That made me realize that I had downloaded the wrong files for sure! I guess my multitasking got me in trouble, but luckily you pointed it out and possibly prevented it from getting serious. That may have been the source of my problems, just not picking up on the ‘2’ in the filename.
I’m downloading the recent Samsung image from sammobile right now. Tomorrow I’ll try to find instructions for flashing it using Heimdall and get that done and give it a spin. I actually like the Samsung interface for the most part, but I’ve grown to like my trusty old S5 with /e/ and Omega loader more. The S5 will be going onto its third battery pretty soon and it’s great to have it around as a reliable backup.

Well, a missing number, a comma {,} instead of a semi-colon {;} in the source code, e. g. makes a web page not work and only a blank screen is displayed or as you’ve now realised a simple number ‘2’ in the file name makes a huge difference. All too often it’s the little things that cause problems for us humans.

Heimdall frontend (Odin equivalent) for Linux (or Mac) does exactly the same as Odin v3.14.4

Heimdall Frontend Linux

Odin v3.14.x Frontend Windows

A guide from XDA

Installation instructions from LineageOS Wiki and /e/documentation