S9 from stable (oreo) /e/ via Stock Q ROM to /e/ on Q

I noticed that following this document some steps were not appropriate it seems:
In step 7 flashing vendor was downgrading my vendors - so I could not move on.
I didnt “patch” the system - I dont know if that is a problem later on. For the moment I dont notice any downside - maybe someone else can comment on that.
/e/ with Q as basis works flawlessly atm.


Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

Unfortunately instructions written from templates can be misleading.

The tell-tale is “…on some devices…” with no attribution to this statement it is worthless.

Thank you @1n4ts for pointing this out.

Edit, of course /e/ documentation feedback can be reported in this section. About the Documentation Suggestions category

1 Like

I should have finished my rant by saying that /e/documentation errors should correctly be reported as a documentation issue on Gitlab Issues · e / Backlog · GitLab

The point is, in the instructions you can only read: "On some devices, installation can fail if vendors are not up-to-date. In this case, please:

  • Download …
  • Install them
    • On the device, go into Advanced > ADB Sideload, then swipe to begin sideload
    • From the computer, please run adb sideload <vendors file>"

I did not assume that it was about to downgrade the vendors from the info given.

As for the patch that I did not apply on my second try, I am not sure if I could recommend that since I have no clue if it might be necessary for some ppl. My phone had stock → /e/->stock/e/ and it looks like I didnt need it.

Thanks @aibd for pointing to Gitlab.

I realise you could have damaged your device - you fortunately know your way around and sounds like you took correct avoiding action. Lots of people might come to harm following those instructions - possibly, I am not certain, I am not familiar with the device.

I did propose all pages with errors be taken down.

Edit on checking, I now find that the “Upgrade” pages I flagged have been taken down. Thank you @Manoj

It will be an evil job for someone to untie the faulty templates.

The re-writer will appreciate clear guidance where the errors are.

Thank you for reporting it.


Thanks for your response. So no need for me to open a issue about this in gitlab?

There is no guarantee your report will be seen here I am afraid by the documentation team!

You have given your thread a good title, hopefully other potential users will be warned.

Or perhaps we should start a Community Documentation Addenda thread. :frowning:

My fault ?


Because of the date I think it is not android 10 based.

is it android 10 based ?

No, not your fault. Miscommunication and @1n4ts got it totally figured out. Thank you for checking.

I am not programmer, but I propose the idea in theory, correct me if I am Wrong

A new user could skip the pain to find a correct firmware, install odin or learn deeper heimdall, if “I/w/e/U” provide a single up to date vendor image…:smiley:

OTA upgraded to Samsung-Android-10 on the s9 / s9+ → did the easy installer process [ emulate heimdall + unlock the bootloader + flash twrp to /recovery + format /data + reboot to recovery ? + wipe /system + install dm-verity + vendor 2018 + emulate adb + sideload e-latest-stable from the computer (to /boot and to /system) + wipe /cache and /dalvicARTcache ] = /e/Oreo on the device
Then is
→ boot TWRP → format /data + reboot to recovery + wipe /system + install android 10 based vendor.img + install /e/Q.zip from SDcard (to /system and to /boot) + wipe /cache and /dalvicARTcache = regular samsung firmware + regular /e/Q on the device ?

Have you or someonelse tried to install directly e-0.17q over an upgraded to 10 with /e/Oreo ? does it boot ?

Deleted my post to not cause more confusion. Hopefully the official documents get updated.

I forgot to mention above, we do have a Document suggestions page for this device. Now linked

Without making any further comment on what error might be present in /e/ documentation …

the /e/ pages are derived from LineageOS pages. A useful cross reference in case of doubt is to looks at the Lineage OS page for the device and turn to the install page:



Both devices are …no longer maintained… not in itself a problem, but might indicate a user be sure to get well updated information.


I actually tried the upgrade path from oreo to Q - there was a howto page (which i sadly cant find anymore) but that didnt work.
It got stuck at the point, when trying to flash the new e ROM zip-file via twrp. I cant remember the exact error wording, but it kinda said, trying to install over wrong base system.
I could try to help with the vendor image if someone points me into the right direction, where to find/extract it?

Hi @1n4ts

I could try to help with the vendor image if someone points me …

This is the line from starlte install page

Download those vendors

Any further light you can shed on this would be valuable.

While your subject is Upgrade from Oreo to Q,

you tell us you had (at this point) brought the device up to “Samsung latest ROM” so you would expect you were now doing a straightforward install.

the paragraph in question:

On some devices, installation can fail if vendors are not up-to-date. In this case, please:

This is an if clause, maybe the wording is suggesting: “on the other hand if you know your manufacturers ROM is the latest, omit this stage (unless you experience a fail)”.

In the light of your experience you may be able to improve on the documentation suggestion I already left. :slight_smile:

1 Like

Thats true - mistake on my side: I assumed I better be updating vendors - since I did not update to the very latest Q stock ROM. I didnt check the date of the vendors upload against the date of the ROM I installed previously.

I did another S9 few minutes ago - coming straight from stock ROM - no ODIN in between and the instructions work fine, if noone downgrades vendors :wink:

1 Like

Thanks for that @1n4ts .

On your second install did you patch the device, with the linked patch?


No, I did skip that as well. Oh and in step 5 from “installing a custom recovery” - the blue bar that one should wait for is actually white. :heart_eyes:

I imagine no-verity-opt-encrypt-samsung-1.0 could be for patching an old twrp and vendor could be android 8 based for make compatibility with an Oreo system on a treble device, even with android 10 or 9 or 8 based firmware