Safetynet and Rootbeer compatibility status on /e/OS phone

Safetynet and Rootbeer compatibility are two new additions to the Supported Device list.Safetynet and Rootbeer compatibility on your /e/OS device ensure a very high level of apps compatibility.

  • Safetynet is an API which allows android users to detect device tampering. It reports if the device is rooted, running a custom ROM or has low level malware.

  • Rootbeer checks if the device is rooted. It is an opensource project.

Implementation in /e/OS:

Official / stable builds

:point_right: Both Safetynet and rootbeer working

The devices are

- Gigaset GS290 
- Teracube zirconia 
- Teracube emerald 
- FP3 
- FP4
- FP5
- Samsung Galaxy S8+ dream2lte
- Samsung Galaxy S8 dreamlte
- Samsung Galaxy S7 Edgehero2lte
- Samsung Galaxy S7 herolte
- Google Pixel 5 redfin
- Murena one
- Murena two
- OnePlus Nord avicii

Community or Dev builds

:point_right: Safetynet to be tested, Rootbeer working

All community or dev builds will have the rootbeer working. Safetynet should also work but remains to be tested

  • Users with dev builds are kindly suggested to test and share the details with us on this thread or the device specific documentation thread. We will update the documentation accordingly

How to test?
As mentioned above we look forward to your feedback on Safetynet and Rootbeer working on all devices.

To test Safetynet:

  • SafetyNet Test app

To test Rootbeer:

We will share names of apps you can install to test Rootbeer on your device

Legacy devices

:point_right: Safetynet or Rootbeer will not work

All devices on Pie,Q,Oreo ,Nougat

Additional references:

Safetynet API


Regain your privacy! Adopt /e/OS the unGoogled mobile OS and online servicesphone


Hello @Manoj

Google pixel 7 (panther),
/e/OS : 1.20-t-20240223382228-dev-panther

SafetyNet test Failed

Best regards


1 Like

Google Pixel 4a
e/OS/: 1.20-t-20240223382228-dev-sunfish

SafetyNet test Passed

Edit: As others have stated, after re-running the test it failed.

After couple of hours I tried it again, then it passed. Maybe re-running it very often in a short period of time makes it fail.

Thanks for sharing the test reports. Ideally I will wait for 2 fail reports before updating the status in the documentation. Will update developers of each fail report to check. In some cases if we do not have the device we may require users to help with the testing. Will set up a process of how this will happen.

Samsung Galaxy S9+
/e/OS: 1.20-r-20240221382014-dev-star2lte

OnePlus 7T hotdogb
/e/OS : 1.20-t-2024022238228-dev-hotdogb

OnePlus 6T, fajita

Sony Xperia XZ2 compact
e/OS/: 1.20-t-20240223382228-dev-xz2c

Sony Xperia XZ2 premium
e/OS/: 1.20-t-20240221382228-dev-aurora

Sony Xperia XZ3
e/OS/: 1.18-t-20231209360971-dev-akatsuki
e/OS/: 1.20-t-20240221382228-dev-akatsuki

The app it’s a bit weird. After the first test (succesfull) if you run it again by touching RUN TEST on the lower corner of PASSED it fails.
I’ve redone it and now it failed on second re-run so I don’t know how reliable is the result.

Hi! Where can I download that APP? Couldn’t find in F-Droid

^^ Aurora or Applounge

Xiaomi 11 Lite 5G NE - lisa

Thanks to all users who have shared the status of Safetynet on their device. The information is being updated to the Supported Device list. :pray:

Xiaomi Mi MIX 3, 1.20 T ROM from Murena.

Xiaomi Mi MIX 2, 1.20 T ROM from Murena.

Same here. It’s not the app, I’ve tried a different one: SafetyNet Cecker on my FP4.
The first checks report a Passed status, after some retries, the checks start to fail.
MicroG itself records a list of all test results:

I have to reboot the phone to get another ‘Passed’ status.
Maybe both apps use the same mechanism which starts to fail after some attemts, or MicroG still has an issue…

Pixel 6a

@Manoj : The Tags are missing for “river”.