Samsung - Galaxy A5 (2016) - a5xelte - Documentation Suggestions

Please add your suggestions to improve the documentation for the Samsung - Galaxy A5 (2016) - a5xelte here …


Hi !

I just installed a5xelte with success (It works very well :blush:) and I have a few suggestions:

  1. The lastest Heimdall suite does not work. This one works (GitHub - alexax66/Heimdall: Heimdall is a cross-platform open-source tool suite used to flash firmware (aka ROMs) onto Samsung Galaxy devices.). It’s a fork of the original project related to this issue: (ERROR: Failed to receive file part response! · Issue #347 · Benjamin-Dobell/Heimdall · GitHub).
  1. The Heimdall build page (Build Heimdall) should say that the compiled file should be placed in /usr/bin/ for Ubuntu.
  2. In the a5xelte installation page (Install /e/ on a Samsung Galaxy A5 2016 - “a5xelte”), the command ’’’heimdall print-it’’’ and ’’’heimdall flash […] --no-rebooted’’’ only worked with sudo.
  1. In the a5xelte installation page (Install /e/ on a Samsung Galaxy A5 2016 - “a5xelte”), in Intalling /e/ from recovery, the command ’’’adb reboot recovery’’’ did not work. I went straight from 7 (Manually reboot into recovery) to 3 (In TWRP return to main menu, then tap Wipe ). The ‘Note’ after 7, should maybe be a ‘warning’ displayed in red since it is a crutial step easily messed up.

In any case, thank you for the OS, I am very happy with it!

first of all its an awesome deGoogled /e/ Operating System.
Thank you so much for your support.
Short story: I have just installed/flashed on my Galaxy A5 (2016) and it works.
i am setting up various apps now and i want to use it as my daily driver.

Long story: regarding installation/flash:
first and foremost, i think the documentation available on site was well written and understandable for me.
My device: Samsung A5 (2006), a5xelte, A510FXXU4BQD1
Bellow i give you my feedback regarding installation steps and i will explain in detail the steps i did to make it work, i ran into many problems.

  • the latest TWRP version twrp-3.7.0_9-0-a5xelte.img didn’t work for me.
    A) if i flashed via Heimdall, i would get an error at 94% (ERROR: Failed to receive file part response! · Issue #347) there was some solution on internet to modify a script file (Bridge…something) and rebuild Heimdall. I tried but it didn’t work for me, with this solution i got same error at 0%
    B) if i flashed via Odin latest twrp-3.7.0_9-0-a5xelte.img.tag, it would flash correctly but the phone was stuck in endless bootloop

  • i succed to flash via ODIN an older version twrp_3.0.2-1 downloaded from XDA-Developers forum and it worked correctly

  • with twrp_3.0.2-1 working correctly, i followed the steps to flash the /e/ operating system, latest version
    (dumb mistake from me, i did not backup the partitions via TWRP)
    and i proceed to Wipe System partition and Cache
    However when i issue adb sideload command i get ERROR7: “This package is for device: a5xelte; this device is .”

  • the solution found on the internet to modify META-INF\com\google\android\updater-script’ and delete lines: “assert (getprop (“ro.product.device”) …” did not work for me.
    with this solution i got another ERROR: “unable to find file update-binary”

  • on i found a similar thread and i understood that version twrp_3.0.2-1 was too old
    so i proceed to download twrp-3.2.1-0-a5xelte.img (it is the oldest version from twrp official site, i just hoped that it would work) and flash according to instructions:
    update TWRP within TWRP
    1.Just download Latest TWRP (for me it worked the oldest) ver from official site or some other trusted website.
    2.Copy it to SDcard.
    3.Select “install” option in TWRP
    3.Select “image” option bottom screen of install page.
    4.Select the new TWRP image file.
    5.SELECT THE TYPE ““RECOVERY”” when prompted and flash it.
    and reboot in recovery.
    twrp-3.2.1-0-a5xelte.img worked!

  • then i proceed to adb sideload
    but the process would stuck loading at 40%

-i disconnected and i reboot again into RECOVERY
i wiped again System partition and Cache
i proceed to adb sideload again
i reboot to system and it worked, finally !

all is working very good on the phone.
the behaviour is smooth.

Each time the phone finished booting i get an error Android System: “There is an internal problem with your device, Contact your manufacturer for details” i suppose because it was flashed or something like that.
But nothing really happens, so i just press OK and all is good.

  • i also installed F-droid, but APP Lounge is awesome great work.
    all good so far.

I have used heimdall and adb on Win10 and OpenSUSE linux to flash twrp and /e/ OS.
Each time i got the errors described above i would boot into Win10 or OpenSuse Linux and try the commands again, just to make sure it is not some driver problem on my laptop OS, but it behaved the same.

Hope someone will find this useful.
Manny thanks for everything.

I have a error to startup