Samsung - Galaxy Note10+ - d2s - Documentation Suggestions

…Enter suggestions to improve documentation in this category. Do not raise bugs or issues here…


No mention here about flashing a modified vbmeta.img (proposed by the twrp team) before flashing TWRP (as advised on LOS wiki for Galaxy Tab s5e)

This device is the d2s linked here on the LOS wiki

Yes, but same génération

From the twrp website about the d2s :

If you wish to install TWRP without rooting, there are numerous pitfalls to consider. For example, a stock device is protected by Android Verified Boot. This is implemented as a vbmeta partition that contains cryptographic digests for verifying the integrity of boot.img, recovery.img and other partitions/images. Flashing TWRP without first flashing a vbmeta image with verity disabled will render your device unable to boot.

3 users have open threads yesterday with the same flashing error message.

There are 2 devices with same d2 …will this fix be relevant for both the guides

Screenshot from 2021-10-23 13-59-41

I am afraid it concerns all Samsung newer than the s9

LOS Wiki does not seem to have the update…which is what worries me since we closely follow their wiki.

Hi there,

Thanks to everyone who has helped make this work happen. I am a first time user and thanks to the instructions, was successful in installing the e/os to my Note 10 plus. There were a couple areas where the instructions could have been more detailed, but I was able to work around them with online searches. Here were the parts that I got stuck on and the additional info that would have helped me:

Pre-Install Instructions
3. Power off the device, and boot it into download mode:

  • Hold Volume down and Volume up first, after a short delay, then connect the USB
  • Long click volume up to unlock bootloader

Installing the e/os Recovery on your 2ds

In this section, I struggled, because there was no pause for me to reboot and so the custom recovery was always overwritten. The only trick that worked was using this code:

heimdall flash --RECOVERY recoveryfilename.img

Notice the missing “–reboot”. In this case, the phone screen went black for a few seconds after the transfer bar finished. In that brief time, I was able to reboot the machine using the custom recovery. By the way, my transfer bar was white, not blue. Maybe best not to mention the color.

Also in this section, it would be nice to elaborate on the method used for reboot:

  1. Manually reboot to recovery
  • Press volume up and power

Those are all the suggestions I have. Thanks again.

Is it possible to install your S bild .zip file from TWRP recovery by simple install of your install] file?

It will work after flashing like this or not?

I have samsung galaxy note 10+.
OEM unlocked. USB debugging is active.
Before flash I done wipe - data - yes.

I have already install TWRP [twrp-3.7.0_9-0-d2s.img.tar on my note 10+.

I use Windows 10, I have not linux or Mac.
Pls help!


1 Like

I can not add the last foto cause I’m a new user here. Bad rules!

I added 3de foto in my first topic.

I did not restart the system after completing the firmware of, so as not to get a “brick” in the worst case. So I rebooted to “download” and flashed the stock ROM again in Odin.
So now I have stock ROM.

I am very interested in if you actually went through with it and tried to install /e/ on this device from TWRP, since i was playing with the idea of trying the same thing.

Right now tho I am rather considering installing it from /e/-recovery, that i will first try and transform to tar-file, so that it can be flashed through odin, since i never worked with heimdal…

Hi again!
I have d2s and have been trying to install TWRP but have not been successfull so far. I would therefore kindly like to ask you how you managed to do that. I am on Android 12, use Odin and both the twrp-zip (version you have installed) and the other zip file that is recommended (can’t remember the name just now), put them in the right places in Odin. But it doesn’t work, it just messages ‘Analyzing file’ and gets stuck there so finally i have to manualy reboot after a while…

I have just switch from lineageos to /e/os succesfully, I have used heimdall (linux os), thanks for your work.

tanks a lot for the quality of documentation, it’s even more complete than the lineage one. in particular it has the instructions to prevent samsung reinstall it’s recovery!

just an addition : for me adb sideload of /e/os did not work, don’t know why, adb on computer didn’t found the device

it can be added in the doc that using a usb drive, it’s possible to install, this is how I managed to install : I put the image on usb drive, plug it while on recovery, gone to update, choose update using usb drive, select the file, everything else is same as adb sideload

thanks and regards