Samsung galaxy S II

Hello all,

I would like to try /e/ on a old Samsung Galaxy S II. I don’t care if it is not working 100%. I’ve tried the S III iso but it automatically checks and sees it’s a i9100. Is there a way around?




Thanks for creating this version. I have tried to flash it on the Samsung Galaxy SII with TWRP. TWRP was already on the device. The proces of installing stopt at about 80% and nothing happend any more. Finally I had to remove the battery but it bricked the phone… Can’t try again


its softbrick maybe, you just need reflash stock rom i think, but i never had samsung devices so i cant help you with it, and what about rom, i tried build few times always got that system image size is smaller and i left only core /e/ apps and then it was enough, i dont think you completely broke your phone, just search manuals how to flash stock.

The error message was:
failed to mount /dev/block/mmcblkOp9 at /system
: invalid argument
Unmount of /system failed no such volume

have you wipe all in twrp before flash rom?

You might be right. The battery indicator still functions when charging. But TWRP doesn’t start.

Yes. Wipe all was preformed.

well if we had one more user with that device, we could 100% found the reason of it, if it rom problem or your personal device, if you can try flash stock rom than install twrp again, or if you can try another twrp maybe twrp is the problem, then try again, but i left only all core apps so if i remove something else it will be not /e/ anymore.

Thanks for the help. I finally got TWRP working again by unplugging the phone from the PC and than restart it again. Then I tried again to reinstall /e/. But same the same problem occured. Now reinstalled Slim ROM. When the problem is detected, I will try again.

well maybe its rom problem if slimrom works, you know i dont have all devices so i build it without testing but its same like officiall but no ota support, and in your build a lot of non core apps removed, so maybe /e/ not compatiblle with this device, this device is old and system image size limited.

Hello @Robby, it is highly recommended to use a current TWRP version, e.g. twrp-3.3.1-0 from 2019-05-20. An update of TWRP can easily be done via TWRP “Install”. Comparison also Install from microSD.

TRWP can usually be flashed very easily with the proven version Samsung Odin3 v3.09 - TRWP (yes, there are also newer ones).

Back to StockROM Android 4.1.2 and then start all over again might also be a solution.

Let us know if you need any help.

1 Like

Hello Archie,

TWRP version is to old to use TWRP install. (No iso option). So tried on Lunux Heimdall… not working. Then wend to Windows system. Installed Heimdall… problems with missing DLL’s. Couldn’t get it running. Then tried Odin. Got mss “complete (write) operation failed. All treads completed. (succeed 0 / failed 1)”

Yes, I am aware of this ODIN error message. There are several reasons for this, e.g. missing Samsung USB drivers, USB cable, etc…

First question: Can you boot your S2 i9100 in “Samsung Download Mode”?


Yes, downloadmode is working fine.
I’ve been trying voor more than 8 hours to get it all going. I Think my device is to old for the relative new TWRP version. And I doubt in the end a newer version wil solve the /e/ installing problem. May be it’s time to give up. At least for this device…

If the Samsung download mode works, then after all experience it should be possible to flash StockROM and TWRP.

The i9100 too old? Still available, an LOS 14.1 image of LineageOS-for-mircoG from 23.03.2019 and a current TWRP 3.3.1-0 from 2019-05-20.

Well, I think you’re right. It should be possible because I managed to get the old TWRP on the device too. That was however several years ago. I used Odin at that time. All the manuals on internet of how to flash the device presume that the device is flashed for the first time. So they all are a little bit of… And non of them provide info what to do if it doesn’t work out. I’m not a programmer so all I can do is follow intstructions, not quit knowing what I’m doing and hoping the best for it.

TWRP can be updated within TWRP recovery itself, by flashing the latest image. Alternatively, It’s possible to flash a newer version via fastboot as well.

When asked to select between boot and recovery partition select the recovery partition.

Which software version does your “old TWRP” have? so it is not possible toe update TWRP with TWRP itself.

@Robby, please don’t get me wrong now, but it’s very hard for me to believe that because I already updated a TWRP version to 3.3.1-0 with TWRP myself.

Maybe 2:19 minutes video tutorial will help. How to Update TWRP Recovery from 2.X to 3.X. I don’t understand the spoken word so well, but the pictures speak volumes.

If you have questions, please ask! We manage this!!