Samsung - Galaxy S10 - beyond1lte - Documentation Suggestions

Hi,

first of all: Merry Christmas!

Now, why I made that thread:
I am pretty new at installing custom ROMs, so far I only installed LineageOS 18.1 on my old Sony Z5 Premium.
Now I would like to try on my Samsung S10 and have a few questions about the installation, common pitfalls, and eOS.

So far I have looked at those two tutorials and read them to familiarize myself with them:

https://doc.e.foundation/devices/beyond1lte/install

Which tbh left me more confused, because one tutorial mentioned TWRP the official one for my device didn’t.

And does eOS have Dolby Atmos installed or do I have to add it?

I’ve read somewhere, probably on xda-developers, that one could add with Magisk, but I am afraid
that I might increase my chance of bricking the device if I try to do too much.

When I followed the build heimdall part of the tutorial I got the message that the file CMakeLists.txt doesn’t exist after the command
cmake -G "MSYS Makefiles" -DCMAKE_BUILD_TYPE=Release -DQt5Widgets_DIR=/c/msys64/mingw64/qt5-static/lib/cmake/Qt5Widgets ..

I simply created an empty file with that name and continued without any issue.

But just in case I downloaded the “finished” heimdall suite for windows as well and simply added the folder to the path variable. So I hope that this should do the job as well.

Also is installing MicroG on /e/ necessary? And which Apps are most likely redundant to install on /e/ compared to Lineage?

Kind regards,
Meitei

Hi,

On a windows PC, better and easier is to use Odin than Heimdall, to flash the reconvery-e or TWRP

1 Like

Thanks. I will take a look. Are there any differences I have to know when I go through the offical tutorial then?

It is worth being aware of this thread Samsung - Galaxy S10 - beyond1lte - Documentation Suggestions

/e/ comes with microG already. /e/ does not expect or require magisk

1 Like

What I am still confused about is eRecovery or TWRP, going by the official documentation it says to use heimdall + eRecovery. But the version with odin uses TWRP.

What are the up and downsides to each? And what is easier to update with? Or put regular LOS on my phone with, should I not like eOS?

I might try the heimdall + eRecovery for today

LineageOS and /e/ have been developing their own Recoveries. They both seem to be based on TWRP, they are simplified and they are device specific. For LineageOS and /e/ this has the effect that documentation is simpler to write, per device, when describing the install process. The /e/ system (advanced) is also capable of keeping the /e/ Recovery updated.

Many experienced users prefer TWRP because of other opportunities offered within the Recovery mode. (Documentation written before /e/ Recovery was mainstream simply does not mention it!)

For a user with zero experience of TWRP, following /e/ Recovery instructions should be a little more intuitive, as the /e/ Recovery allows very few options.

Some documentation tends to prefer Linux methods. Heimdall is a Linux product.

It is said that Odin is a semi-official Samsung product released to Windows.

Heimdall is developed in Linux - now available in a Windows version!! Choose to use Windows or Linux according to your PC operating system. Read all you can for the broadest overview, but once started please only follow one set of instructions. :slight_smile:

Know your hardware - Samsung

1 Like

Thanks. I tried it with Heimdall but it didn’t work because it was unable to install the driver. When I tried it again it couldn’t detect the device.

Then I tried it with odin, but when I try to put TWRP on it fails. I already tried it a couple of times.

Edit: I tried it againm but then odin didn’t show any progress for like 10-15 minutes, so I stopped. Also I noticed a red text in download mode: custom binary (recovery) blocked by oem lock

Now I did enable oem and have the dev settings on too.

Perhaps review every point here, (being a new device, Samsung may have introduced hoops which we had not seen previously!) #3 OEM Unlock

Alternatively “TWRP file in .tar format previously downloaded.” Did you offer an .img?

I’ll do that after a short break.

I ulocked the bootloader because I thought that that maybe is the issue. But nope… Odin failed again and after a second attempt and being frozen there I now get the following error on my device:
an error has occured while updating the dvice software.
Use the emergency recovery function in the smart switch PC software

an error has occurred while updating the device software.
Use the emergency recovery function in the smart switch PC software

Is not too serious a problem … Samsung is hanging on and “needs” you to revert to “Samsung official”.

I expect you can reach Odin mode?

In the worst case, you may have to re-flash a stock ROM, but you can probably use Odin to do what you previously intended. The use of the correct TWRP and format is well documented in the Windows [HOWTO].

The device is still recognized by Odin, but when I try to install TWRP it still fails… So I moved two steps back, because I am worse off. And I constantly have that message on my phone. I cannot even turn it off properly.

Do you mean by stock to upload/install the other files with Odin like BL and CP, CSC?

Edit: I did use a .tar so far… I’ll try the .img next
Forget that, only tar possible. But I do have some “other” version of that TWRP from xda-forum, maybe I could try that one

Ok I do get a pass on Odin with the other version (twrp-3.6.0_9-2_afaneh92-beyond1qlte.tar) for whatever reason. But I am unable to boot into TWRP even after disabling auto reboot.

I do get some new red text:
Recovery: error validating footer (0)
Recovery: error verifying vbmeta image: invalid vbmeta header (6)

So probably you have hit an Android 11 R issue which is beyond my experience. You probably need to be careful to do everything in a correct way.

Did your phone have a fully updated Android R before you started? Probably a good idea to sort out a Factory ROM on standby. Read carefully any warnings associated with TWRP, you may need to be using a dedicated R version of TWRP.

(Completely unconfirmed, but I saw TWRP 3.6 as being associated with R)

Hi,

thanks for your quick responses.

I fully updated my phone before trying to install anything custom. And I did use 3.6, I just tried 3.5 to no avail.

And currently I am switchting back and force between download mode and the above “an error has occured” screen. And I am stuck in a download mode loop, meaning I cannot access my phone regulary or turn it off anymore.

And how can I do everything correctly when I following the documentation and it still fails.

how can I do everything correctly when I following the documentation and it still fails.

Sorry :slight_smile: my poor choice of words!

In this situation, Samsung is in charge and will not willingly let you go independant! As I cannot give you expert guidance, it is probably best to follow the Samsung guidance and revert to a factory ROM, then start again.

My meaning had been, that if you take a wrong step now, the phone may try to disable itself in a way that looks like bricked.

You may need to reflect and review how to view /e/ documentation. You have a new device and you are an early tester. The device specific install page should be correct, but may be modified in light of user experience. The Windows [HOWTO] was written some time ago when Samsung/Android phones were a bit more easy to liberate!

Ok, I see :).

At first I followed /e/ documentation but failed at using heimdall when trying to install the drivers.

So far I could only find US stock for Samsung, even though I have an EU phone

I just noticed LineageOS seems to offer some slightly fuller explanations Install LineageOS on beyond1lte | LineageOS Wiki. I am not a Windows user, so only read the Linux steps when reviewing the docs, but perhaps Odin is not equipped to deal with R? I didn’t know - but an Odin method found in # post 20.

When searching for firmware you need the model number in the format SM-G973F … is that your exact model?

Did you already search the 4 options at Know your hardware - Samsung Sammobile downloads can be very slow: https://www.sammobile.com/samsung/galaxy-s10/firmware/

Thanks

Yes it is SM-G973F.

I already started to download some german firmware, but it is slow and I have to leave in a few hours and come back tomorrow evening.

So currently I am in this download mode loop that is my current “best situation” with the red Recovery Error lines…

Odin has shown “pass” when I tried TWRP.

But does this mean I have to use Heimdall even though I couldn’t get it to work on Windows?

Anyways I’ll take a look now at what you sent.

But does this mean I have to use Heimdall even though I couldn’t get it to work on Windows?

I definitely do not want you to do more things, to see if they work better. But I want to help you understand the position you might have been in case my informal explanations have been unhelpful.

What you experienced would be perfectly normal if you did something to corrupt the Samsung Recovery, and left the system intact. This is what I meant by saying Samsung is in control.

To replace a Samsung verified Android system you were aiming to do it in two stages. You flash a custom recovery, it is very important now not to allow the system to boot (or else you would experience red messages and the device is disabled), then the intention (while the system is unconscious) is to flash a Custom ROM.

At the described point you cannot expect to use the phone till you rectify this inbalance.

At the point I expect you are, the phone should remain stable in the Download mode to permit you to apply the fix. You would need to know that you were not just experimenting but applying the fix.

Like I mentioned I am stuck in a download mode loop and I cannot get out of it. No matter what combination of power off button, volume ± and bixby I try that I could find or how fast I try to be with different combinations.

So the only solution would be to install stock, wouldn’t it?
Since I have to leave and there is no way for me to turn off the phone it might automatically turn off when it is out of battery at which point I might try to boot into recovery with bixby + volume + and power button. Which isn’t currently possible.

Also, the only way I was able to boot into download mode was bixby + volume- and then inserting a USB cable. Some videos and website tell you to also press the power button to boot into it without a cable, but this never worked for me. no matter how often I tried, it would always reboot over and over again and when I let go, boot up regulary.

That is good that you have learned the “new” key combo for this device. Careful reading of this page will shed more light. Samsung Galaxy S10 (Exynos)

Please continue to search for the great importance of “Your first boot into TWRP” if I have not provided enough clues already! :slight_smile:

Later edit. It is good that you have reviewed all the ways in which the hardware buttons do not behave as usual. However they are all consistent with the descriptions of the situation I have given.

One combo you do not mention is Force stop. Traditionally this works in all three booting modes. As you indicate, Download mode is the only stable mode atm. The Force stop combo on older phones was >7 seconds, Volume down + Power.

This should bring the phone to standstill. With any luck charging will work at the OFF state.

Charging does not happen, I think, on my Samsung in Download mode. In TWRP my Samsung shows the battery level, and whether charging with a +.

Please try to practice Force stop; it is part of the special “First boot into TWRP”.

Be aware of battery level. Best to avoid any intervention with battery less than say 60%.

1 Like