Samsung - Galaxy S10 - beyond1lte - Documentation Suggestions

The device is still recognized by Odin, but when I try to install TWRP it still fails… So I moved two steps back, because I am worse off. And I constantly have that message on my phone. I cannot even turn it off properly.

Do you mean by stock to upload/install the other files with Odin like BL and CP, CSC?

Edit: I did use a .tar so far… I’ll try the .img next
Forget that, only tar possible. But I do have some “other” version of that TWRP from xda-forum, maybe I could try that one

Ok I do get a pass on Odin with the other version (twrp-3.6.0_9-2_afaneh92-beyond1qlte.tar) for whatever reason. But I am unable to boot into TWRP even after disabling auto reboot.

I do get some new red text:
Recovery: error validating footer (0)
Recovery: error verifying vbmeta image: invalid vbmeta header (6)

So probably you have hit an Android 11 R issue which is beyond my experience. You probably need to be careful to do everything in a correct way.

Did your phone have a fully updated Android R before you started? Probably a good idea to sort out a Factory ROM on standby. Read carefully any warnings associated with TWRP, you may need to be using a dedicated R version of TWRP.

(Completely unconfirmed, but I saw TWRP 3.6 as being associated with R)

Hi,

thanks for your quick responses.

I fully updated my phone before trying to install anything custom. And I did use 3.6, I just tried 3.5 to no avail.

And currently I am switchting back and force between download mode and the above “an error has occured” screen. And I am stuck in a download mode loop, meaning I cannot access my phone regulary or turn it off anymore.

And how can I do everything correctly when I following the documentation and it still fails.

how can I do everything correctly when I following the documentation and it still fails.

Sorry :slight_smile: my poor choice of words!

In this situation, Samsung is in charge and will not willingly let you go independant! As I cannot give you expert guidance, it is probably best to follow the Samsung guidance and revert to a factory ROM, then start again.

My meaning had been, that if you take a wrong step now, the phone may try to disable itself in a way that looks like bricked.

You may need to reflect and review how to view /e/ documentation. You have a new device and you are an early tester. The device specific install page should be correct, but may be modified in light of user experience. The Windows [HOWTO] was written some time ago when Samsung/Android phones were a bit more easy to liberate!

Ok, I see :).

At first I followed /e/ documentation but failed at using heimdall when trying to install the drivers.

So far I could only find US stock for Samsung, even though I have an EU phone

I just noticed LineageOS seems to offer some slightly fuller explanations Install LineageOS on beyond1lte | LineageOS Wiki. I am not a Windows user, so only read the Linux steps when reviewing the docs, but perhaps Odin is not equipped to deal with R? I didn’t know - but an Odin method found in # post 20.

When searching for firmware you need the model number in the format SM-G973F … is that your exact model?

Did you already search the 4 options at Know your hardware - Samsung Sammobile downloads can be very slow: https://www.sammobile.com/samsung/galaxy-s10/firmware/

Thanks

Yes it is SM-G973F.

I already started to download some german firmware, but it is slow and I have to leave in a few hours and come back tomorrow evening.

So currently I am in this download mode loop that is my current “best situation” with the red Recovery Error lines…

Odin has shown “pass” when I tried TWRP.

But does this mean I have to use Heimdall even though I couldn’t get it to work on Windows?

Anyways I’ll take a look now at what you sent.

But does this mean I have to use Heimdall even though I couldn’t get it to work on Windows?

I definitely do not want you to do more things, to see if they work better. But I want to help you understand the position you might have been in case my informal explanations have been unhelpful.

What you experienced would be perfectly normal if you did something to corrupt the Samsung Recovery, and left the system intact. This is what I meant by saying Samsung is in control.

To replace a Samsung verified Android system you were aiming to do it in two stages. You flash a custom recovery, it is very important now not to allow the system to boot (or else you would experience red messages and the device is disabled), then the intention (while the system is unconscious) is to flash a Custom ROM.

At the described point you cannot expect to use the phone till you rectify this inbalance.

At the point I expect you are, the phone should remain stable in the Download mode to permit you to apply the fix. You would need to know that you were not just experimenting but applying the fix.

Like I mentioned I am stuck in a download mode loop and I cannot get out of it. No matter what combination of power off button, volume ± and bixby I try that I could find or how fast I try to be with different combinations.

So the only solution would be to install stock, wouldn’t it?
Since I have to leave and there is no way for me to turn off the phone it might automatically turn off when it is out of battery at which point I might try to boot into recovery with bixby + volume + and power button. Which isn’t currently possible.

Also, the only way I was able to boot into download mode was bixby + volume- and then inserting a USB cable. Some videos and website tell you to also press the power button to boot into it without a cable, but this never worked for me. no matter how often I tried, it would always reboot over and over again and when I let go, boot up regulary.

That is good that you have learned the “new” key combo for this device. Careful reading of this page will shed more light. Samsung Galaxy S10 (Exynos)

Please continue to search for the great importance of “Your first boot into TWRP” if I have not provided enough clues already! :slight_smile:

Later edit. It is good that you have reviewed all the ways in which the hardware buttons do not behave as usual. However they are all consistent with the descriptions of the situation I have given.

One combo you do not mention is Force stop. Traditionally this works in all three booting modes. As you indicate, Download mode is the only stable mode atm. The Force stop combo on older phones was >7 seconds, Volume down + Power.

This should bring the phone to standstill. With any luck charging will work at the OFF state.

Charging does not happen, I think, on my Samsung in Download mode. In TWRP my Samsung shows the battery level, and whether charging with a +.

Please try to practice Force stop; it is part of the special “First boot into TWRP”.

Be aware of battery level. Best to avoid any intervention with battery less than say 60%.

1 Like

Hi,

the volume down power off for 7 seconds is something I already tried a couple of times and loops me back to the download mode.

1 Like

I was able to successfully flash the stock on my phone. So far I charged my phone to be usable again and finishing to steps to see if it is functional. And then it is back to step one I guess…

What I noticed when booting up: The phone reminds me that the bootloader is unlocked and I have to press the bixby button continue.

So I guess you have some more reading to do. It should be more easy a second time with some clues what not to do! I feel more confident for you having read the updated TWRP page I added here 24 hours ago. An Odin method is given and when you read carefully he describes how to avoid exactly what happened last time.

Ok… so again I am stuck at the download mode loop again…

Now I wanted to try to follow the official /e/ documentation and use heimdall with zadig, which worked this time after using the version linked in the official LOS documentation for Windows.

After that I wanted to boot into the recovery but instead I’m being welcomed by a looping download mode… once again.

I’ll try it with odin again maybe that one helps, otherwise I am back to flashing stock again tomorrow.

And do you mean this page? Samsung Galaxy S10 (Exynos)

If so, to be honest, I am not really any wiser, at least in knowing how to avoid this. At first I thought by using heimdall I might solve the issue, because like you mentioned “but perhaps Odin is not equipped to deal with R”, but this doesn’t appear to be the issue.

Know your hardware - Samsung

On recent samsung devices, it is necessary to use a VBmeta file that disabling samsung protection :
In Odin, put it on CP and the custom recovery in AP

https://forum.xda-developers.com/t/recovery-official-3-5-0-x-twrp-for-galaxy-s10-e-5g-exynos.4180287/
.


.
Odin

Heimdall

.

[HOWTO] an Unified Install Guide Project for /e/

Thanks! Why isn’t this mentioned in the offical S10 /e/ or LOS documentation?
Also as far as I understood it, if I’d like to install Magisk as well I should be doing that before any recovery in a Samsung device, right? Because like I mentioned in the first post I’d like to have Dolby Atmos on my phone.

Did you find the special instructions for “Your first boot into TWRP”? It sounds as if you did not; as this would explain both results.

Do you mean this part?

Therefore you will have to manually reboot the device by pressing the main button, the power button and the volume down button. As soon as the screen turns off, move your finger from the volume down button to the volume up button (while continuing to press on the other buttons) in order to enter into TWRP.

If so, I already tried that but again I got stuck on the loop… I’ll be trying to install magisk and the link that piero recommended with vbmeta, if still necessary with magisk

Thank you for confirming that you got the “magic” of first boot into TWRP, - it is probably the most common reason for failure! :slight_smile:

Be sure to follow fully the guide by corsicanu, noticing the way that he separates

  • App Install Method (Requires Root):
  • Odin Install Method (No Root Required):

/e/ documentation may recommend against App installs (for various reasons) but @piero is absolutely correct to draw your attention to the “patch the stock ROM to prevent the stock ROM from replacing TWRP”

Also, anytime you get the same error twice, review all suggestions provided. This crops up very early in this thread: Samsung - Galaxy S10 - beyond1lte - Documentation Suggestions. It includes a warning about a limitation of TWRP; and it is mentioned that LineageOS documentation includes a "Pre-Install Instructions” section, found at Install LineageOS on beyond1lte | LineageOS Wiki.

1 Like

So should I be going with the e-Recovery or Lineage-Recovery w/ Odin instead of TWRP?
I did try the e-Recovery in tar (thanks to 7z) with Odin within the last few days and got an error.

Edit: And btw my phone is already rooted like I mentioned, which is giving me a message every time I boot, and I have to “click it away” with the power button.