Samsung - Galaxy S10 - beyond1lte - Documentation Suggestions

That is good that you have learned the “new” key combo for this device. Careful reading of this page will shed more light. Samsung Galaxy S10 (Exynos)

Please continue to search for the great importance of “Your first boot into TWRP” if I have not provided enough clues already! :slight_smile:

Later edit. It is good that you have reviewed all the ways in which the hardware buttons do not behave as usual. However they are all consistent with the descriptions of the situation I have given.

One combo you do not mention is Force stop. Traditionally this works in all three booting modes. As you indicate, Download mode is the only stable mode atm. The Force stop combo on older phones was >7 seconds, Volume down + Power.

This should bring the phone to standstill. With any luck charging will work at the OFF state.

Charging does not happen, I think, on my Samsung in Download mode. In TWRP my Samsung shows the battery level, and whether charging with a +.

Please try to practice Force stop; it is part of the special “First boot into TWRP”.

Be aware of battery level. Best to avoid any intervention with battery less than say 60%.

1 Like


the volume down power off for 7 seconds is something I already tried a couple of times and loops me back to the download mode.

1 Like

I was able to successfully flash the stock on my phone. So far I charged my phone to be usable again and finishing to steps to see if it is functional. And then it is back to step one I guess…

What I noticed when booting up: The phone reminds me that the bootloader is unlocked and I have to press the bixby button continue.

So I guess you have some more reading to do. It should be more easy a second time with some clues what not to do! I feel more confident for you having read the updated TWRP page I added here 24 hours ago. An Odin method is given and when you read carefully he describes how to avoid exactly what happened last time.

Ok… so again I am stuck at the download mode loop again…

Now I wanted to try to follow the official /e/ documentation and use heimdall with zadig, which worked this time after using the version linked in the official LOS documentation for Windows.

After that I wanted to boot into the recovery but instead I’m being welcomed by a looping download mode… once again.

I’ll try it with odin again maybe that one helps, otherwise I am back to flashing stock again tomorrow.

And do you mean this page? Samsung Galaxy S10 (Exynos)

If so, to be honest, I am not really any wiser, at least in knowing how to avoid this. At first I thought by using heimdall I might solve the issue, because like you mentioned “but perhaps Odin is not equipped to deal with R”, but this doesn’t appear to be the issue.

Know your hardware - Samsung

On recent samsung devices, it is necessary to use a VBmeta file that disabling samsung protection :
In Odin, put it on CP and the custom recovery in AP




[HOWTO] an Unified Install Guide Project for /e/

Thanks! Why isn’t this mentioned in the offical S10 /e/ or LOS documentation?
Also as far as I understood it, if I’d like to install Magisk as well I should be doing that before any recovery in a Samsung device, right? Because like I mentioned in the first post I’d like to have Dolby Atmos on my phone.

Did you find the special instructions for “Your first boot into TWRP”? It sounds as if you did not; as this would explain both results.

Do you mean this part?

Therefore you will have to manually reboot the device by pressing the main button, the power button and the volume down button. As soon as the screen turns off, move your finger from the volume down button to the volume up button (while continuing to press on the other buttons) in order to enter into TWRP.

If so, I already tried that but again I got stuck on the loop… I’ll be trying to install magisk and the link that piero recommended with vbmeta, if still necessary with magisk

Thank you for confirming that you got the “magic” of first boot into TWRP, - it is probably the most common reason for failure! :slight_smile:

Be sure to follow fully the guide by corsicanu, noticing the way that he separates

  • App Install Method (Requires Root):
  • Odin Install Method (No Root Required):

/e/ documentation may recommend against App installs (for various reasons) but @piero is absolutely correct to draw your attention to the “patch the stock ROM to prevent the stock ROM from replacing TWRP”

Also, anytime you get the same error twice, review all suggestions provided. This crops up very early in this thread: Samsung - Galaxy S10 - beyond1lte - Documentation Suggestions. It includes a warning about a limitation of TWRP; and it is mentioned that LineageOS documentation includes a "Pre-Install Instructions” section, found at Install LineageOS on beyond1lte | LineageOS Wiki.

1 Like

So should I be going with the e-Recovery or Lineage-Recovery w/ Odin instead of TWRP?
I did try the e-Recovery in tar (thanks to 7z) with Odin within the last few days and got an error.

Edit: And btw my phone is already rooted like I mentioned, which is giving me a message every time I boot, and I have to “click it away” with the power button.

Now you are getting to know the device my advice is to go with your own judgement. We all tend to read these warnings with our own emphasis, perhaps based on where we are most comfortable usually based previous experience.

You have a relatively new device, so you are leading the way! Without the device in my hand I feel you don’t need my view over the experts who have contributed the material we are each reading!


I feel like TWRP or LOS Recovery would give me more flexibility/future-prove, if I understood it correctly.

I’ll try twrp with magisk first and if that one fails I can still go with the Recovery.

Ok, so I was able to finally install eOS - thanks for the help :)!

Some notes:

  • One down- or upside is, I had to use TWRP when I tried the Lineage-Recovery Odin would crash every time. I followed the Odin tutorial here that piero already posted: [RECOVERY][OFFICIAL][3.5.0-x] TWRP for Galaxy S10/e/+/5G Exynos | XDA Forums

  • I did not install Magisk for now

  • Adb sideload didn’t work since my device wasn’t recognized, although it did work with my Sony Xperia Z5 in the past

Is there any way to fix this?

  • When I boot up my phone I am always greeted by the “your bootloader is unlocked” text and I have to press the power button every time edit: Also goes away on it’s own

  • After that, I get another new red text on how I am not using the original OS

Now, I still have to get used to the eOS look and feel. Have to swipe down to see all Apps is something I am not used to at all. I also noticed there is no default QR scan app, like with stock Samsung if I remember correctly.

I’ll be using it as my daily driver for now and hope I don’t get any issues. For now everything looks fine, although unusual like I mentioned.

Edit: Because of weird reply limit (probably because this isn’t my thread anymore)

happy new year :)!

Yes I did follow the pre-install instructions.
I checked out Lawnchair, really saved me^^! Although I am wondering: Shouldn’t one be careful even when it comes to installing Launchers, because of privacy?

I’m using QR Scanner (privacy friendly) from F-Droid. Although I couldn’t find a way to make it part of the tiles. Binary Eye has this feature!

Some things that came up for, that might go beyond the constraints of thread, and no idea if they are just me not seeing things or a “real issue”:

  1. I used to get 4G on my phone but with /e/ I only get LTE (recommended), 2G and 3G
  2. I have some problems with Signal not being able to see/import my contacts even though permission is set.
  3. As far as I can remember there was a setting about screen resoltuion on stock, it’s missing in /e/. But again, this could be something like the Dolby Atmos, that is pretty much stock/magisk exclusive
  4. On my Sony Z5 there was an AudioFX App with LOS 18.1, it’s missing from eOS. So I am wondering if there is something that is similar and comes close to Dolby Atmos
  5. Is there any way to blacklist remove the ability to install GApps? I know in Aurora there is some hide feature, but I am still getting the recommendation.

Kind regards

1 Like

Great news - Happy New Year!

Sometimes you have to see those lock messages as your “Escape badge”! However I wonder if what you see is standard for new Samsungs, that sounds more than I see. Did you go through Pre-install instructions as mentioned by @unicorn above? Install LineageOS on beyond1lte | LineageOS Wiki

One comment there is on the default launcher or Home app, Bliss. If you don’t get used to it, you might check out Lawnchair. You might have to use Aurora store in order to get the current version 2. For QR scanning I use Binary Eye.

1 Like

Have you ever tried if it is possible to start Odin in Wine? Would be an interesting solution for people without Windows.

(I hope this will be considered only slightly off-topic in Document Suggestions :blush: )
Heimdall Frontend is spoken of infrequently; in Debian the package names are heimdall-flash and heimdall-flash-frontend. In command line we see:

Usage: heimdall <action> <action arguments> #with heimdall help to start.

We can fire up the GUI, (looks fairly similar to ODIN) with


Hope this might help users find it in their distro! :slight_smile:

…and @Xenthos to answer your actual question, after adjusting Debian to cope with Windows 32bit, UNTESTED, I was able to
wine 'Odin3 v3.09.exe'



Tried starting it directly from my Windows installation partition… Nope. Doesn’t play nice with NTFS drives.
Moving it onto a linux partition solved that issue for me.
However I can’t test if I’d be able to connect as I don’t have my Samsung device anymore.

This is wrong file for the Samsung S10 (SM-G973F). You’ll need the TWRP version beyond1lte in stead of de the beyond1qlte. Note the letter q! The beyond1qlte is used for the snapdragon version. The SM-G973F is the exynos version.

1 Like

Tbh it is a bit confusing, and at some point I did use the wrong recovery.
The one I ended up using and working was twrp-3.6.0_9-1-beyond1lte.img

Although was on eRecovery after installing /e/ and after switching to LOS I am most likely on LineageRecovery now.

If there is a working (and maybe even out of beta?) version of /e/ I am more than happy to switch again, or even buy an efoundation phone at some point (the Fairphone 4 looked interesting)