Samsung - Galaxy S10 - beyond1lte - Documentation Suggestions

Now you are getting to know the device my advice is to go with your own judgement. We all tend to read these warnings with our own emphasis, perhaps based on where we are most comfortable usually based previous experience.

You have a relatively new device, so you are leading the way! Without the device in my hand I feel you don’t need my view over the experts who have contributed the material we are each reading!


I feel like TWRP or LOS Recovery would give me more flexibility/future-prove, if I understood it correctly.

I’ll try twrp with magisk first and if that one fails I can still go with the Recovery.

Ok, so I was able to finally install eOS - thanks for the help :)!

Some notes:

  • One down- or upside is, I had to use TWRP when I tried the Lineage-Recovery Odin would crash every time. I followed the Odin tutorial here that piero already posted: [RECOVERY][OFFICIAL][3.5.0-x] TWRP for Galaxy S10/e/+/5G Exynos | XDA Forums

  • I did not install Magisk for now

  • Adb sideload didn’t work since my device wasn’t recognized, although it did work with my Sony Xperia Z5 in the past

Is there any way to fix this?

  • When I boot up my phone I am always greeted by the “your bootloader is unlocked” text and I have to press the power button every time edit: Also goes away on it’s own

  • After that, I get another new red text on how I am not using the original OS

Now, I still have to get used to the eOS look and feel. Have to swipe down to see all Apps is something I am not used to at all. I also noticed there is no default QR scan app, like with stock Samsung if I remember correctly.

I’ll be using it as my daily driver for now and hope I don’t get any issues. For now everything looks fine, although unusual like I mentioned.

Edit: Because of weird reply limit (probably because this isn’t my thread anymore)

happy new year :)!

Yes I did follow the pre-install instructions.
I checked out Lawnchair, really saved me^^! Although I am wondering: Shouldn’t one be careful even when it comes to installing Launchers, because of privacy?

I’m using QR Scanner (privacy friendly) from F-Droid. Although I couldn’t find a way to make it part of the tiles. Binary Eye has this feature!

Some things that came up for, that might go beyond the constraints of thread, and no idea if they are just me not seeing things or a “real issue”:

  1. I used to get 4G on my phone but with /e/ I only get LTE (recommended), 2G and 3G
  2. I have some problems with Signal not being able to see/import my contacts even though permission is set.
  3. As far as I can remember there was a setting about screen resoltuion on stock, it’s missing in /e/. But again, this could be something like the Dolby Atmos, that is pretty much stock/magisk exclusive
  4. On my Sony Z5 there was an AudioFX App with LOS 18.1, it’s missing from eOS. So I am wondering if there is something that is similar and comes close to Dolby Atmos
  5. Is there any way to blacklist remove the ability to install GApps? I know in Aurora there is some hide feature, but I am still getting the recommendation.

Kind regards

1 Like

Great news - Happy New Year!

Sometimes you have to see those lock messages as your “Escape badge”! However I wonder if what you see is standard for new Samsungs, that sounds more than I see. Did you go through Pre-install instructions as mentioned by @unicorn above? Install LineageOS on beyond1lte | LineageOS Wiki

One comment there is on the default launcher or Home app, Bliss. If you don’t get used to it, you might check out Lawnchair. You might have to use Aurora store in order to get the current version 2. For QR scanning I use Binary Eye.

1 Like

Have you ever tried if it is possible to start Odin in Wine? Would be an interesting solution for people without Windows.

(I hope this will be considered only slightly off-topic in Document Suggestions :blush: )
Heimdall Frontend is spoken of infrequently; in Debian the package names are heimdall-flash and heimdall-flash-frontend. In command line we see:

Usage: heimdall <action> <action arguments> #with heimdall help to start.

We can fire up the GUI, (looks fairly similar to ODIN) with


Hope this might help users find it in their distro! :slight_smile:

…and @Xenthos to answer your actual question, after adjusting Debian to cope with Windows 32bit, UNTESTED, I was able to
wine 'Odin3 v3.09.exe'



Tried starting it directly from my Windows installation partition… Nope. Doesn’t play nice with NTFS drives.
Moving it onto a linux partition solved that issue for me.
However I can’t test if I’d be able to connect as I don’t have my Samsung device anymore.

This is wrong file for the Samsung S10 (SM-G973F). You’ll need the TWRP version beyond1lte in stead of de the beyond1qlte. Note the letter q! The beyond1qlte is used for the snapdragon version. The SM-G973F is the exynos version.

1 Like

Tbh it is a bit confusing, and at some point I did use the wrong recovery.
The one I ended up using and working was twrp-3.6.0_9-1-beyond1lte.img

Although was on eRecovery after installing /e/ and after switching to LOS I am most likely on LineageRecovery now.

If there is a working (and maybe even out of beta?) version of /e/ I am more than happy to switch again, or even buy an efoundation phone at some point (the Fairphone 4 looked interesting)

recovery is outside of the normal system, so you can swap it out whenever you want (via Download mode and then install new recovery), you just have to make sure it’s for the correct version and model. Keeping it up to date is also a good idea, since it can cause issues with OTA/Updates (this is for the most part done automatically if you hit the checkbox to update recovery)

1 Like

Thanks, I am guessing I can do that somewhere in the recovery settings.

Also what I did notice on my device is that sometimes I cannot “close” an App when I hit the return button, the application simply flashes back on, and I have to “kill” the app itself.

It can be set in “settings”

I think it was update settings, or during Initial setup.

1 Like

Can you be more specific, please?

1 Like

An “template error” has crept into Install /e/ on a Samsung Galaxy S10 - “beyond1lte” section Pre-Install Instructions where we see

  • devices.download_boot_beyond0lte

in place of

  • hold Volume Down + Bixby and connect USB cable to PC

Noticed this some time back. This is an error that came in after the template was updated. Have updated it.

Thanks for the great documentation, bellow a remark and a suggestion.

There is a paragraph duplicated here :

Note: Be sure to reboot into recovery immediately after having installed the custom recovery. Otherwise the custom recovery will be overwritten and the device will reboot (appearing as though your custom recovery failed to install).

I managed to follow all steps successfully but I get difficulties during this step :

Manually reboot into recovery:

  • With the device powered off, Reboot and immediately hold Volume Up + >Bixby + Power while the device is connected to a PC via USB cable

It would be useful to indicate that it is normal that “download in progress” is still displayed at the end of the download, and to precise how to reboot (volume down + power button 7/8s) and quickly switch to volumeup bixby power.
The documentation of lineage is interesting : .

1 Like

Hi, I’ve just now installed /e/OS on an S10 and I’ve noticed a small problem with the German translation. After I’ve successfully flashed the phone, I got the below info about updating the recovery.
It say, if the Recovery shall remain unchanged after an /e/OS update, then I shall deactivate the function.
However, the checkbox is unchecked in the first place (i.e. deactivated). That’s a little confusing to me.
If the default behavior should be to have it automatically updated, then checkbox should be IMO checked by default. Then if I don’t want the auto-update of recovery, I should uncheck the box.
So my suggestion is to leave the text as is, but check the checkbox by default.
In the case the checkbox should be unchecked by default, the translation should be changed IMO.

Install /e/os on Samsung Galaxy S10 on Linux Mint

This was my first time ever flashing a phone. I am coming from the IOS world.

First, I used this video to find out how to unlock the bootloader. I fumbled around for like 1 hour pressing keys and not seeing, that I have to go into the bootloader settings for everything to work.

This is the video that helped me a lot:

Then I installed the adb and fastboot (and the libs) using a simple sudo apt install.

Also for heimdall there is no need for the process of downloading and compiling. Simple

sudo apt install heimdall
sudo apt install heimdall-flash

did it for me.

After that I installed recovery V14 and OS V14 (wanted to have the same version number) from the description of the website.

Worked like a charm. :slight_smile: Then I upgraded in /e/os to V15.

Very happy to have a Open Source Privacy focused phone! :slight_smile:

If you got a Galaxy S10, just look at the video for how to unlock the bootloader. The rest will be a breeze.

Follow up question: Now that I got /e/os running, can I lock the bootloader again?