Samsung - Galaxy S10+ - beyond2lte - Documentation Suggestions

…Enter suggestions to improve documentation in this category. Do not raise bugs or issues here…

Just got an update from the LOS maintainer for the device that TWRP could create a problem …specifically it will cause issues on these devices and eventually even force users to wipe in order to boot up again after an OTA (this is due to TWRP messing with FBE encryption)
The suggested method by the maintainer is to avoid TWRP and instead use the Lineage recovery .

Checking with the team if the lineage recovery will work with the /e/ build and also if the /e/ recovery will be updated to accommodate these changes

Will also check how to add this to the documentation for the S10 devices

add instructions to flash e-recovery instead of TWRP

  1. Download custom recovery, /e/ recovery from named something like recovery-e-0.18-r-20210831132813-dev-beyond2lte.img (depending on version)

  2. Enter Download mode:

  • With the device powered off, hold Volume Down + Bixby and connect USB cable to PC.
  • Now, click the button that the on screen instructions correlate to “Continue”, and insert the USB cable into the device.
  1. heimdall flash --RECOVERY <recovery_filename>.img --no-reboot

  2. Device will be flashed, be patient: When the status message in the top left of the devices’s display reports that the process is complete, you may proceed.
  3. Unplug the USB cable from your device & manually reboot:
    press the Volume Down + Power buttons for 8~10 seconds until the screen turns black & release the buttons immediately when it does.
  4. Then proceed to boot into the recovery:
    Reboot and immediately hold Volume Up + Bixby + Power while the device is connected to a PC via USB cable.

Installing /e/ OS from /e/ recovery

  1. Before proceeding ensure you have downloaded the /e/OS for your device.

  2. If you aren’t already in recovery mode, reboot into recovery mode:
    With the device powered off, Reboot and immediately hold Volume Up + Bixby + Power while the device is connected to a PC via USB cable.

  3. Now tap Factory Reset, then Format data/factory reset and continue with the formatting process. This will remove encryption and delete all files stored in the internal storage.
    Proceed with “Format cache partition” and “Format system partition

  4. Return to the main menu

  5. Sideload the /e/OS .zip package:

  • On the device, select “Apply Update”, then “Apply from ADB” to begin sideload.
  • On the host machine, sideload the package using: adb sideload
    If the process succeeds the output will stop at 47% and report adb: failed to read command: Success. (on the PC terminal)
  1. Once you have installed everything successfully, click the back arrow in the top left of the screen, then “Reboot system now”.

Major parts of this have been from the installation guide from LineageOS, while I have edited some parts from my experience.

1 Like

Please don’t entomb TWRP until we have a data, settings and apps backup solution…

1 Like


I am trying to install /e/ on a s10+ (Android 10).
I am on Ubuntu.
What I did:

Method 1: heimdall

  • On S10+, set up android 10 + update

  • Turned on developer option / allow usb debugging. Unable to find OEM Unlock evn after update and reboot.

  • on PC Ubuntu>
    instaled adb & fastboor + Heimdall

On S10+ Enter Download mode.
On PC: heimdall print-pit
_> Error: ERROR: Failed to send handshake!ERROR: Protocol initialisation failed!

Same error when heimdall flash --RECOVERY <recovery_filename>.img --no-reboot


  1. method 1: Sideload
    reboot in recovery mode
    factory reset
    wipe format data
    adb sideload
    PC: message= Total xfert: 1.00x
    S10+: Message = install completed with status 2 installation aborted

Reboot now
Samsung logo on screen

after 3 min start android config

Any idea where I did something wrong ?

Many thanks in advance

Merci ! in fact the problem is in the model of S10+ I have. It seems Snapdragon CPU are not OEM unlock-able… and hence not compatible. Too bad for me.

OEM unlock isn’t optional, you gotta unlock before you can install custom OS/recovery
That said, it should be available for the Snapdragon version of the S10+, but you maybe need to connect to a Wi-Fi network first!
I had the same phenomenon on my phone and also read in other threads about this issue.

But /e/ OS is only available for the international (global) version of the S10+

SM-G975F/DS (Global); SM-G975U (USA); SM-G975W (Canada)

That said, it maybe possible to install if there is a generic image … if you are the adventurer type.

Check that your heimdall is installed via typing into terminal:

heimdall version

other than that it’s essentially the steps as shown in piero’s post… other than flashing /e/ recovery instead of TWRP because that may cause issues.

1 Like

Try using Windows Odin

I just wanted to add additional info in case it helps someone else in their attempt to install eOS on a Samsung S10+. I walked through the instructions multiple times but each time it would boot back into Samsung’s OS. I finally figured out that in addition to enabling “OEM unlock” in developer options you also have to unlock the bootloader.

Full instructions can be found at this site, ( How to unlock bootloader in SAMSUNG Galaxy S10 Plus Exynos?, how to - - pay attention to step 8 and forward) but basically you boot up the phone while pressing both the Bixby button and the volume down button (and then insert the USB cable) there should be an option on the screen to long press the volume up button to unlock the bootloader. The key is long pressing on the volume up button at this point instead of using a short press to “continue.”

This enabled me to go into the /e/ Recovery screen, but at that point I was unable to sideload the zip file via the ADB command (I think this may have been caused by Samsung OS previously loading). My workaround was to load the zip file onto an SD card as that is one of the options in the /e/ Recovery.

That successfully completed the eOS installation.


Thank you! I met the same issue. But to unlock the OEM part I think I had to insert my SIM card unless the menu would appear.

Now, I’d like to understand

  • how to get ride of the ugly message about «the phone bootloader is unlock… gnagnagna warranty gnagnagna. PRESS POWER"
  • how to secure the boot process anyway

Thanks in advance

Unfortunately, I don’t have the phone any more since it wouldn’t work with my carrier, but I remember wanting to lock the bootloader to get rid of that message too, but I think when you unlock the bootloader and install a different ROM it may be built into the hardware to prevent you from locking it again. Unfortunattely, I can’t verify that. If you haven’t done that already, you could try going back to the same section where you unlocked the bootloader to see if there’s another option to relock it.


Can I install version S on my S10+ running Android 12 ?

I see this on the install guide page:
Warning: Before following these instructions please ensure that the device is on the latest Android 10 or 11 firmware.

But I see this on the Smartphone Selector page:
Update 9 Nov /e/OS ‘S’ builds have been released. You can find the download links on the Documentation site

Can I install on Andoid 12 now or do I need to wait or what?

Thank You :slight_smile:

I successfully installed e/OS S on the SM-G975F/DS model! Initially, I had been stuck at the Samsung Galaxy boot screen after installing, but I was able to fix that by following these steps:
Before installing e/OS, I had installed the latest updates from Samsung. It appears that those updates prevent any LineageOS + microG ROM from booting. I had tried several versions of e/OS, the microG Lineage project, and then read about the issue for iodéOS (another similar project). But, by flashing the phone back to an older Samsung version, I was then able to install e/OS and boot without a problem.

1 Like

Because of anti-roll-back protection by Samsung, you need to flash something new.
/e/ include security patch from the past mounths, if your device was recently updated from the vendor, you have two ootions, wait for a /e/OS newer than your installed firmware, or first install (if possible) an older firmware based on the same latest android level.