Samsung - Galaxy S10e - beyond0lte - Documentation Suggestions

Hi I finally succeed to install /e/ on the S10e thanks to community support !

it was and “orange” ( french carrier ) device before

What we should change :

  • if the KG or RMM is “locked” the user has to boot once and change the date to seven days earlier ( we still need to clarify that ) otherwise we will get some kind of

only official release can be flashed

when trying to flash recovery , I also inserted a french ( Free mobile) sim card , I don’t now if this made the KG to “checking” mode

  • After the recovery is flashed , we have to tell to poweroff using BIX+VOLDOWN+ PWR and right after go in recovery with BIX+VOLUP+PWR , otherwise the recovery will be erased and the samsung recovery will be booted.
1 Like

I installed /e/ on Galaxy s10e Beyond0lte Exynos from a windows machine today. I would like to sugest an easyer method for people not fit for code.


  • /e/ build and recovery
  • TWRP
  • avb disabled vbmeta .tar and odin from here

Pre install instructions stay same.


  • power off phone
  • aktivate download mode
  • open odin (phone should be shown as “added”)
  • put TWRP.tar file as AP
  • put vbmeta.tar file in CP
  • start flash and immediately press Vol-Up+home+power
  • TWRP should start
  • swipe right for write mode
  • transfer /e/ recovery and /e/OS on phone or SD-card
  • go to install/Install Image
  • choose /e/ recovery file
  • hit reboot into recovery (/e/ recovery is booting)

From here it is the same steps than in the existing description.
Steps to install /e/OS from recovery

For me this was much easier than handling heimdal.


Thanks but we can only give instructions with open source tools , you have the graphical heimdall that could replace the CLI if you prefer


There is a warning saying “Do not install /e/OS on top of a higher version of stock OS.”

The documentation does not say what one should do if his S10e is running Android 12 “S” version, when the latest available /e/ version is R.

Hi @Cobus, welcome to this forum !

I clearly understand that you have 2 options :

  • Downgrade the device Stock OS
  • or Wait for an upgrade of /e/OS

Luckily there is one HowTo for your device series :
/How to/ install /e/ R on a samsung galaxy s10e already running android 12

Thank you for your quick reply, @piero !

I saw (and read) this thread about downgrading, but My CSC shows an “F” binary.
Sammobile has no frmware downgrade to Android 11 for CSCs with “F” binaries.

Looks like I have to wait for an upgrade of /e/OS…

It is a common warning, if you like playing, you could try, as it seems not to have big difference betwen android 11 and 12 device and system trees, that there were betwen 7 and 8

In case of problems, Odin can restore your device to his original state (note your firmware version code number included CSC to download it from sfirmware faster than sammobile or from database of your choice)

Thanks for your advice !
I may give it a try and post the results in another thread (it would be off topic here).

Anyway, I had the right advice (from you @piero), but other readers of the docuentation may need it too.
I think that a table with “What Android version do you run” entries and "what should you do to run /e/ version Q, /e/ version R, etc. outputs would make things clear.

Hello, Just a small glitch but with important consequences for new users/installers :

The documentation for installation of /e/os on Samsung s10 s10e s10+ is not using the last Heimdall link from lineage doc. The heimdall version linked in the /e/ os doc is not working. The Heimdall offered in Lineage OS doc is working.

The instructions of other samsung devices should also be checked for this.

1 Like


I’ve just installed the 1.6-s build on s10e using Ubuntu. There are also other successes for this phone with this build (here, there…)

NB : I used the heimdall I took previously from the LineageOS install page.

The documentation and install documentation must be updated:

  • my model is SM-G970F/DS (dual sim), documentation can add this model (as LineageOS has)
  • my model was running G971FXXSGHVI1 (Android 12) before flashing the ROM

Many thanks for all people making this build and documentation available.

Sometimes when you flash a custom ROM through Recovery on S10e you ended up stuck on boot screen logo. This happens because the firmware needed to be upgraded, there is a tutorial maded by LineageOS team teaching how to do that and it works perfect with e/os too. This happens on my phone and i fixed by upgrading the firmware.

Here is the link if anyone get stuck on the process:

1 Like

I had the problem during the installation that I got an error message when sideloading at the 47% point and the installation was aborted.
The message that was displayed:
"E:failed to verify whole-file signature
Update package verification took 57.6 s (result 1).
E:Signature verification failed
E:error: 21

Install from ADB completed with status 2.
Installation aborted."

It helped me to switch on ADB via the recovery screen: “Advanced >> Enable adb”.

After that, the installation worked without any problems.

1 Like

We managed to flash a Samsung S10e at or flash-party, but it has been hard.

First, it was “RMM” locked. So flashing with heimdall ended up with this error on the command-line

Ending session...
ERROR: Failed to receive session end confirmation!
Releasing device interface...

And a red message on the device, saying:

Only official released binaries are allowed to be flashed(RECOVERY)

The solution of this first issue was simply to start the device once, and connect it to the Internet (WiFi or mobile data)

But it was still ignoring the /e/ recovery, and rebooting on Android.

The solution, found on, was to flash both the recovery and the vbmeta.img (downloaded from, with this command-line:

heimdall flash --RECOVERY recovery.img --VBMETA vbmeta.img --no-reboot

I think it’s necessary to add this information in the official documentation.

Finally, as @freechelmi said 2 years ago in Samsung - Galaxy S10e - beyond0lte - Documentation Suggestions - #5 by freechelmi, the buttons usage should be more explicit after recovery flashing

1 Like

Thanks! That did the trick for me! I could not get into /e/ recovery before. Tried several times but doing it this way worked immediately. =)

1 Like

Hello, I am running into the very same problem than you, but I don’t understand how you fixed it. What do you mean by «switch on ADB via the recovery screen: “Advanced >> Enable adb”.« ?

1 Like

If you already have access to /e/OS recovery then you may simply go in the sideload/adb menu to activate sideload mode and then from your PC send the terminal command sideload … to send and install the OS image.

If you do not have access to /e/OS recovery, then it is probably because the Samsung recovery erased automatically the /e/OS during first startup after loading the /e/recovery in fstboot/download mode.
As explained in previous posts, the key combination is tricky and the change from volume down to volume down must be very fast as soon as the phone switches off, while always pressing the two other keys. It might require several trials.

thanks for your reply! That must be it then. After installing the e/os/ recovery in download mode, I reboot (there seem to be no solution for just switching off, only reboot by pressing for 7 seconds PWR+VOL Down or something like that), and as soon as it is off, I press PWR+VOL UP+BIXBY, and end up in “Android Recovery”. From here, I have the menu with the entry “Apply update from adb”, which I do, and then I got the error I mentionned.
Shal I understand that this “Android Recovery” is not the right place? I should have “e/os/ recovery”, where I will find this sideload/adb menu? I’ll give another try this evening.
Or could it be that the installation of the recovery image with heimdall has not worked properly? On my command prompt on the PC side, it looks fine, but on the telephone screen, I see nothing, except the progress bar that seemed to be at 100% after a few seconds, so I assumed it went fine.

Also, there are many posts that mention TWRP, but the installation guide does not. It does mention it in the troubleshooting section though. That is a bit confusing. Is TWRP obsolete for the installation on the Galaxy S10e?

Last point, my Galaxy S10e is runnung Android S (12), and I downloaded the e/os Android T(13) That should be fine, right?

Thanks again.

You are correct, Android Recovery is not the /e/OS Recovery.
From what you say, you probably install correctly the /e/OS recovery but it is then erased by the automatic process and replaced by the Android recovery again. Try switching to up button before while keeping pressed all the other buttons.

Regarding the Android version, if I am correct, the latest version that Samsung has pushed on the phone is Android 12 and it will not be a problem for installing a newer Android version like /e/ 1.20 T / android 13


  • To get out of the Download mode you must Force Power Off your Samsung device,
    unplug the device,
    hold Volume Down + Power.
    release when you see the screen turn off…


  • immediately Boot to Recovery before any other boot mode attempt,
    hold Volume up + Home + Power.
    release when you see the very little blue line in the top of the screen…




if you see something like that :



It FAILED ! that is the Official Stock Vendor Samsung / Gogol Firmware Recovery screen !
Please re-read and retry the flashing process

Thank you for all your advice. So indeed, I was on Android Recovery instead of /e/OS recovery. What I actually had to do was, at the first (green) screen in download mode, to make a long press on VOL UP, which means “Unlock device” or something like that, to allow the installation of unofficial ROM, instead of a short press, which weans “continue” (as the install guide tells us to do.). At this point, the telephone tried to reboot several times, hanged up on the SAMSUNG logo, then started with a welcome screen (the one when you start with a brand new Android to configuer), so from here I could switch it off properly, and reboot in download mode. Then, short press on VOL +, installation of the recovery image, then reboot as explained, and I finally ended up on the /e/OS recovery, etc… I just had to follow the install guide from here.
It’s all fine now, I am enjoying my brand new /e/OS on my Galaxy S10e ! :smiley: Thanks again to all of you.