Samsung galaxy s7 - stuck on TWRP screen or Download mode

Hi team,

I was happily using /e/ on Samsung Galaxy S7.

At some point it stopped recognising my sim card.

Sim card works fine as I can use it in a different phone.

Initially I thought it was a hardware fault.

Then I thought it could have been due to Magisk which I had installed in order to get my banking app running (to no avail).

Anyway I uninstalled Magisk but it wouldn’t still work.

I did a wipe cache - nothing

I did a Dalvik Cache Wipe - still nothinig.

I did a complete reset and still nothing.

I was convinced that it was a hardware fault.

As a final attempt I thought to install LineageOS. I found a LeOS version 19 (Android 12). Installed it using TWRP and the sim card came back to life.

Due to the fact that:

a) LeOS is not as DeGoogled as /e/
b) Some basic apps seemed to crash

I decided I wanted to do a fresh install of /e/ on the phone using TWRP.

I downloaded the dev version (same as I was using before) but after flashing it, it wouldn’t start. It was getting stuck on the e bouncing ball logo.

I then used keys to boot into recovery and it now gets stuck on the TWRP login screen.

I can also get into download but I don’t seem to be able to do anything.

Please help!

Is this because LeOS Android 12 is a later version of the /e/ I tried to install?

Is the phone totally bricked now?

I’m using Heimdall on Linux (I have access to Windows PC if necessary).

Both Heimdall frontend and Heimdall command line cannot talk to the device (in Download mode). When I attempt to run heimdall print-pit it comes up with an error:

Detecting device…
libusb: error [_get_usbfs_fd] libusb couldn’t open USB device /dev/bus/usb/002/003: Permission denied
libusb: error [_get_usbfs_fd] libusb requires write access to USB device nodes.
ERROR: Failed to access device. libusb error: -3

Any suggestions please?

I guess what I’m looking to do is to wipe it clean and reinstall /e/ on it.

Many Thanks

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

i am surprise that you can install a G.S.I. (LeOS) into a galaxy s7 witch is not a treble device

antway, after SIM not reconised, if you want to perform a clean install from scratch, my advise is to first revert to lastest stock firmware, install TWRP and finaly /e/

Thank you Piero.

The LeOS was an unofficial I think version for the S7.

The problem I have currently is that the device either gets stuck on TWRP boot screen (3.6.1_9-0) or I can get it to go into download mode.

Is there a way to push TWRP further than the boot screen? Or would I have to do a fresh install of the TWRP from the PC while the device is on download mode?

Many thanks

first of all, try some other cable !

This is before I even try the reflashing.

I was just wondering if there is a key combination to “push” the device to go further than the TWRP boot screen.

Just asking … are you fully aware that LeOS shares some roots with /e/ BUT is quite dissimilar in many ways to LineageOS and /e/ in the install? LeOS is a GSI image.

While you might think it would be a runner to dirty flash /e/ on top of LineageOS … it would be a different proposition to try to put /e/ on top of a GSI.

1 Like

Hi aibd.

Apologies for the late reply. No I’m not aware of this and I don’t fully understand the terminology.

What is the recommendation here?

Ok no problem !

My recommendation here is to flash the phone back to the correct Samsung Stock ROM for your device. What is a stock ROM and how do I get one? Then start again with /e/.

We can also try to help you recover the situation, but it is not fully clear exactly where you are stuck. In following your instructions (linked below) you must just do everything in a workable sequence. When the computer says no, (as we all know) you cannot argue with it, the answer is no. So you must retrace your steps to solid ground!

I just say all this as your previous last questions were:

Is there a way to push TWRP further than the boot screen? Or would I have to do a fresh install of the TWRP from the PC while the device is on download mode?

So let’s just look at this fundamentally.

  • You have Download mode - (this is fairly hard to destroy, but you probably could !), I regard it as a very fundamental communication channel with the device. Any time you could not reach Download mode you would be stuffed.
  • You have Recovery mode. The device comes with Samsung recovery has limited powers to recover the “Main device system”. We like to substitute a Custom recovery, TWRP. It is generally best to search for the TWRP recommended for your device and use that. If it is wrong, change it. If your Recovery can cause “System” to boot, end of story. If “System” cannot boot or run, the system will just collapse and (fundamentally) hand back to Recovery.
  • Now we have the System. This only really has to contain every element of the ROM, in the correct place and with the correct connections to the “Lower layers”, and it will run.

So the answer to the question as you posed it would be No and Yes.

But the solution is more likely to be some error in “System” which is not allowing “System” to boot or run.

Did you use LeOS last? LeOS (being a GSI) is different from LineageOS and /e/, especially as it makes use of the “Lower layers” in a fundamentally different way.

/e/ install instructions,, say

Caution: Do not install /e/OS on top of a higher version of stock OS. Before installing /e/OS ensure your device has the latest stock OS of the same version as /e/OS. If only lower versions of the stock are available then install the last available lower version before installing /e/OS.

I would not expect to be able to advise on how to proceed if you were attempting to flash the device on top of LeOS instead of the recommendation, “the latest stock OS”

Hi again.

Many thanks for the detailed post.

I feel a bit embarrassed to admit that i thought that LeOS and LineageOS are the same thing… Doh!

I installed LineageOS following the instructions found here:

(so when I refer to LeOS in my initial post I actually mean LineageOS)

My assumption is that flashing /e/ again on top of lineageos broke because Lineageos was Android 12 while /e/ is Android 8. Is that a fair assumption?

Ok, so reading from your OP now, the Lineage 12 is well in advance of anything I know. However I think you said that the unofficial LineageOs 19, Android 12, worked.

Then you downloaded /e/ dev version. This would be Android 10. Please reconfirm, because your reference to Android 8 confused me.

The previous recommendation by @piero and me, (revert to Stock ROM) still holds as downgrading Andriod 12 (experimental) to /e/ Android 10 is a recipe for failure.

Now perhaps your OP does say that you are now in the process of trying to install a stock ROM

I guess what I’m looking to do is to wipe it clean and reinstall /e/ on it.

when you get this error?

libusb: error [_get_usbfs_fd] libusb requires write access to USB device nodes.
ERROR: Failed to access device. libusb error: -3

Is your phone bricked? In a Samsung, most unlikely.

This is a communication error between your PC and the device.

This would aim to address the libusb error.

Please confirm if you are seeking help to install a Stock ROM with Heimdall. In this event we are saying a temporary goodbye to TWRP, and just need to get communication with Download mode !

Please tell us the OS on your host machine, and if you might have a second device available. Edit, sorry, I see Linux and Windows, so Windows and Odin3 is also an option for you !

Thanks for all your time Iain.

As far as I can see, for the S7 the latest /e/ dev version is Oreo (which is Android 8).

Many thanks

Doh, my error, you are quite right. :blush: