Samsung Galaxy S9 "only official released binaries are allowed to be flashed(RECOVERY)"

Your local Samsung Support would not help you because they would not be briefed how to work round the commercial arrangement they have with USA to only ship in locked phones.

Time for lateral thinking.

So the phone was sold in UK? Did the seller ship it to USA or a third party? Who handed over £££s in the UK?

@aibd I purchased 2 of these new S9+ G965F models from a private seller on eday from Florida, USA(2nd one will be here in the next few days). The estore was out of stock and because I successfully flashed a new S9 G960F not too long ago I didn’t think there would be any issues. I also bought the new S9 G960F on eBay from a different seller in Texas, USA. I have purchased these S9+s for family members to get them using /e/ ecosystem (OS, cloud, etc).

@egx470 Thanks for all that information! This would be illegal in EU, but I guess you do not have that option for a remedy in the EU. You could consider phoning Samsung UK, but you would have to spin a bit of a “story”. :slight_smile:

I don’t know with a valuable new phone how intrusive you would be prepared to be. What did you make of my getprops idea?

Edit. In the end, I guess it would depend on how intrusive you were prepared to be with a brand new phone. A “money back” road might be the one I would be thinking of!

I’ll have to figure this one out.

Some hope that the issue might dissolve after 7 days? I would not hold my breath. :slight_smile:

I purchased a Walmart Family Mobile (TMobile MVNO approved by /e/ to work) SIM and 30 day plan. I have activated the phone on this SIM and will report back after 7 days :crossed_fingers:. But yes, I am not hopeful :frowning:

Edit: My gut tells me something is communicating back to Knox/Samsung servers my IP location or something alike resulting in code changing the RMM to prenormal because I am outside of the international boundaries set up by Samsung/Knox.

In the UK Asda will send out a SIM card to potential users free of charge.

You might find it interesting to apply, my first guess the SIM would be unsupported in USA, but you might think it worth a try?

Edit, If we are right about Regional lock being the issue, Samsung probably require the “regional” SIM activated and used in the “region”. I did see an xda post that I was not sure of the reliability (now I can’t find), saying Samsung licenced “workshops” could swap out some locks, with proof of ownership using “licenced” Odin. So I do see a fit with your Samsung call handler pointing you to a brick and mortar outfit.

I tried to process a free SIM but the system denied my post zipcode. I emailed them to see if they would ship to the USA if I paid shipping and I am waiting for their reply. I am determined to figure out a way to remove the RMM prenornal lock. This is causing a lot of people problems.

1 Like

If you are hesitant about adb shell getprops, you can run getprops from within the Termux app.

I do not know if it will reveal anything, but it is harmless and may give a clue. :slightly_smiling_face:

1 Like

This did not work so I sold the phone.

1 Like


When you get this screen. Press vol up bixby power to get the twrp screen

TWRP could never be flashed because RMM was set to “Prenormal” blocking any flash. We went the gambit on this, Knox blocks any nonofficial sub Android 10 flash due to the Android 9 update. One would have had to unlock their bootloader before updating to Android 9 if the Samsung device was activated outside its geographically fenced country. We have had multiple confirmations on this :worried: Avoid Samsung hardware if found in these circumstances.

And what about using a combination firmware to downgrade and reset the bootloader count ?

After updating to official Q it would not let me flash to official Pie or official Oreo. It was like Knox knew I was outside the intended geographical location for the Exynos model and locked RMM to Prenormal. Because I did not unlock the bootloader remove RMM with Chimera Tool or cleared it so not flagged “Prenormal” before the update to official Pie I couldn’t flash anything unofficial nor go backwards to official Oreo so I continued to official Q. RMM prenormal was blocking any flash except official Q.

Edit: I paid to use Chimera Tool and confirmed with their support team that this change took place with the official Pie update.

Edit: This is what showed every time a flash was tried, except official Q which would flash every time. :point_down:

1 Like

I, like yourself, purchased one of these phones from a Florida eBay seller. Just got the phone yesterday and installed all the system updates. Tried installing /E/ tonight and got the same error you did. I’ve been trying to figure this out for the past 3 hours. The utter disappointment I have after reading this thread man, was so looking forward to getting this phone set up this weekend.

Welcome @Archer,

Wish I had gotten to you before the updates. If you can return it and get a OneOlus 6T I highly recommend. I am typing on one now and it is the best phone I have used /e/ on. The Galaxy 9 series don’t support VoLTE or VoWiFi. This OP6T supports both and has awesome specs. This was TMobile’s official 6T and everything was very smooth except having to wait 7 days for the unlock code. Samsung in the USA is bunk, that is until /e/ can figure out VoLTE/WiFi.

1 Like

Ill order one tonight and give it a try, i currenting have a Note 20 Ultra and i hate it. I had an S9+ before that and loved it, hands down best phone I’ve ever owned, should have never got rid of it. I’ve been trying to remove google from my life and when i found out i could get another S9 and have it Degoogled, it sounded almost to good to be true, i guess it was. Thanks for your contributions to this thread, I’m glad i stumbled upon it when i did, i was starting to loose it!

1 Like

Shout-out should go to @aibd, can you believe how long he stuck it out to help me? He is a saint!

Just also had this issue with a Samsung S9+ with the Prenormal issue.
For me it seems it was fix when I inserted a SIM card and waited some minutes

1 Like

Good point, thanks @ronnz98, before getting over anxious about this error, just use the phone, it may need to connect to RMM (Remote Management and Monitoring), Post #30.

Or to help analise any other issue, I have updated Know your hardware – Samsung #Bootloader locked.