Samsung Galaxy Tab2 espressowifi (two models 7 & 10)

Cant install on p3100 i get error 7 on twrp

@Mighty, as you can read above, there might be an issue with TWRP 3.4. Just downgrade to 3.3.x.x and try again.
Check also my previous posts about rebooting after formating /data

Didnt work
Its stuck at e logo
i dont think this is gonna develop more Andi did leave development didnt he?

“stuck at e logo” can only be caused by a faulty installation! And in no case TWRP 3.4.0-0 should be used but only TWRP 3.3.1-0.

@Android-Andi’s /e/ ROM’s work very well - on all models in all variants. Only the first start after installation takes a perceived eternity. Then Andy’s /e/ OS Edition runs on the TAB with only 1 GB RAM including phone calls with 2G.

Andi has updated the sources and made a test build, but he don’t have time for further development…
sources are open !

Yup i downgraded to TWRP 3.3.1-0 from the official twrp website! Still its stuck on the logo for quite a lot of time
I am in no ways blaming Andi his work for the tab 2 is just awesome!

Yes i know i have been trying to build oreo myself but i have 2 issues
1 - Kernel is too old for oreo and i dont know how to update it
2 - My computer is well below the requirements to build AOSP

Yes lol i have been flashing roms from a long time i know xD

Installing the latest version of stock Android 4.2.2 (Jelly Bean) sometimes works wonders. Then again TWRP 3.3.1-0 and e-0.9-n-20200618 * espresso3g / espressowifi. I know with absolute certainty that @Android-Andi’s ROM works well.

Okay will try thanks for still continuing development on this tab!
Hopefully I can help

Any idea if someone is developing Oreo or above Android versions?
Anything i can do to help?

Hi all,

I just installed e OS on my Galaxy Tab 2 P3100 following the How To written by Android-Andi.
After a couple of hours of usage I can say I’m pretty satisfied, the only thing I noticed is the Apps app crashing from time to time.
I really enjoy the fact that quite all the apps I was looking for are available and works.

Thanks a lot!


What TWRP version did you use and what rom was before it

TWRP version 3.3.1 --> twrp-3.3.1-0-espresso3g.img

Previously everything was as out of the factory (Android 4), so I would say a stock ROM.

Sorry, I currently don’t have enough time to update this rom.

Afaik no one working on Oreo or above @Mighty.

But: Merry Christmas everyone :christmas_tree::snowman:

1 Like

And about the recovery: you should use one of my compiled TWRP which works on All 6 variants (P31xx and P51xx):

1 Like

Alrighty thanks a lot

Oh i guess that might have been an issue, i used twrp from the official website!
It worked fine i could flash sungsonic as well as i flashed my mainline (trying to mainline tab 2) kernel, if you can guide/help me in that it would be really great!
Will try with your twrp, thanks a lot!

Merry Christmas :christmas_tree:

Alrighty it worked, thank you all for helping and thanks Andi for building it!
It feels really snappy :smiley: will try with some apps installed
Camera is broken and keyboard appears when i remove app from recents :?
Nevertheless I hope someone continues this (or maybe Oreo Go considering normal Oreo will be too heavy for 1 gig RAM)

Edit - Cant install app from Apps nor can download apks…