Samsung S7 Edge fail to open recovery_cause(No such file or directory) loop


My grandstander’s Samsung S7 Edge was frozen on the Samsung S7 logo screen, and it didn’t want normally turn on.

We launched it in Safe Mode, and now it is in a constant loop with an error message “#fail to open recovery_cause(No such file or directory).” Please, see the attachments below.


The phone is not as important to him as the photos accumulated on the phone’s internal memory over the years. He didn’t back them up into the cloud.

We tried using DroidKit and Fonedog apps to recover the information on the phone, but they didn’t work.

We are afraid to use Odin because we are unsure if it removes photos on the memory.

How could we recover grandpa’s photos from this phone? Any suggestion will be greatly appreciated.

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

Hi @kmarcink welcome to the /e/ forum. I am sorry to hear this story.

As a starting point, may I ask if you are sufficiently familiar with the command line to contemplate extracting the photos by adb pull?

The tools to use would be Android Bridge and Platform Tools. This link has some quite readable information.

Do not get involved with the Download tab on this page, but quite a useful guide to getting platform-tools is given in the Commands tab under How do I find ADB located

The command line tools you would be able to use are listed in the left hand menu under File Manager. Please let me know if this would be a good starting point for you.

Alternatively, reflashing the recovery may be worth trying. When you mentioned Odin, is reflashing the recovery what you had in mind? As you mention Odin, this might be a useful tutorial. [HOWTO] Install /e/ on a Samsung smartphone with Windows easily. Do ask again but a recovery.img, that is TWRP, can be found - via - here:

Downloads for the hero2lte

  • Of course the normal warning would be “Back up your data” before experimenting with Odin! This is the reason that I mentioned adb pull first as I think this would be a sound backup method.
1 Like

Hi @aibd,

Thanks for the awesome and detailed replay. I really really appreciate it.

Yes, I know the command line a bit. We plugged in the phone, which caused it to go into a loop that I described in the post above.

We have tried the following pull command as a test:
adb pull /mnt/sdcard/Download/test.apk pc.apk

The result was
adb: error: failed to get feature set: no devices/emulators found
Sometimes it was:
adb: error: failed to get feature set: device offline

Do you know what is the path to the photos in the internal storage?

We also tried the command:
adb devices
Which usually resulted in just
List of devices attached

And sometimes it listed:
List of devices attached
emulator-5556 offline

Unfortunately, we were unable to move any further with adb pull. Should we try something else in it?

About Odin, someone suggested using the following video to flash the firmware on the device, which might help get the phone out of the rebooting loop.

We were unsure what TWRP versions to download. We cannot turn the device on to check information about the device. Any suggestion, which version should we use or how else to check it?

  • Samsung Galaxy S7 edge (Exynos) (hero2lte)
  • Samsung Galaxy S7 edge (China Qualcomm) (hero2qltechn)

Thanks again for your help.

Ok, I can see that adb is unlikely to work, but worth a try if saving the photos was important. The “internal storage” where we expect to find the photos is mounted at /sdcard (I know, sounds improbable; the external SD card is at /external_sd !)

If you cannot get a positive reply from adb devices that door is closed I guess. PS, unless you are able to boot into Recovery mode, mentioned below.

Please be sure to keep the phone fully charged. Please confirm that when the phone is off it will charge ok and keep it well above 60% for the job of replacing TWRP, if you decide to go for it.

Replacing TWRP with no user errors, will leave all the contents of the phone untouched. Odin is a Samsung product, so might tend to draw you to return to Samsung, so just follow the tutorial with care and you will have no problems !

When I wrote

Alternatively, reflashing the recovery may be worth trying. When you mentioned Odin …

I expected all the links beyond that point to cover your situation including the TWRP link; you would use the most recent TWRP, in the format required by Odin, see tutorial.

I guess the long [HowTO] might have looked a bit daunting, but reflashing TWRP is not hard and is only a very small part of that full tutorial. Please study only Sections 4, 5 and 6. I will not rehash any of that information, it was written by an expert, there are points where you have to be very precise, but it is not hard if you stay on course.

I doubt anyone managed to flash /e/ on to a Qualcomm (hero2qltechn) – I say this as it has a locked bootloader.

You will need to be able to boot into Odin mode on the device, described here, Know your hardware - Samsung. Boot modes also given at the foot of this page

So, first, we just need to be sure you can boot into Download mode successfully. Once you do that hero2lte should be displayed in tiny print top left. (You can do this before you do any downloads, hopefully will be nice to see the phone in a stable mode again !)

While experimenting with Boot modes, you might as well try to see if the phone might possibly boot into Recovery mode. Seems unlikely, but silly not to try, as if successful that would give us other options.

Please call back if you do not see Odin mode, or if you do see a stable Recovery.

someone suggested using the following video to flash the firmware on the device

That would not be a good way to approach this, as we cannot be sure a Samsung ROM would not overwrite the internal memory. You would recover the phone for sure, photos unlikely. If we really cannot fix /e/ I would be disappointed.

(I am not good with videos; his presentation left me more confused than I started.)

Of course you do not want to overwrite the system. Your reported error is that Recovery was not found / could not be read. So we propose just to replace the damaged Recovery, a relatively small part of the total software.)

Please tell me anything else is unclear.

1 Like

Hi aibd,

Thank you so much for the detailed reply.

The phone is charging fine when connected via a cable.

We are having a problem with connecting the phone to the MacBook computer. We have downloaded JOdin3 and Samsung driver, but when we open JOdin3, and connect the phone to the laptop via cable, it fails to connect to the phone while the phone is in the Download mode.

Do you have any suggestions on how we could solve this?

More surelly efficient is using heimdall on MacOS

[HOWTO] an Unified Install Guide Project for /e/

Don’t flash over userdata, don’t format or wipe anything for now,
Just flash TWRP and boot on it, to save your photos !
If it’s work, then you will reinstall stock firmware and /e/

If even after you are sure you have success flashing TWRP
you cannot reach recovery mode
It could be because Internal memory is died

I have not used JOdin, but it cannot be much different from the other methods !

Simplest things first USB cable; you will know you need a data cable rather than a charging cable. Avoid any USB hubs.

USB ports within the Mac - does the machine manual indicate if some ports are less optimally connected. On a PC or laptop sometimes the back ports are connected directly to the motherboard and the front ports are effectively off an internal hub. Speculating USB 1, 2, 3 should be compatible (within limits), but it is unknown to me why sometimes a USB combination just won’t work. Maybe Samsung introduce some unknown sensitivity?

Maybe that version of JOdin won’t work on your Mac. Speculating, it may be difficult to juggle the correct version of Java to go with your JOdin download?

This document gives the instructions to install Heimdall on OSX it is quite simple:

These instructions are for OS X operating systems.
Installing Heimdall and Heimdall Frontend Binaries:

    1. Run “Heimdall Suite.pkg” and follow the instructions.
    1. Reboot your system.
    1. Done

This is the source: – I know, too much to read – but as detailed there the “packaged” version is expected to be available through Glass Echidna. This may not be a very up to date way to proceed, but it may well work with an older device.


Thank you, everyone, for your suggestions. We borrowed a Windows laptop to avoid the issue we experienced on OSX.

We got the right firmware version for the right region. We were able to connect to the phone. However, Odin shows the Fail message :frowning: and in the log, it says
Complete(Write) operation failed.
All threads completed. (succeed 0 / failed 1)
included image

We tried:

  • using Odin 3.14.1 and Odin 3.14.1 patched
  • restarting laptop
  • booting the phone into the “download mode” 1x, 2x, and 3x in a row before pressing the start button in Odin
  • using every USB on the laptop

Any suggestions on what can we do in this situation?

During the whole Odin process screen on the phone has not changed. It shows this:
included image

So your Odin mode screen now shows that you have a Samsung original binary installed (I guess this will have involved removal of /e/)

It also shows that FRP lock is applied. (Search Factory Reset Protection.) This is associated with a pre existing Google account.

So maybe this happened since you last reported (I don’t see how). Maybe this is connected with the reason for the reported “implied collapse of /e/ – of unknown cause” in the OP.

I do not know if further knowledge of the history of this incident would help? – by being able to give connected account details?

If you use a bypass FRP method, you could hope to recover the device.

I cannot say if the photos may have survived to this point. I am pretty certain a FRP bypass will ensure full wiping clean of the device. :frowning_face:

I would try another attempt to connect with the device with adb pull; but almost certainly the Developer option to access by adb will be closed at this point.

1 Like

Could you tell if having “Samsung original binary installed” is good or bad? We don’t know what you were trying to tell us by it. We don’t know much about Samsung systems :frowning:

Grandfather says that does not have a Google account, but maybe he does not know he has one. Since we got the phone, we didn’t add a Google account to it, because the phone does not go past the loading screen.

I checked it again with the grandfather, and he said that he left the phone at home on a table, and when he came back, the phone didn’t work anymore.

We tried pulling files from the device just in case if the Developer option is enabled, but we get this message

Could you tell us what software we need for it? We could not find this info when we searched online :frowning:

“Samsung original binary installed” is saying to me that when you used Odin you flashed a stock ROM rather that a custom recovery like TWRP. You say

We got the right firmware version for the right region.

This represents the “Samsung original binary”.

So this is now in charge, sadly, and not /e/.

Your image shows what I rather expected adb not working.

You probably know that the command

adb devices

might give a more positive indication of the status.

A trick you might try is to issue adb devices and attempt to boot into Recovery mode and Download mode and switch between them, just in case the device will respond.

This is highly unlikely though especially as Factory Reset Protection is attempting to secure the device against hostile actors !

I suggest you do some reading to understand what Factory Reset Protection is.

My warning last time was that if you bypass FRP you will for certain delete all history in the phone (it may of course already be gone).

1 Like

Thank you for the explanation.

We have tried the command:
adb devices

It outputted:

  • daemon not running; starting now at tcp:5037
  • daemon started successfully
    List of devices attached

And then nothing, please see the Screenshot

We tried it both when the device was:

  • Download Mode
  • turned on regularly, with triggered the following message
    “An error has occurred while updating the device software. Use the emergency recovery function in the Smart Switch PC Software.”

Please, see a Screenshot

We downloaded the Smart Switch, and when tried Emergency Recovery and Device Initialization modes in it, they both mentioned that all data will be lost, which was not what we were looking for :frowning:

Tomorrow, we are going to visit our grandparents. I was hoping to have good news for them about the phone, but I was not able to recover the images.

Is there anything else that we could try?

In trying to think of an answer today I am sorry but I am out of ideas. The action proposed by Samsung will definitely delete the photos. I have really no idea what the exact chances are that the photos remain.

Because there is a possibility you could wind back (I can’t think how, right now) or you could have the photos extracted “professionally” I would avoid (if practical) doing the delete mentioned by Samsung.

Remember that the guidance on the phone is always to get you back in the Samsung fold. So you don’t have to take that path.

You might feel like disclosing your approx location in case anyone would be in a position to try to help – idk)

No problem. Thank you for all the help that you have provided us with during the last few months. We really appreciate it. Without you, we would have been completely lost! You are awesome!

1 Like

If you might still be pursuing this and you are more familiar with a Mac, you might have a means of connecting with the phone like this Samsung S7 Edge fail to open recovery_cause(No such file or directory) loop - #9 by aibd - or did you try and fail?