Samsung S8 - Cannot install TWRP

I have an S8 dreamlte (european version) where I just can’t manage to install TWRP.
I tried it on linux with heimdall and just to be sure also on Win10 with Odin but I receive the following error message:
ERROR: Partition “ECOVERY” does not exist in the specified PIT.


Session begun.
Downloading device’s PIT file…
PIT file download successful.

ERROR: Partition “ECOVERY” does not exist in the specified PIT.
Ending session…
Rebooting device…
Releasing device interface…

heimdall print-pit

heimdall flash --RECOVERY twrp.X.X.x-x-dreamlte.img --no-reboot


The command I’ve used is

./heimdall flash -RECOVERY twrp-3.3.1-2-dreamlte.img.tar //and version 3.5.x

So no, that is not the problem.

What I’ve forgot to mention.
Just to be sure I’ve downloaded the recommended vendors27 file but I wasn’t able to sideload it successfully (“footer wrong” message).

Any ideas?

use the .IMG file with Heimdall, --no-reboot
.IMG.TAR file is for using with Odin unselect auto-reboot

Be sure reboot to recovery after format /data in TWRP : go back to the main menu tap reboot and choose recovery

Not sure if vendors27 is needed with android 10

Hi again and thank you .
I have tried both (*.img and *.tar) to be sure.
So no again.
The S8 is on the latest official system and patch level.

Check and compare your steps to this detailled guide

Merck Piero,
it worked now.
Solution was: Heimfall as ZIP download (ubuntu20.04) was the reason. As soon as i installed the same package (identical Version) with apt install the “ecovery” failure was gone

In fact, I’m writing this reply with /e/ on the S8

Could you be clearer please ? It will help others futur users

The official instructions for S8 show a link to to run them without installation.
Your generic Samsung instructions describe the installation of heimdall with APT.
Apparently even if the version of Heimdall was the same, something was missing that came automatically during the installation over debian/ubuntus package manager.

To be sure to be efficient with the “without installation” solution, you have to put the all the downloaded files in the same folder where adb and heimdall binary file are, and open a terminal from there.
OR add their path to your shell
as i understood

I’m running OpenSuSE Tumbleweed and found that it was reading -R as “recursive” and snipping it from RECOVERY which was generating the "ECOVERY’ problem.

When I typed: # heimdall flash -RRECOVERY twrp.img
it worked.