Samsung S9+ usb network tethering broken

USB tethering doesn’t work with my S9+ & Laptop with Ubuntu 20.04.
When usb is connected a device shows up, but no IP address is allocated. The connection is stuck at “connecting”.

The laptop end works fine when I connect a different phone with LineageOS installed.

Any hints about what is wrong? Does usb tethering work on your S9+ ?


(build number e_star2lte-userdebug 10 QQ3A.200805.001 eng.root.20210529.154710)


Still the case with 20210828 release.
BTW wifi hotspot works fine.

Any chance this has the same cause? Moto G5: can't start wifi hotspot - #2 by padynx

Good thought, but no. Data saver is off. Wifi hotspot is working fine.

I just updated OS to latest 20211027.081908, still not working.

The connection is made at the hardware level, but the interface doesn’t receive an IP address.

ip addr -> 9: usb0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UNKNOWN group default qlen 1000
    link/ether 8e:30:4d:8f:10:64 brd ff:ff:ff:ff:ff:ff

No inet addresses listed.

If I select File transfer, that also works fine, so I know the usb cable etc. is working properly.

Hmmm … a search for
mtu 1500 qdisc fq_codel state UNKNOWN
reveals an awful lot of “don’t knows”, specifically from the PC end, maybe you would recognise some ifconfig issue that could apply? deprecated!

Edit: I do actually have operstate unknown, I thought the connection was a bit flaky, but does seem to be working ok now. I did this.

ls  /sys/class/net/
enp0s29f7u1  enp2s0  lo  wlp3s0 	# where enp0s29f7u1 is my Samsung

ip link show
14: enp0s29f7u1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UNKNOWN mode DEFAULT group default qlen 1000
    link/ether 88:xx:00.77:22:ff brd ff:ff:ff:ff:ff:ff

cat /sys/class/net/enp0s29f7u1/operstate

sudo ip link set dev enp0s29f7u1 down
sudo ip link set dev enp0s29f7u1 address 88:xx:00.77:22:ff brd ff:ff:ff:ff:ff:ff
sudo ip link set dev enp0s29f7u1 up

cat /sys/class/net/enp0s29f7u1/operstate
unknown						# Remains unknown but is allowing traffic!

More interesting is what ip addr show enp0s29f7u1 returns for you.

Using wireshark I can see my laptop is sending DHCP requests, and getting no response.
Somethink broken in DHCP service on the phone is all I can guess.

My USB Preferences change automatically to “USB tethering”, yours?

Not automatically. I get a notification “Charging this device via USB, tap for more options”
Then list of 5 options including File transfer and USB tethering.

Might you have another PC tou can try tethering on just to make sure it’s not something specific between the s9 and the computer?

I have now tried with another PC, and the result is the same (no address assigned to the interface).
As I mentioned at the start I have used a different phone running lineageos with this PC, and tethering works fine. The other USB options on the S9+ (file xfer, debug etc) all work fine.

is there something to this thread? it misses any sources though: (click for parent comment) - the reporter is using an S9

1 Like

yes, that describes my situation accurately.
Also another reddit comment

Anybody knows if this will be fixed any day soon?
I’m about to switch all to my e phone but I’m highly dependend on that function.
My phone gets even a ip and everything looks fine. but not one bit is transfered…

Thanks for helping!

Hello, I’ve the same issue with my S9. Still no solution ?
Here is my ifconfig -a result :

usb0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500
inet6 fe80::7c5c:c431:92e3:251e prefixlen 64 scopeid 0x20
ether ea:5b:a5:4f:b6:e6 txqueuelen 1000 (Ethernet)
RX packets 0 bytes 0 (0.0 B)
RX errors 14 dropped 0 overruns 0 frame 0
TX packets 16 bytes 3207 (3.1 KiB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

I confirm that the issue still exist with S9+ with the /e/OS last version available and Ubuntu 22.04. The DHCP server on /e/OS does not answer to the DHCP request of the host.

1 Like