Should phone encryption work on S7 /w 0.11?

Hi all

I have a new Galaxy S7 with preinstalled /e/, upgraded from 0.9 to 0.11.

I would like to encrypt the phone (Settings->Security->Encrypt phone). It does ask for the screen pattern and apparently tries to restart (android “robot” appears, then the /e/ animated logo), but after a couple of seconds I am back on the login screen, and the encryption was not done.

Is there another way to do this?

Thanks & best /m


thank you for your purchase and sorry for the issue you are facing.

I was able to successfully encrypt a pre-installed S7 phone but I will try again with the 0.11 version and tell you the resulat.

I formated the phone, I set a pattern and I successfully encrypted the phone.

If after trying again your phone isn’t encrypted, I suggest you to also format the data partition (it will erase all your data) :

  • turn off your phone,
  • long press on Power + Home + volume plus buttons for 10 seconds to enter into TWRP (the recovery mode),
  • if a warning appears, swipe “Swipe to allow modifications”,
  • click on “Wipe” then “Format Data”,
  • enter “yes” and confirm,
  • click on Reboot System (and “Do Not Install” if it appears).

Set your pattern and try to encrypt again.

Following your instructions it now shows “Encrypted” under Settings>Security>Encrypt phone, so it seems to have worked.
It did only take a couple of seconds, though, far from the hour that was announced beforehand :wink:
Is that expected after wiping the data partition?

PS: Now I also can connect the phone via MTP, so my other issue MTP connections not working on 0.11 also seems to have been resolved with this :wink:

Thank you very much for your support! Will definitely keep supporting the project via donations.

Best /m

Indeed it worked :+1:

There was no data to encrypt so yes it’s normal if it was very quick.

Nice to hear.

Thank you for your support :slight_smile:

If you need something else, do not hesitate !