SM-G901F SIM card not detected

I installed eOS on my Samsung Galaxy 5 Plus with these instructions:

Everything worked well - no one warning or error message.

After rebooting the device all things looked well - BUT the SIM card isn’t detected. Before flashing to eOS the SIM card worked without problems. And I tried with an other SIM card of an other provider - same problem.

SIM card has password check switched of. I did the flashing a second time - no change.

Any help?

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

Try to dial *#*#4636#*#* or *#4636#* and change the default used bands according to your country/carrier
Edit : “prefered network type”

Search results for 'SIM card not detected' - /e/ community

I have not list in menu top left “Select frequency range” - the “list” is empty.

Edit : sorry my mistake, it is “prefered network type”

There are only a few entries in the list. Seems that is any connection to the SIM card. IMEI unknown, but SIM seems to be ok - checked with an other smartphone.

So there is no other idea for a solution?

Looks like /efs partition is gone

Saffer is re-flash Samsung stock OS (easier on windows), then reflash TWRP, to re-install /e from scratch

[HOWTO] an Unified Install Guide Project for /e/

1 Like

YES - this way was the right one. After re-flashing to Samsung OS and then flashing again to eOS - SIM card is detected now.