So, I installed /e/ via Easy Installer on Galaxy S9+ but now it's on Android 8.1?

Hello!

First of all, I’m a novice when it comes to flashing devices. I wanted to free myself from Google and therefore decided to use /e/.

I installed the /e/ OS on my Samsung Galaxy S9+ today, which was running on Android 10, using the Easy installer (snap version) on opensuse Linux.
After the seemingly successful installation, I now have /e/ OS running but this appears to be a “downgrade” to Android 8.1 as a base - this wasn’t clear during the installation at all. There was no information about which version was installed. If I look into the Snap folder and then ‘Sources’ it also only mentions “e-latest-star2lte”.
How do I now get the latest version?
Can I use this Guide to upgrade from 8.1 to 10 (Q) without being on (stock?) Android 10 first?
https://doc.e.foundation/devices/star2lte/upgrade

No !
as this page is written for orthers devices that use fastboot commands.

I am not sure you have to reinstall stock-samsung-android-10 as you already were on this version previously. (easier using windows Odin than Linux Heimdall)

Then compare the steps of this page
https://doc.e.foundation/devices/star2lte/install
(Just don’t care about the vendor patch that was for android-8)
To the detailed steps of this illustrated guide
/[HOWTO] install /e/ on a Samsung device from a GNU/Linux PC successfully

1 Like

Qu’affichent les infos sur la version de bande de base (modem) dans les paramètres a propos de l’appareil ?

I am not sure that I understand you correctly.
The Easy Installer has TWRP installed, so you could possibly do something with it?
These fastboot commands, aren’t they part of “android-tools”? They are available for opensuse in the OBS repos (see openSUSE Software).

Qu’affichent les infos sur la version de bande de base (modem) dans les paramètres a propos de l’appareil ?
Translation: What does the baseband (modem) version info show in the About Settings?

G965FXXUFFUE1

Le easy-installer a probablement flashé le fichier modifié "vendor.img” évoqué dans la documentation (permettait d’installer /e/oreo par dessus un Android 8, 9, 10)
Il posera problème pour un fonctionnement avec /e/Q

Peut-être peux-tu extraire du firmware Samsung Android 10, le nouveau vendor.img et le flasher avec TWRP ( ou Heimdall ) vers la partition prévue (VENDOR), avant d’installer /e/.

Sinon tu devra réinstaller le firmware Samsung complet, ce qui paraît plus sûr ( plus clair en tout cas, mais fastidieux si tu n’as pas accès a windows )
Avant d’installer TWRP, le patch de decryption et /e/ pour finir

Translation: Maybe you can extract from the Samsung Android 10 firmware, the new vendor.img and flash it with TWRP ( or Heimdall ) to the intended partition (VENDOR),
Otherwise you’ll have to reinstall the complete Samsung firmware, which seems safer ( clearer anyway )

OK then I would rather choose the safe variant and reinstall the entire Samsung firmware…
Then once I’m on (stock) Android 10, I can try the detailed guide you posted instead of using the Easy Installer.
How do I get the Samsung firmware back on the phone?

I have Windows available, on a second Hard drive so that shouldn’t be the issue.

using Odin

do you know your CSC code ?

1 Like

Hi @Xenthos welcome,

Oreo is quite a good OS, and you have the stable /e/ version.

Are there some Android 10 features you really need?

It is a complicated position. I recommend you stick with Oreo for a week, while you get your bearings. :slight_smile:

1 Like

Ok via Odin on Windows I suppose.

No I don’t know my CSC code… Something out of Germany I think.
It’s not carrier locked, so I can use DBT?

1 Like

You can choose DBT, it is lighter as it is free of carrier’s adds

You can find your CSC code there
IMEI CHECK - Free IMEI Checker Online | IMEICheck.com

1 Like

ok I tried odin but in download mode I get a red error message and it doesn’t seem to do anything after that.
SW REV. CHECK FAIL (BOOTLOADER) DEVICE : 15, BINARY : 12

I don’t know what I’m doing wrong …
I’m using Odin3_v3.14.4; Samsung-USB-Driver-v1_7_23_0 && this firmware (DBT) SM-G965F_2_20201012211233_hme8eekytx_fac

the Bootloader file you tried to flash is older than the one in your device

it is G965F XXU C
you need minimum G965F XXU F or later

Should I skip the BL file in Odin then?

OK that explains it then but… unfortunately I can not find a firmware with a suitable version on the site

you can’t !

but try this under linux :

open the AP_folder.tar.md5
extract the vendor.img,
Boot the device in TWRP mode and plug it to the PC.
copy/paste the vendor.img into your device storage
using TWRP, install the right vendor.img
then using TWRP install /e/.zip

if that don’t work, i am thinking about reinitialising your Bootloader level with a “combination”

in TWRP: Install → Install Image → vendor.img → Select target partition?
Now I get to choose:
System image
boot
recovery
vendor image
carrier configs

Don’t know which one, best guess would be vendor (???)

In your guide on " /[HOWTO] install /e/ on a Samsung device from a GNU/Linux PC successfully" you mentioned that

twrp version 3.4.0-0 is designed for android 10/Q don’t choose it

currently it’s running 3.2.3-0, can I even install the /e/ Q with that?

1 Like

3.2.x-x was designed for devices shipped with android 8

try and see

All right, it worked!

I chose vendor image for the first flash, then moved the .zip file of the Q version (dev branch /e/ image ROM download ) on the internal storage of the phone and installed that.
Reboot. Now it’s on Android 10

However, everything is sooooo smaaaaaaalll

BUT ok, that will have to wait for a fix later…

BTW will I need to update TWRP in the future? Will that work with future updates?

Thanks a lot for your help!

something’s missing ? What is sooo smaaall ? is it abnormal ? or you are just surprised ?

any idea ? it is not a "G965FXXUFFUE1_vendor-file" !

do you want an cleaner install ?

Please modify tittle…