So, I installed /e/ via Easy Installer on Galaxy S9+ but now it's on Android 8.1?

Translation: Maybe you can extract from the Samsung Android 10 firmware, the new vendor.img and flash it with TWRP ( or Heimdall ) to the intended partition (VENDOR),
Otherwise you’ll have to reinstall the complete Samsung firmware, which seems safer ( clearer anyway )

OK then I would rather choose the safe variant and reinstall the entire Samsung firmware…
Then once I’m on (stock) Android 10, I can try the detailed guide you posted instead of using the Easy Installer.
How do I get the Samsung firmware back on the phone?

I have Windows available, on a second Hard drive so that shouldn’t be the issue.

using Odin

do you know your CSC code ?

1 Like

Hi @Xenthos welcome,

Oreo is quite a good OS, and you have the stable /e/ version.

Are there some Android 10 features you really need?

It is a complicated position. I recommend you stick with Oreo for a week, while you get your bearings. :slight_smile:

1 Like

Ok via Odin on Windows I suppose.

No I don’t know my CSC code… Something out of Germany I think.
It’s not carrier locked, so I can use DBT?

1 Like

You can choose DBT, it is lighter as it is free of carrier’s adds

You can find your CSC code there
IMEI CHECK - Free IMEI Checker Online | IMEICheck.com

1 Like

ok I tried odin but in download mode I get a red error message and it doesn’t seem to do anything after that.
SW REV. CHECK FAIL (BOOTLOADER) DEVICE : 15, BINARY : 12

I don’t know what I’m doing wrong …
I’m using Odin3_v3.14.4; Samsung-USB-Driver-v1_7_23_0 && this firmware (DBT) SM-G965F_2_20201012211233_hme8eekytx_fac

the Bootloader file you tried to flash is older than the one in your device

it is G965F XXU C
you need minimum G965F XXU F or later

Should I skip the BL file in Odin then?

OK that explains it then but… unfortunately I can not find a firmware with a suitable version on the site

you can’t !

but try this under linux :

open the AP_folder.tar.md5
extract the vendor.img,
Boot the device in TWRP mode and plug it to the PC.
copy/paste the vendor.img into your device storage
using TWRP, install the right vendor.img
then using TWRP install /e/.zip

if that don’t work, i am thinking about reinitialising your Bootloader level with a “combination”

in TWRP: Install → Install Image → vendor.img → Select target partition?
Now I get to choose:
System image
boot
recovery
vendor image
carrier configs

Don’t know which one, best guess would be vendor (???)

In your guide on " /[HOWTO] install /e/ on a Samsung device from a GNU/Linux PC successfully" you mentioned that

twrp version 3.4.0-0 is designed for android 10/Q don’t choose it

currently it’s running 3.2.3-0, can I even install the /e/ Q with that?

1 Like

3.2.x-x was designed for devices shipped with android 8

try and see

All right, it worked!

I chose vendor image for the first flash, then moved the .zip file of the Q version (dev branch /e/ image ROM download ) on the internal storage of the phone and installed that.
Reboot. Now it’s on Android 10

However, everything is sooooo smaaaaaaalll

BUT ok, that will have to wait for a fix later…

BTW will I need to update TWRP in the future? Will that work with future updates?

Thanks a lot for your help!

something’s missing ? What is sooo smaaall ? is it abnormal ? or you are just surprised ?

any idea ? it is not a "G965FXXUFFUE1_vendor-file" !

do you want an cleaner install ?

Please modify tittle…

Sorry, I was apparently unable to reply to you until several hours later due to restrictions on new forum users… :confused:

Dark mode. :wink:

As far as I can tell, nothing is missing, it was just that the icons and font were extremely small and had to be adjusted manually in the display settings, to the big difference from the previous “Oreo” version.

I don’t understand where you are going with this?
Still I must add that I have taken another firmware for the ‘vendor.img’ as mentioned above and namely the DTM version (SM-G965F_2_202102065705_y7bp6konpr_fac) because according to IMEI that was probably the previous standard and also the firmware was somewhat newer.

On the one hand, I am of course happy that it has now worked at all to install the Q version of /e/ on it after all. Would I like to have a “clean” installation? Of course that would be the absolute non-plus-ultra.

Addition
I have successfully flashed a new firmware to the “stock” Android 10 using Odin. I found the correct firmware here. Galaxy Firmware - Samsung Galaxy S9+ (SM-G965F)
and then I could install newest TWRP and /e/ dev Q version successfully with your HOWTO Guide!
The (7) adb sideload wasn’t working for me, so I did it with, the (8) SDcard method. :slight_smile:

1 Like

happy end …

good to know, thanks

@manoj, could w/e/you host an Android 10 vendor image for the s9 /s9+ device in ecloud.global ?

and recommand thoses steps as a workaround for those who have already OTA updated runned the easy installer on s9/s9+ are desapointed with their Oreo, and are afraid about flashing

if
updated to Samsung-Android-10 on the s9 / s9+ → did the easy installer process [ emulate heimdall + unlock the bootloader + flash twrp to /recovery + format /data + reboot to recovery ? + wipe /system + install dm-verity + vendor 2018 + emulate adb + sideload e-0.17-o-stable from the computer (to /boot and to /system) + wipe /cache and /dalvicARTcache ] = /e/Oreo on the device
Then is
→ boot TWRP → format /data + reboot to recovery + wipe /system → install android 10 based vendor.img → install /e/Q.zip from SDcard (to /system and to /boot) = regular /e/Q on the device ?

1 Like

It would help if the ‘Easy Installer’ would name the version it will install - then if you want a newer version that the installer does not support, you can install it manually. This would have saved me a lot of trial and error, and probably others as well.

An issue has been created for this on the gitlab

2 Likes

This new gitlab issue is similar to #2663 - A resource to show the status of Easy Installer which resulted in version of /e/ installed. Unfortunate the OP did not see this first.

The newly introduced hashtag #community:lists will help readers with their initial searches. It would be nice to see a hashtag #getting-started too. :slight_smile: