[Solved] Easy Installer cannot download Fairphone 3 image file

I used the easy installer for 3 fairphones 3 already. It worked very well and I’m very grateful for it. I wanted to do it for a forth, but this time it did not work. The installer wants to download a new e/os image file which fails even after a very long time. I suspect there is something wrong with this new file. Anyone else with this problem? If I understand right I can not use the easy installer with an old version of the image file? (I’m forced to use the latest version)
Thank you in advance!

Here the name of the file in question

hello @Nilpferd,
welcome to this Forum.

what is the actual version of the android system installed on your device ?

in theory, you should rename the old one as “tatest” and replace the downloaded file in the dedicated folder to try, but be carefull about security patch date included in the install relatively to the one already installed on the device…

1 Like

You might check out recent forum posts in the easy-installer and Easy Installer sections.

It seems a recurring problem, keywords being “Download fails” or “Try again”. I suggest you study one or two recent posts if they seem a bit like yours, perhaps dig out the log Howto troubleshoot issues with the easy-installer.

Well, when downloading a new ROM, one would generally want the latest.

The current issue seems to involve programmatically finding latest is a problem for Easy Installer either locally and / or remotely at selection of files from /e/ servers.

1 Like

Thank you! It was Android 11. Now I tried with Android 13 (that’s the Version of the other FP3’s) No luck for now.
I found the old file that worked, but I don’t see how I can make the installer use it.

Here is a link for a log file. Maybe somebody understands the problem better with this?

Thank you so much. I did not find those posts. I see there are a few things I can try. I’ll do that.

Thank you for adding a log file ! Just in a very quick look … line 152:

compare checksum: 1698472dcd5eeb87292e33d27cc94b392b20ff89c04ea5e231d340d362399f8a vs 037a83e1dfd1900d8635d380dc983dd0af0e4db594306e1026beb26013f0f15e

This draws attention to a “checksum mismatch”. This thread contains quite a lot of detail … Installer stops after downloading, no error or acknowledgement just a "Try again" button

1 Like

Thank you! I tried the easiest solution (delete all files in %LOCALAPPDATA%\easy-installer) That actually worked!

1 Like